motorola-addison: new device (Moto Z Play) (MR 1577)
This commit is contained in:
parent
dde1d81a85
commit
7d1d03164b
6 changed files with 5299 additions and 0 deletions
22
device/testing/device-motorola-addison/APKBUILD
Normal file
22
device/testing/device-motorola-addison/APKBUILD
Normal file
|
@ -0,0 +1,22 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-motorola-addison
|
||||
pkgdesc="Motorola Moto Z Play"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="aarch64"
|
||||
options="!check !archcheck"
|
||||
depends="postmarketos-base linux-motorola-addison mkbootimg mesa-dri-gallium"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="1c263920ff593e64f4711ebbd2a98e6f1abf5eb6149f53f79708ba15b018bbe09a56889e6b10261cedaa24709d9592f9080c995e60ae95b81dcb11109e9cd95f deviceinfo"
|
29
device/testing/device-motorola-addison/deviceinfo
Normal file
29
device/testing/device-motorola-addison/deviceinfo
Normal file
|
@ -0,0 +1,29 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Motorola Moto Z Play"
|
||||
deviceinfo_manufacturer="Motorola"
|
||||
deviceinfo_codename="motorola-addison"
|
||||
deviceinfo_year="2016"
|
||||
deviceinfo_arch="aarch64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="handset"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="1080"
|
||||
deviceinfo_screen_height="1920"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="console=ttyHSL0,115200,n8 androidboot.console=ttyHSL0 androidboot.hardware=qcom user_debug=30 msm_rtb.filter=0x237 ehci-hcd.park=3 androidboot.bootdevice=7824900.sdhci lpm_levels.sleep_disabled=1 vmalloc=350M buildvariant=userdebug"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="true"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_offset_base="0x80000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
51
device/testing/linux-motorola-addison/APKBUILD
Normal file
51
device/testing/linux-motorola-addison/APKBUILD
Normal file
|
@ -0,0 +1,51 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm64/configs/addison_defconfig
|
||||
|
||||
pkgname=linux-motorola-addison
|
||||
pkgver=3.18.120
|
||||
pkgrel=0
|
||||
pkgdesc="motorola Motorola Moto Z Play kernel fork"
|
||||
arch="aarch64"
|
||||
_carch="arm64"
|
||||
_flavor="motorola-addison"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="bash bc bison devicepkg-dev flex openssl-dev perl dtbtool"
|
||||
|
||||
# Source
|
||||
_repository="artxplay_msm8953_addison"
|
||||
_commit="c2dcd33239fb09ba0f322ee6bfe3a8f1f6329c4c"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/KB-E/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
wireguard.patch
|
||||
gcc10-extern_YYLOC_global_declaration.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
|
||||
# Master DTB (deviceinfo_bootimg_qcdt)
|
||||
dtbTool -p scripts/dtc/ -o "$_outdir/arch/$_carch/boot"/dt.img "$_outdir/arch/$_carch/boot/"
|
||||
install -Dm644 "$_outdir/arch/$_carch/boot"/dt.img "$pkgdir"/boot/dt.img
|
||||
}
|
||||
|
||||
sha512sums="5943439e2951c8857a3a41c806cd6f607c78872648d7826c1c4aa67b1c6bfb9500516899e9f7fd73bc7bf8e746ccb0fdb0712e047e8e53d28930121e6fe93cc4 linux-motorola-addison-c2dcd33239fb09ba0f322ee6bfe3a8f1f6329c4c.tar.gz
|
||||
aa6aff7d85ed811389169df4b0c770bbc04be3a040cb609c28e1b05af0d4ecb69f505b0480659645d1c78d2c523a18ca4184c9156d22c8b5b4a6f27364c4bddc config-motorola-addison.aarch64
|
||||
638c4b9887f14f0c6cbbd7bb042cc9ef142795a3e62e4f2e5ef8c4489f2d1129d0aa3d0ee1c20fdd8c08b56bee1405aca4fb65a882124b6cc3c31fd2bc90a8ba wireguard.patch
|
||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch"
|
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
13
device/testing/linux-motorola-addison/wireguard.patch
Normal file
13
device/testing/linux-motorola-addison/wireguard.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
removes wireguard from kconfig because that directory doesn't exist
|
||||
diff --git a/net/Kconfig b/net/Kconfig
|
||||
index 0d521b7e..4dd633e3 100644
|
||||
--- a/net/Kconfig
|
||||
+++ b/net/Kconfig
|
||||
@@ -87,7 +87,6 @@ config INET
|
||||
Short answer: say Y.
|
||||
|
||||
if INET
|
||||
-source "net/wireguard/Kconfig"
|
||||
source "net/ipv4/Kconfig"
|
||||
source "net/ipv6/Kconfig"
|
||||
source "net/netlabel/Kconfig"
|
Loading…
Reference in a new issue