Added new device: samsung-espresso10 (Samsung Galaxy Tab 2 10.1) (#1027)
This commit is contained in:
parent
2f9ef89189
commit
7bce1ef049
7 changed files with 2996 additions and 0 deletions
22
device/device-samsung-espresso10/APKBUILD
Normal file
22
device/device-samsung-espresso10/APKBUILD
Normal file
|
@ -0,0 +1,22 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname="device-samsung-espresso10"
|
||||
pkgdesc="Samsung Galaxy Tab 2 (10.1 inch)"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="noarch"
|
||||
options="!check"
|
||||
depends="linux-samsung-espresso10 mkbootimg"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="db52de8c130d502aa662a39684012949edfa6169a86d7fee987d1e3f7d9522f4357689fc5a68e4c451989330451e963e221b4b4fa3999c96becf81a3fc2db991 deviceinfo"
|
34
device/device-samsung-espresso10/deviceinfo
Normal file
34
device/device-samsung-espresso10/deviceinfo
Normal file
|
@ -0,0 +1,34 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Galaxy Tab 2 (10.1 inch)"
|
||||
deviceinfo_manufacturer="Samsung"
|
||||
deviceinfo_date=""
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_external_disk_install="false"
|
||||
deviceinfo_arch="armhf"
|
||||
|
||||
# Device related
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_disk="true"
|
||||
deviceinfo_screen_width="1280"
|
||||
deviceinfo_screen_height="800"
|
||||
deviceinfo_dev_touchscreen=""
|
||||
deviceinfo_dev_touchscreen_calibration=""
|
||||
deviceinfo_dev_keyboard=""
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="heimdall-bootimg"
|
||||
deviceinfo_kernel_cmdline="androidboot.hardware=espresso"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_flash_offset_base="0x40000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_flash_heimdall_partition_system="FACTORYFS"
|
||||
|
|
@ -0,0 +1,27 @@
|
|||
From 7041266a29e9681fc13034f345cdcc269d672f83 Mon Sep 17 00:00:00 2001
|
||||
From: Alejandro Mery <amery@geeks.cl>
|
||||
Date: Fri, 11 May 2012 23:57:15 +0200
|
||||
Subject: [PATCH] security: fixed to build with ANDROID_PARANOID_NETWORK
|
||||
disabled
|
||||
|
||||
---
|
||||
security/commoncap.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/security/commoncap.c b/security/commoncap.c
|
||||
index ccfe568b396fb..8bfbd13497467 100644
|
||||
--- a/security/commoncap.c
|
||||
+++ b/security/commoncap.c
|
||||
@@ -88,10 +88,12 @@ EXPORT_SYMBOL(cap_netlink_recv);
|
||||
int cap_capable(struct task_struct *tsk, const struct cred *cred,
|
||||
struct user_namespace *targ_ns, int cap, int audit)
|
||||
{
|
||||
+#ifdef CONFIG_ANDROID_PARANOID_NETWORK
|
||||
if (cap == CAP_NET_RAW && in_egroup_p(AID_NET_RAW))
|
||||
return 0;
|
||||
if (cap == CAP_NET_ADMIN && in_egroup_p(AID_NET_ADMIN))
|
||||
return 0;
|
||||
+#endif
|
||||
|
||||
for (;;) {
|
||||
/* The creator of the user namespace has all caps. */
|
|
@ -0,0 +1,25 @@
|
|||
From e11f599d4985fdf516733423cf086e6454902e50 Mon Sep 17 00:00:00 2001
|
||||
From: Robill Tian Supatrio <rsupatrio@android-x86.org>
|
||||
Date: Sun, 8 Jan 2012 12:51:32 +0800
|
||||
Subject: [PATCH] Fixed compilation error for rndis_bind_config.
|
||||
|
||||
---
|
||||
drivers/usb/gadget/ether.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/drivers/usb/gadget/ether.c b/drivers/usb/gadget/ether.c
|
||||
index 1690c9d..53ee2c5 100644
|
||||
--- a/drivers/usb/gadget/ether.c
|
||||
+++ b/drivers/usb/gadget/ether.c
|
||||
@@ -246,7 +246,7 @@ static int __init rndis_do_config(struct usb_configuration *c)
|
||||
c->bmAttributes |= USB_CONFIG_ATT_WAKEUP;
|
||||
}
|
||||
|
||||
- return rndis_bind_config(c, hostaddr);
|
||||
+ return rndis_bind_config(c, hostaddr, 12345, "android-arm");
|
||||
}
|
||||
|
||||
static struct usb_configuration rndis_config_driver = {
|
||||
--
|
||||
1.7.4.1
|
||||
|
84
device/linux-samsung-espresso10/APKBUILD
Normal file
84
device/linux-samsung-espresso10/APKBUILD
Normal file
|
@ -0,0 +1,84 @@
|
|||
# Kernel config based on: arch/arm/configs/espresso_defconfig
|
||||
|
||||
pkgname="linux-samsung-espresso10"
|
||||
pkgver=3.0.101
|
||||
pkgrel=0
|
||||
pkgdesc="Samsung Galaxy Tab 2 (10.1 inch) kernel fork"
|
||||
arch="armhf"
|
||||
_carch="arm"
|
||||
_flavor="samsung-espresso10"
|
||||
url="https://kernel.org"
|
||||
license="GPL2"
|
||||
options="!strip !check !tracedeps"
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev"
|
||||
HOSTCC="${CC:-gcc}"
|
||||
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||
|
||||
# Source - Use omnirom kernel (seems to have more fixes)
|
||||
_repository="android_kernel_samsung_espresso10"
|
||||
_commit="3d5cf7e95d29d32623747b7cae37bd7c1db151ff"
|
||||
_config="config-${_flavor}.${arch}"
|
||||
source="
|
||||
|
||||
$pkgname-$_commit.tar.gz::https://github.com/omnirom/${_repository}/archive/${_commit}.tar.gz
|
||||
$_config
|
||||
compiler-gcc6.h
|
||||
01_fix_aid_net_on_apn_disable.patch
|
||||
02-Fixed-compilation-error-for-rndis_bind_config.patch
|
||||
"
|
||||
builddir="$srcdir/${_repository}-${_commit}"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
|
||||
# gcc6 support
|
||||
cp -v "$srcdir/compiler-gcc6.h" "$builddir/include/linux/"
|
||||
|
||||
# Remove -Werror from all makefiles
|
||||
find . -type f -name Makefile -print0 | \
|
||||
xargs -0 sed -i 's/-Werror-/-W/g'
|
||||
find . -type f -name Makefile -print0 | \
|
||||
xargs -0 sed -i 's/-Werror//g'
|
||||
|
||||
# Prepare kernel config ('yes ""' for kernels lacking olddefconfig)
|
||||
cp "$srcdir"/$_config "$builddir"/.config
|
||||
yes "" | make ARCH="$_carch" HOSTCC="$HOSTCC" oldconfig
|
||||
}
|
||||
|
||||
menuconfig() {
|
||||
cd "$builddir"
|
||||
make ARCH="$_carch" menuconfig
|
||||
cp .config "$startdir"/$_config
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
# kernel.release
|
||||
install -D "$builddir/include/config/kernel.release" \
|
||||
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||
|
||||
# zImage (find the right one)
|
||||
cd "$builddir/arch/$_carch/boot"
|
||||
_target="$pkgdir/boot/vmlinuz-$_flavor"
|
||||
for _zimg in zImage-dtb Image.gz-dtb *zImage Image; do
|
||||
[ -e "$_zimg" ] || continue
|
||||
msg "zImage found: $_zimg"
|
||||
install -Dm644 "$_zimg" "$_target"
|
||||
break
|
||||
done
|
||||
if ! [ -e "$_target" ]; then
|
||||
error "Could not find zImage in $PWD!"
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
sha512sums="3c869ec19a36e97c9ed63952d5959205ed3f4121d51d79e22b40596ef61d1601ef0a0bf13362c0f5451867f4b59d0a8511d6870fb6c9948a609140df1579fd27 linux-samsung-espresso10-3d5cf7e95d29d32623747b7cae37bd7c1db151ff.tar.gz
|
||||
e2e28094b0ea57156e0484d1319266852b122b3599e37dce7a48dd05dd574636317acb7ab90c869c91a9eec6b608e7c48cad806e482d59f515d2b8e9cdbf1a95 config-samsung-espresso10.armhf
|
||||
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h
|
||||
1cae09c775d787e877f82cb164b5d68530f4bd9b108b7abaf8192bd85a3d8975456762ce9f563fa766b1c03519e09ef93e177fd6972e439e4aa0c3a5709ea691 01_fix_aid_net_on_apn_disable.patch
|
||||
822e41a0c4b4f00e1f9e5e847378504e9a4b113a360b73e72998e70cc5a47cac42489cfd2475f6924e237dfe4791f19a20169c224680ab11a7c272a866e361ac 02-Fixed-compilation-error-for-rndis_bind_config.patch"
|
69
device/linux-samsung-espresso10/compiler-gcc6.h
Normal file
69
device/linux-samsung-espresso10/compiler-gcc6.h
Normal file
|
@ -0,0 +1,69 @@
|
|||
// SOURCE:
|
||||
// https://github.com/NextThingCo/CHIP-u-boot/issues/10#issuecomment-287515505
|
||||
|
||||
#ifndef __LINUX_COMPILER_H
|
||||
#error "Please don't include <linux/compiler-gcc6.h> directly, include <linux/compiler.h> instead."
|
||||
#endif
|
||||
|
||||
#define __used __attribute__((__used__))
|
||||
#define __must_check __attribute__((warn_unused_result))
|
||||
#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||
|
||||
/* Mark functions as cold. gcc will assume any path leading to a call
|
||||
to them will be unlikely. This means a lot of manual unlikely()s
|
||||
are unnecessary now for any paths leading to the usual suspects
|
||||
like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||
older compilers]
|
||||
|
||||
Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||
in the preprocessor, but we can live with this because they're unreleased.
|
||||
Maketime probing would be overkill here.
|
||||
|
||||
gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||
a special section, but I don't see any sense in this right now in
|
||||
the kernel context */
|
||||
#define __cold __attribute__((__cold__))
|
||||
|
||||
#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||
|
||||
#ifndef __CHECKER__
|
||||
# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||
# define __compiletime_error(message) __attribute__((error(message)))
|
||||
#endif /* __CHECKER__ */
|
||||
|
||||
/*
|
||||
* Mark a position in code as unreachable. This can be used to
|
||||
* suppress control flow warnings after asm blocks that transfer
|
||||
* control elsewhere.
|
||||
*
|
||||
* Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||
* this in the preprocessor, but we can live with this because they're
|
||||
* unreleased. Really, we need to have autoconf for the kernel.
|
||||
*/
|
||||
#define unreachable() __builtin_unreachable()
|
||||
|
||||
/* Mark a function definition as prohibited from being cloned. */
|
||||
#define __noclone __attribute__((__noclone__))
|
||||
|
||||
/*
|
||||
* Tell the optimizer that something else uses this function or variable.
|
||||
*/
|
||||
#define __visible __attribute__((externally_visible))
|
||||
|
||||
/*
|
||||
* GCC 'asm goto' miscompiles certain code sequences:
|
||||
*
|
||||
* http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||
*
|
||||
* Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||
*
|
||||
* (asm goto is automatically volatile - the naming reflects this.)
|
||||
*/
|
||||
#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||
|
||||
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||
#define __HAVE_BUILTIN_BSWAP32__
|
||||
#define __HAVE_BUILTIN_BSWAP64__
|
||||
#define __HAVE_BUILTIN_BSWAP16__
|
||||
#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||
|
2735
device/linux-samsung-espresso10/config-samsung-espresso10.armhf
Normal file
2735
device/linux-samsung-espresso10/config-samsung-espresso10.armhf
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue