temp/qt5-qtsvg: fork from alpine to revert broken patch (MR 2104)

Fix build error:

CMake Error at /usr/lib/cmake/Qt5Svg/Qt5SvgConfig.cmake:111 (find_package):
  Could not find a configuration file for package "Qt5Widgets" that is
  compatible with requested version "5.15.3".
  The following configuration files were considered but not accepted:
    /usr/lib/cmake/Qt5Widgets/Qt5WidgetsConfig.cmake, version: 5.15.2

MR for Alpine:
https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/20307

[ci:skip-vercheck]: pkgrel>0 on purpose
This commit is contained in:
Oliver Smith 2021-04-08 23:08:54 +02:00
parent 7d5b119b0e
commit 7a6dc2d081
3 changed files with 169 additions and 0 deletions

View file

@ -0,0 +1,69 @@
From e82cf6e005d43be9c49fb3f931433e5d508534f0 Mon Sep 17 00:00:00 2001
From: Antti Kokko <antti.kokko@qt.io>
Date: Thu, 15 Oct 2020 09:53:19 +0300
Subject: [PATCH 1/5] Add changes file for Qt 5.12.10
Change-Id: I08a4c977fe1652853e79ea6ce53b071db72b6986
Reviewed-by: Robert Loehning <robert.loehning@qt.io>
(cherry picked from commit 261ed79b966065f4ce398f1a701be6298dd49be9)
Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
---
dist/changes-5.12.10 | 46 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)
create mode 100644 dist/changes-5.12.10
diff --git a/dist/changes-5.12.10 b/dist/changes-5.12.10
new file mode 100644
index 0000000..b8f8f69
--- /dev/null
+++ b/dist/changes-5.12.10
@@ -0,0 +1,46 @@
+Qt 5.12.10 is a bug-fix release. It maintains both forward and backward
+compatibility (source and binary) with Qt 5.12.9.
+
+For more details, refer to the online documentation included in this
+distribution. The documentation is also available online:
+
+ https://doc.qt.io/qt-5.12/index.html
+
+The Qt version 5.12 series is binary compatible with the 5.11.x series.
+Applications compiled for 5.11 will continue to run with 5.12.
+
+Some of the changes listed in this file include issue tracking numbers
+corresponding to tasks in the Qt Bug Tracker:
+
+ https://bugreports.qt.io/
+
+Each of these identifiers can be entered in the bug tracker to obtain more
+information about a particular change.
+
+****************************************************************************
+* Library *
+****************************************************************************
+
+ - This release fixes a number of cases where input fuzzing has
+ revealed that corrupt or pathological input could result in crashes
+ or undefined behavior:
+ oss-fuzz-23588
+ oss-fuzz-23606
+ oss-fuzz-23633
+ oss-fuzz-23643
+ oss-fuzz-23644
+ oss-fuzz-23731
+ oss-fuzz-24000
+ oss-fuzz-24028
+ oss-fuzz-24131
+ oss-fuzz-24146
+ oss-fuzz-24308
+ oss-fuzz-24611
+ oss-fuzz-24738
+
+Third-Party Code
+----------------
+
+ - XSVG license was re-classified to HPND-sell-variant, "Historical Permission
+ Notice and Disclaimer - sell variant"
+
--
2.31.1

View file

@ -0,0 +1,41 @@
From aceea78cc05ac8ff947cee9de8149b48771781a8 Mon Sep 17 00:00:00 2001
From: Eirik Aavitsland <eirik.aavitsland@qt.io>
Date: Tue, 1 Dec 2020 14:39:59 +0100
Subject: [PATCH 4/5] Improve handling of malformed numeric values in svg files
Catch cases where the input is not containable in a qreal, and avoid
passing on inf values.
Change-Id: I1ab8932d94473916815385240c29e03afb0e0c9e
Reviewed-by: Robert Loehning <robert.loehning@qt.io>
Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
(cherry picked from commit 428d56da9d5ed9bda51f7cc3c144996fb3a6a285)
Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
---
src/svg/qsvghandler.cpp | 3 +++
1 file changed, 3 insertions(+)
diff --git a/src/svg/qsvghandler.cpp b/src/svg/qsvghandler.cpp
index c937254..b3d9aaf 100644
--- a/src/svg/qsvghandler.cpp
+++ b/src/svg/qsvghandler.cpp
@@ -65,6 +65,7 @@
#include "private/qmath_p.h"
#include "float.h"
+#include <cmath>
QT_BEGIN_NAMESPACE
@@ -672,6 +673,8 @@ static qreal toDouble(const QChar *&str)
val = -val;
} else {
val = QByteArray::fromRawData(temp, pos).toDouble();
+ if (qFpClassify(val) != FP_NORMAL)
+ val = 0;
}
return val;
--
2.31.1

59
temp/qt5-qtsvg/APKBUILD Normal file
View file

@ -0,0 +1,59 @@
# Forked from Alpine, revert Bump-version.patch that caused build failures
pkgname=qt5-qtsvg
pkgver=5.15.2
pkgrel=3
pkgdesc="Qt5 - Support for rendering and displaying SVG"
url="https://www.qt.io/developers/"
arch="all"
license="(LGPL-2.0-or-later OR GPL-3.0-only OR GPL-2.0-or-later) AND Qt-GPL-exception-1.0"
makedepends="qt5-qtbase-dev zlib-dev"
subpackages="$pkgname-dev"
builddir="$srcdir/qtsvg-everywhere-src-$pkgver"
case $pkgver in
*_beta*|*_rc*) _rel=development_releases;;
*) _rel=official_releases;;
esac
source="https://download.qt.io/$_rel/qt/${pkgver%.*}/$pkgver/submodules/qtsvg-everywhere-src-$pkgver.tar.xz
0001-Add-changes-file-for-Qt-5.12.10.patch
0003-Improve-handling-of-malformed-numeric-values-in-svg-.patch
"
prepare() {
default_prepare
# qmlplugindump fails for armv7+qemu (pmb#1970). This is purely for
# packager knowledge and doesn't affect runtime, so we can disable it.
if [ "$CARCH" = "armv7" ]; then
for i in $(find -name CMakeLists.txt); do
echo "Disabling ecm_find_qmlmodule in: $i"
sed -i "s/ecm_find_qmlmodule/# ecm_find_qmlmodule/g" "$i"
done
fi
}
build() {
qmake-qt5
make
}
check() {
make check
}
package() {
make INSTALL_ROOT="$pkgdir" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "$pkgdir/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
install -d "$pkgdir"/usr/share/licenses
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
sha512sums="101e9c8fc05b1bb9c4e869564bff8e5723dd35f0ef557185e56e9dc12fdce74c531522c9642cdff639900eccf7ed0e04bfa48142741259697dded990fb481730 qtsvg-everywhere-src-5.15.2.tar.xz
ed2e77abed8e93b10fcc23d6c5b9f08c53fa0cfe2ed36ddb30f8140846238fedcd7e1f9a0c76cc4b8ee2b35f34b34d39d078616c5e8c8b60006166d70d17908c 0001-Add-changes-file-for-Qt-5.12.10.patch
11f4651321f9094599d0dfbe322e403f0139b7322a4c543e3ce5e8fa2b1d5880f2f08ff4898743f697f2ec0e64a3b2102a6e815cc9cdd59f636e24374a5609f9 0003-Improve-handling-of-malformed-numeric-values-in-svg-.patch"