postmarketos-ui-matchbox: drop (!729)

It's unmaintained both on our side and upstream. Nobody stepped up to
maintain it (https://gitlab.com/postmarketOS/pmaports/issues/372), so
let's drop it before it introduces security issues and compilation
problems.
This commit is contained in:
Bart Ribbers 2019-11-08 17:52:35 +01:00 committed by Oliver Smith
parent 156b107929
commit 6ba8b2d7ed
No known key found for this signature in database
GPG key ID: 5AE7F5513E0885CB
20 changed files with 0 additions and 1545 deletions

View file

@ -1,5 +0,0 @@
# This file gets removed with postmarketos-ui-matchbox, even if modified!
[Seat:*]
autologin-user=username
autologin-user-timeout=0
autologin-session=matchbox

View file

@ -1,22 +0,0 @@
pkgname=postmarketos-ui-matchbox
pkgver=1
pkgrel=5
pkgdesc="(X11) Very basic user interface for handhelds"
url="https://matchbox-project.org"
arch="noarch"
license="GPL-2.0-only"
depends="matchbox-common matchbox-panel matchbox-desktop matchbox-keyboard matchbox-window-manager xterm xorg-server dbus-x11 mesa-egl gtk+2.0 lightdm-openrc"
install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-deinstall $pkgname.post-upgrade"
source="matchbox.desktop 60-lightdm-autologin.conf"
options="!check"
package() {
install -Dm644 "$srcdir"/matchbox.desktop \
"$pkgdir"/usr/share/xsessions/matchbox.desktop
install -Dm644 "$srcdir"/60-lightdm-autologin.conf \
"$pkgdir"/usr/share/lightdm/lightdm.conf.d/60-autologin.conf
}
sha512sums="1ceae6d4939cdddf14602471f52cf409e4094a81718ef5d7ea83adf5bf3d7ca8d13e15b8a98f99dee54bb8703038ea31abd74ad1fbe8d2c752d5f1a56310f508 matchbox.desktop
366a75dc36b123f184e4a9296784b22fe1b64de278c508e19536c150b44536b653ae819ca449d53f430fb88f9d853e10a2b64dc7aeb39d93ee763b67a13d7e1d 60-lightdm-autologin.conf"

View file

@ -1,11 +0,0 @@
[Desktop Entry]
Name=Matchbox
Name[en]=Matchbox
Comment=This session logs you into Matchbox
Comment[en]=This session logs you into Matchbox
Exec=matchbox-session
TryExec=matchbox-session
Icon=
Type=Application
DesktopNames=Matchbox
Keywords=launch;Matchbox;desktop;session;

View file

@ -1,3 +0,0 @@
#!/bin/sh
rm /usr/share/lightdm/lightdm.conf.d/60-autologin.conf

View file

@ -1,5 +0,0 @@
#!/bin/sh
sed -i "s/username/$(getent passwd 10000 | cut -d: -f1)/g" /usr/share/lightdm/lightdm.conf.d/60-autologin.conf
rc-update add lightdm default

View file

@ -1,5 +0,0 @@
#!/bin/sh
sed -i "s/username/$(getent passwd 10000 | cut -d: -f1)/g" /usr/share/lightdm/lightdm.conf.d/60-autologin.conf
rc-update add lightdm default

View file

@ -1,3 +0,0 @@
#!/bin/sh
rc-update del lightdm

View file

@ -1,49 +0,0 @@
# Contributor: Duncan Guthrie <dguthrie@posteo.net>
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=libmatchbox
pkgver=1.12
pkgrel=1
pkgdesc="Library for matchbox window manager"
url="http://matchbox-project.org"
arch="all"
license="GPL-2.0-only"
source="$pkgname-$pkgver.tar.gz::https://git.yoctoproject.org/cgit/cgit.cgi/$pkgname/snapshot/$pkgname-$pkgver.tar.gz
external-xsettings.patch
libmb.pc.in.patch"
depends="pango glib jpeg libpng libx11 libxext libxft libxsettings libxsettings-client"
makedepends="autoconf automake libtool libx11-dev libxext-dev libxft-dev pango-dev doxygen libjpeg-turbo-dev libxsettings-dev libxsettings-client-dev"
subpackages="$pkgname-dev $pkgname-dbg"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
autoreconf --install
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
--enable-pango \
--enable-doxygen-docs \
--enable-jpeg \
--enable-unit-tests \
--enable-debug \
LIBS="-lXsettings-client -lX11"
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="28392757960a41272e3ac32b8698549be6ee923a79f17a3b648abd59efcf5bda3eaa6de18337e1920a5ca602d7c8f3031c5418a4ce44d6c39376c70aeb49267a libmatchbox-1.12.tar.gz
d13c3cea22bdb99ea14ec39bad0eac48278cec4d5b013e97dfff7c431160d31bd6b0e048f72816fbc367b232c0f2b7da7ef747058b8e373514831199d0a34103 external-xsettings.patch
c548b4bc8ff9a596233d46b72b7c4fc8cd942f93f34edf521175ff38423772952d1a1bf4218f2d6319cc912a86908f233b2d7e40c6878db378f52f5557309501 libmb.pc.in.patch"

File diff suppressed because it is too large Load diff

View file

@ -1,14 +0,0 @@
diff -Naur a/libmb.pc.in b/libmb.pc.in
--- a/libmb.pc.in 2016-07-08 11:15:21.000000000 +0100
+++ b/libmb.pc.in 2018-05-08 04:24:57.673377262 +0100
@@ -7,6 +7,8 @@
Description: Utility Library used by Matchbox utilities.
Version: @VERSION@
-Requires: @XLIBS_REQUIRED@ @PANGO_REQUIRED@ @PNG_REQUIRED@ @XFT_REQUIRED@
-Libs: -L${libdir} -lmb @MB_EXTRA_LIBS@
+Requires.private: @XLIBS_REQUIRED@ @PANGO_REQUIRED@ @PNG_REQUIRED@
+Requires: libxsettings-client
+Libs: -L${libdir} -lmb
+Libs.private: @MB_EXTRA_LIBS@
Cflags: -I${includedir} @MB_EXTRA_CFLAGS@

View file

@ -1,25 +0,0 @@
--- a/Makefile.am 2018-04-16 09:15:05.172748991 +0100
+++ b/Makefile.am 2018-04-16 09:15:43.009935778 +0100
@@ -1,7 +1,7 @@
SUBDIRS = doc
-source_h = xsettings-client.h xsettings-common.h
-source_c = xsettings-client.c xsettings-common.c
+source_h = xsettings-client.h
+source_c = xsettings-client.c
INCLUDES = -I $(includedir) $(X_CFLAGS)
--- a/Makefile.in 2018-04-16 09:15:05.172748991 +0100
+++ b/Makefile.in 2018-04-16 09:16:02.733032247 +0100
@@ -141,8 +141,8 @@
target_alias = @target_alias@
SUBDIRS = doc
-source_h = xsettings-client.h xsettings-common.h
-source_c = xsettings-client.c xsettings-common.c
+source_h = xsettings-client.h
+source_c = xsettings-client.c
INCLUDES = -I $(includedir) $(X_CFLAGS)

View file

@ -1,42 +0,0 @@
# Contributor: Duncan Guthrie <dguthrie@posteo.net>
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=libxsettings-client
pkgver=0.17
pkgrel=0
pkgdesc="Utility functions for the Xsettings protocol"
url="https://standards.freedesktop.org/xsettings-spec/0.5/"
arch="all"
license="GPL-2.0-or-later"
depends="libx11"
makedepends="libx11-dev gtk+2.0-dev"
source="http://http.debian.net/debian/pool/main/libx/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz
01-ignore-xsettings-common-h.patch"
builddir="${srcdir}/${pkgname}-${pkgver}"
options="!check"
subpackages="$pkgname-doc $pkgname-dev"
prepare() {
default_prepare
update_config_sub
update_config_guess
}
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var
make LIBS=-lX11
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="2ea1f1d239fb17f37b2ec7689aca1a848b3faee8052b622f718f9bb0f3e7b174ae5d056c4d8a27ef526ade3e0ad155ebc73de6084b837d7cb5a93bb31f92bfa7 libxsettings-client_0.17.orig.tar.gz
428a76a40ddb9a7fb3d7c461e91cff53148c9856c8a1f231f2d4f0b2b40fd1e6dbef9d67b2f745e728921ae3846f1caa1f85cd537961bbe7421fefe516f6b070 01-ignore-xsettings-common-h.patch"

View file

@ -1,33 +0,0 @@
# Contributor: Duncan Guthrie <dguthrie@posteo.net>
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=libxsettings
pkgver=0.11
pkgrel=0
pkgdesc="Xsettings protocol library for GPE Palmtop Environment"
url="https://standards.freedesktop.org/xsettings-spec/0.5/"
arch="all"
license="GPL-2.0-or-later"
depends="libx11"
makedepends="libx11-dev"
source="http://http.debian.net/debian/pool/main/libx/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz"
builddir="${srcdir}/${pkgname}-${pkgver}"
subpackages="$pkgname-dev"
options="!check"
dev () {
cd "$builddir"
mkdir -p "$subpkgdir"/usr
make PREFIX="/usr" DESTDIR="$subpkgdir" install-devel
}
build () {
cd "$builddir"
make
}
package() {
cd "$builddir"
make PREFIX="/usr" DESTDIR="$pkgdir" install
}
sha512sums="9b385949673e5de28d711dcbcd3b924fe9da9176002bfb32785f384220d4e4d6a66a12cf0cfc36a77994fe4d8623e6557ae09995889f915b9c319147ed134942 libxsettings_0.11.orig.tar.gz"

View file

@ -1,37 +0,0 @@
# Contributor: Duncan Guthrie <dguthrie@posteo.net>
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=matchbox-common
pkgver=0_git20070606
pkgrel=2
_commit="3055fb158054d059e9a50141e7ded2a41ecfbd47"
pkgdesc="Common data files for Matchbox"
url="http://matchbox-project.org"
arch="noarch"
license="GPL-2.0-only"
depends=""
makedepends="libmatchbox-dev autoconf automake libtool"
source="https://git.yoctoproject.org/cgit/cgit.cgi/$pkgname/snapshot/$pkgname-$_commit.tar.gz
matchbox-v2-utils.patch"
builddir="$srcdir/$pkgname-$_commit"
options="!check"
build() {
cd "$builddir"
autoreconf --install
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var
make
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="742c38c60efa99de6a7d9bf510045eaf8ea1038722c9e45d614b66a3112f2b48f715d53bf9d44f173ca35e858aee135d0fbc3ed4fe0937b74c40ac515c5320f4 matchbox-common-3055fb158054d059e9a50141e7ded2a41ecfbd47.tar.gz
d2e01db56b2f230ca36773e96678359e528570fc0a3f78124ab1088cdf94a495d67173dec539400f7529382bc405ac9de93e266a905c022099396d1865fe1775 matchbox-v2-utils.patch"

View file

@ -1,44 +0,0 @@
diff -Naur a/matchbox-session b/matchbox-session
--- a/matchbox-session 2018-05-12 13:33:32.019726303 +0100
+++ b/matchbox-session 2018-05-12 13:34:06.633851723 +0100
@@ -4,21 +4,25 @@
#
# Uncomment below to enable parsing of debian menu entrys
-# export MB_USE_DEB_MENUS=1
-
-if [ -e $HOME/.matchbox/session ]
-then
-exec $HOME/.matchbox/session
-fi
-
-if [ -e /etc/matchbox/session ]
-then
-exec /etc/matchbox/session
-fi
-
+# export MB_USE_DEB_MENUS=1
+#
+# if [ -e $HOME/.matchbox/session ]
+# then
+# exec $HOME/.matchbox/session
+# fi
+#
+# if [ -e /etc/matchbox/session ]
+# then
+# exec /etc/matchbox/session
+# fi
+#
# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
-# dont exist.
+# dont exist.
+
+START_APPLETS=showdesktop,windowselector
+END_APPLETS=clock,keyboard,systray,startup-notify,notify
matchbox-desktop &
-matchbox-panel --orientation south &
-exec matchbox-window-manager $@
+matchbox-panel --edge=bottom --start-applets=$START_APPLETS --end-applets=$END_APPLETS &
+matchbox-keyboard --daemon &
+exec matchbox-window-manager-2-simple -use_cursor yes $@

View file

@ -1,36 +0,0 @@
# Contributor: Duncan Guthrie <dguthrie@posteo.net>
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=matchbox-desktop
pkgver=2.0
pkgrel=0
pkgdesc="Desktop system for handhelds using the GTK+2 stack"
url="https://matchbox-project.org"
arch="all"
license="GPL-2.0-only"
depends="gdk-pixbuf glib gtk+2.0 pango startup-notification libx11 matchbox-common libmatchbox libjpeg-turbo"
makedepends="startup-notification-dev gtk+2.0-dev autoconf automake libtool libmatchbox-dev libjpeg-turbo-dev"
source="http://http.debian.net/debian/pool/main/m/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
options="!check"
build() {
cd "$builddir"
./configure \
--enable-startup-notification \
--enable-dnotify \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
LIBS="-lX11"
make
}
package() {
cd "$builddir"
make DESTDIR=$pkgdir install
}
sha512sums="c1e4b4312a21691b9fe6f956e788d6064835bf062d69944b0124f7c274464b13320d8b8641315fe0c355eb5e35f8f42c9b817232f4aedf443a7bf34cb047f725 matchbox-desktop_2.0.orig.tar.gz"

View file

@ -1,41 +0,0 @@
# Contributor: Duncan Guthrie <dguthrie@posteo.net>
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=matchbox-panel
_pkgname=$pkgname-2
pkgver=2.11_git20161123
pkgrel=0
_commit="f82ca3f42510fb3ef10f598b393eb373a2c34ca7"
pkgdesc="Simple GTK+3-based panel for handheld devices"
url="http://matchbox-project.org"
arch="all"
license="GPL-2.0-or-later"
depends="libmatchbox startup-notification libx11 libxext matchbox-common dbus dbus-glib gdk-pixbuf gtk+3.0"
makedepends="libintl libmatchbox-dev startup-notification-dev libx11-dev autoconf automake libtool gettext git gdk-pixbuf-dev gtk+3.0-dev dbus-glib-dev dbus-dev"
source="https://git.yoctoproject.org/cgit/cgit.cgi/${_pkgname}/snapshot/${_pkgname}-${_commit}.tar.gz
allow-smaller-icons.patch"
builddir="$srcdir/$_pkgname-$_commit"
options="!check"
subpackages="$pkgname-dev"
build() {
cd "$builddir"
autoreconf --install
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
--enable-startup-notification \
--enable-dbus
make
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="faf5d3cb25a8cc88656099986e3f44b6f8d7fbd16ea510ca2bab04b40bd3e82304604dd4214d1015e6f14a396d442a8adac0436ea4f1745174178665bcb1f299 matchbox-panel-2-f82ca3f42510fb3ef10f598b393eb373a2c34ca7.tar.gz
b4ec412a269565d8eb426d339c68e13ae839700658b4654ae32fbd53ad53bd3948647fe84cb59051e1fe1517f5dbd69f1cbda255278f51107a5c444780680ef7 allow-smaller-icons.patch"

View file

@ -1,34 +0,0 @@
From f83a9179696b2d060ee4860733dafbf38bbd4b87 Mon Sep 17 00:00:00 2001
From: Jussi Kukkonen <jussi.kukkonen@intel.com>
Date: Wed, 28 Sep 2016 15:05:41 +0300
Subject: [PATCH] applets/systray: Allow icons to be smaller
Don't expand/fill the systray items, align them in the center of the
systray panel. This makes sure the icons are drawn at the size they
expect.
Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Upstream-Status: Submitted
---
applets/systray/systray.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/applets/systray/systray.c b/applets/systray/systray.c
index 39698a8..94a5753 100644
--- a/applets/systray/systray.c
+++ b/applets/systray/systray.c
@@ -29,8 +29,9 @@ on_realize (GtkWidget *widget, gpointer user_data)
tray = (GtkWidget *)na_tray_new_for_screen (screen, orientation);
gtk_widget_show (tray);
-
- gtk_container_add (GTK_CONTAINER (widget), tray);
+ gtk_widget_set_valign (tray, GTK_ALIGN_CENTER);
+ gtk_widget_set_halign (tray, GTK_ALIGN_CENTER);
+ gtk_box_pack_start (GTK_BOX (widget), tray, FALSE, FALSE, 0);
}
G_MODULE_EXPORT GtkWidget *
--
2.1.4

View file

@ -1,40 +0,0 @@
# Contributor: Duncan Guthrie <dguthrie@posteo.net>
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=matchbox-window-manager
_pkgname=$pkgname-2
pkgver=2.0_git20171119
pkgrel=0
_commit="5f44595c66be118b1a74f489de7f8492035cbdf0"
pkgdesc="Window manager intended for non-desktop embedded platforms such as handhelds and set-top boxes"
url="http://matchbox-project.org"
arch="all"
license="GPL-2.0-only"
source="https://git.yoctoproject.org/cgit/cgit.cgi/${_pkgname}/snapshot/${_pkgname}-${_commit}.tar.gz
libpng.pc.patch"
depends="libmatchbox libpng expat gtk+2.0 pango"
makedepends="expat-dev autoconf automake libtool libmatchbox-dev libpng-dev expat-dev gtk+2.0-dev pango-dev"
builddir="$srcdir/$_pkgname-$_commit"
options="!check"
build() {
cd "$builddir"
autoreconf --install
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/ \
--with-gtk \
--with-pango \
LIBS="-lexpat"
make
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="5972c9304de064501f657e3fc7920b4fd25dec24db609442e340dbe1850dd48b5cc9abaca1ad175cbb52fdede180f12b522ab0e8c028f12a1bd691710f15d5f3 matchbox-window-manager-2-5f44595c66be118b1a74f489de7f8492035cbdf0.tar.gz
76e0af420f81ce6af545e3f42cb3deb73378dc10db21e6f4eb0e4baddb9c617366d3409bccf3c9b5a14e76e54401a90270ec6a720e16175452736a4ce497b818 libpng.pc.patch"

View file

@ -1,12 +0,0 @@
diff -Naur a/configure.ac b/configure.ac
--- a/configure.ac 2018-05-06 23:55:16.363969631 +0100
+++ b/configure.ac 2018-05-07 00:03:30.842077995 +0100
@@ -96,7 +96,7 @@
fi
if test "x$png_theme" = "xyes"; then
- needed_pkgs="$needed_pkgs libpng12 "
+ needed_pkgs="$needed_pkgs libpng16 "
fi
if test "x$composite_managers" != xno -a \