Add initial device support for Sony Xperia T3 (sony-seagull) (#1389)
This commit is contained in:
parent
97f94c593e
commit
69fdf24589
10 changed files with 4251 additions and 0 deletions
22
device/device-sony-seagull/APKBUILD
Normal file
22
device/device-sony-seagull/APKBUILD
Normal file
|
@ -0,0 +1,22 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname="device-sony-seagull"
|
||||
pkgdesc="Sony Xperia T3"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="noarch"
|
||||
options="!check"
|
||||
depends="postmarketos-base linux-sony-seagull mdss-fb-init-hack mkbootimg mesa-dri-swrast"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="4e66017e7191aca0f4e8b5155c0a18cc35381cc80286c7d15642d5dcc3c761f4c04f350d7bfd4f7dd56af122cc0ec55d6cf4276119afc6a5451f5ad3c7fee1ea deviceinfo"
|
34
device/device-sony-seagull/deviceinfo
Normal file
34
device/device-sony-seagull/deviceinfo
Normal file
|
@ -0,0 +1,34 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Sony Xperia T3"
|
||||
deviceinfo_manufacturer="Sony"
|
||||
deviceinfo_date=""
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_arch="armhf"
|
||||
|
||||
# Device related
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="720"
|
||||
deviceinfo_screen_height="1280"
|
||||
deviceinfo_dev_touchscreen="/dev/input/event0"
|
||||
deviceinfo_dev_touchscreen_calibration=""
|
||||
deviceinfo_dev_keyboard=""
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="androidboot.hardware=qcom user_debug=31 msm_rtb.filter=0x37"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="true"
|
||||
deviceinfo_flash_offset_base="0x00000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x02000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x01e00000"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
|
||||
# Weston
|
||||
deviceinfo_weston_pixman_type="2"
|
49
device/linux-sony-seagull/01_fix_return_address.patch
Normal file
49
device/linux-sony-seagull/01_fix_return_address.patch
Normal file
|
@ -0,0 +1,49 @@
|
|||
From aeea3592a13bf12861943e44fc48f1f270941f8d Mon Sep 17 00:00:00 2001
|
||||
From: Behan Webster <behanw@converseincode.com>
|
||||
Date: Wed, 24 Sep 2014 01:06:46 +0100
|
||||
Subject: [PATCH] ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h
|
||||
|
||||
With compilers which follow the C99 standard (like modern versions of gcc and
|
||||
clang), "extern inline" does the wrong thing (emits code for an externally
|
||||
linkable version of the inline function). In this case using static inline
|
||||
and removing the NULL version of return_address in return_address.c does
|
||||
the right thing.
|
||||
|
||||
Signed-off-by: Behan Webster <behanw@converseincode.com>
|
||||
Reviewed-by: Mark Charlebois <charlebm@gmail.com>
|
||||
Acked-by: Steven Rostedt <rostedt@goodmis.org>
|
||||
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
||||
---
|
||||
arch/arm/include/asm/ftrace.h | 2 +-
|
||||
arch/arm/kernel/return_address.c | 5 -----
|
||||
2 files changed, 1 insertion(+), 6 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h
|
||||
index 39eb16b0066f2..bfe2a2f5a644e 100644
|
||||
--- a/arch/arm/include/asm/ftrace.h
|
||||
+++ b/arch/arm/include/asm/ftrace.h
|
||||
@@ -45,7 +45,7 @@ void *return_address(unsigned int);
|
||||
|
||||
#else
|
||||
|
||||
-extern inline void *return_address(unsigned int level)
|
||||
+static inline void *return_address(unsigned int level)
|
||||
{
|
||||
return NULL;
|
||||
}
|
||||
diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c
|
||||
index fafedd86885dd..f6aa84d5b93c9 100644
|
||||
--- a/arch/arm/kernel/return_address.c
|
||||
+++ b/arch/arm/kernel/return_address.c
|
||||
@@ -63,11 +63,6 @@ void *return_address(unsigned int level)
|
||||
#warning "TODO: return_address should use unwind tables"
|
||||
#endif
|
||||
|
||||
-void *return_address(unsigned int level)
|
||||
-{
|
||||
- return NULL;
|
||||
-}
|
||||
-
|
||||
#endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */
|
||||
|
||||
EXPORT_SYMBOL_GPL(return_address);
|
33
device/linux-sony-seagull/02_gpu-msm-fix-gcc5-compile.patch
Normal file
33
device/linux-sony-seagull/02_gpu-msm-fix-gcc5-compile.patch
Normal file
|
@ -0,0 +1,33 @@
|
|||
source:
|
||||
https://github.com/ShinySide/HispAsian_Lollipop_G6/commit/b7756b6fc4bb728722b14d2dfdbaf1dc843812e9
|
||||
|
||||
* These need to be static to avoid these errors:
|
||||
|
||||
drivers/built-in.o: In function `.LANCHOR1':
|
||||
msm_iommu_sec.c:(.data+0x9298): undefined reference to `kgsl_iommu_sync_lock'
|
||||
msm_iommu_sec.c:(.data+0x929c): undefined reference to `kgsl_iommu_sync_unlock'
|
||||
Makefile:877: recipe for target '.tmp_vmlinux1' failed
|
||||
make: *** [.tmp_vmlinux1] Error 1
|
||||
|
||||
Signed-off-by: Chet Kener <Cl3Kener@gmail.com>
|
||||
|
||||
--- a/drivers/gpu/msm/kgsl_iommu.c
|
||||
+++ b/drivers/gpu/msm/kgsl_iommu.c
|
||||
@@ -1010,7 +1010,7 @@ static int kgsl_iommu_init_sync_lock(struct kgsl_mmu *mmu)
|
||||
*
|
||||
* Return - int - number of commands.
|
||||
*/
|
||||
-inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
+static inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
unsigned int *cmds)
|
||||
{
|
||||
struct kgsl_device *device = mmu->device;
|
||||
@@ -1080,7 +1080,7 @@ inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
*
|
||||
* Return - int - number of commands.
|
||||
*/
|
||||
-inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||
+static inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||
unsigned int *cmds)
|
||||
{
|
||||
struct kgsl_device *device = mmu->device;
|
|
@ -0,0 +1,66 @@
|
|||
diff --git a/arch/arm/mach-msm/smd_init_dt.c b/arch/arm/mach-msm/smd_init_dt.c
|
||||
index 640656cb..046f4470 100644
|
||||
--- a/arch/arm/mach-msm/smd_init_dt.c
|
||||
+++ b/arch/arm/mach-msm/smd_init_dt.c
|
||||
@@ -21,7 +21,7 @@
|
||||
#include <linux/io.h>
|
||||
|
||||
#include <mach/msm_ipc_logging.h>
|
||||
-#include <smd_private.h>
|
||||
+#include "smd_private.h"
|
||||
|
||||
#define MODULE_NAME "msm_smd"
|
||||
#define IPC_LOG(level, x...) do { \
|
||||
diff --git a/sound/soc/codecs/msm8x10-wcd-tables.c b/sound/soc/codecs/msm8x10-wcd-tables.c
|
||||
index 7e0263d4..9167dd83 100644
|
||||
--- a/sound/soc/codecs/msm8x10-wcd-tables.c
|
||||
+++ b/sound/soc/codecs/msm8x10-wcd-tables.c
|
||||
@@ -10,7 +10,7 @@
|
||||
* GNU General Public License for more details.
|
||||
*/
|
||||
|
||||
-#include <msm8x10_wcd_registers.h>
|
||||
+#include "msm8x10_wcd_registers.h"
|
||||
#include "msm8x10-wcd.h"
|
||||
|
||||
const u8 msm8x10_wcd_reg_readable[MSM8X10_WCD_CACHE_SIZE] = {
|
||||
diff --git a/sound/soc/msm/msm8x10.c b/sound/soc/msm/msm8x10.c
|
||||
index 5e666f0f..e69d0fef 100644
|
||||
--- a/sound/soc/msm/msm8x10.c
|
||||
+++ b/sound/soc/msm/msm8x10.c
|
||||
@@ -26,7 +26,7 @@
|
||||
#include <sound/jack.h>
|
||||
#include <asm/mach-types.h>
|
||||
#include <mach/socinfo.h>
|
||||
-#include <qdsp6v2/msm-pcm-routing-v2.h>
|
||||
+#include "../qdsp6v2/msm-pcm-routing-v2.h"
|
||||
#include <sound/q6afe-v2.h>
|
||||
#include <linux/module.h>
|
||||
#include <mach/gpiomux.h>
|
||||
diff --git a/sound/soc/msm/qdsp6v2/rtac.c b/sound/soc/msm/qdsp6v2/rtac.c
|
||||
index 701dfef6..8d2e1d41 100644
|
||||
--- a/sound/soc/msm/qdsp6v2/rtac.c
|
||||
+++ b/sound/soc/msm/qdsp6v2/rtac.c
|
||||
@@ -25,7 +25,7 @@
|
||||
#include <sound/q6asm-v2.h>
|
||||
#include <sound/q6afe-v2.h>
|
||||
#include <sound/apr_audio-v2.h>
|
||||
-#include <q6voice.h>
|
||||
+#include "q6voice.h"
|
||||
#include "audio_acdb.h"
|
||||
|
||||
|
||||
diff --git a/sound/soc/msm/msm8226.c b/sound/soc/msm/msm8226.c
|
||||
index 7ff4c82..70322dd 100644
|
||||
--- a/sound/soc/msm/msm8226.c
|
||||
+++ b/sound/soc/msm/msm8226.c
|
||||
@@ -27,7 +27,7 @@
|
||||
#include <asm/mach-types.h>
|
||||
#include <mach/socinfo.h>
|
||||
#include <mach/subsystem_notif.h>
|
||||
-#include <qdsp6v2/msm-pcm-routing-v2.h>
|
||||
+#include "qdsp6v2/msm-pcm-routing-v2.h"
|
||||
#include "qdsp6v2/q6core.h"
|
||||
#include "../codecs/wcd9xxx-common.h"
|
||||
#include "../codecs/wcd9306.h"
|
||||
|
45
device/linux-sony-seagull/04_timeconst_fix.patch
Normal file
45
device/linux-sony-seagull/04_timeconst_fix.patch
Normal file
|
@ -0,0 +1,45 @@
|
|||
From 63a3f603413ffe82ad775f2d62a5afff87fd94a0 Mon Sep 17 00:00:00 2001
|
||||
From: "H. Peter Anvin" <hpa@linux.intel.com>
|
||||
Date: Thu, 7 Feb 2013 17:14:08 -0800
|
||||
Subject: [PATCH] timeconst.pl: Eliminate Perl warning
|
||||
|
||||
defined(@array) is deprecated in Perl and gives off a warning.
|
||||
Restructure the code to remove that warning.
|
||||
|
||||
[ hpa: it would be interesting to revert to the timeconst.bc script.
|
||||
It appears that the failures reported by akpm during testing of
|
||||
that script was due to a known broken version of make, not a problem
|
||||
with bc. The Makefile rules could probably be restructured to avoid
|
||||
the make bug, or it is probably old enough that it doesn't matter. ]
|
||||
|
||||
Reported-by: Andi Kleen <ak@linux.intel.com>
|
||||
Signed-off-by: H. Peter Anvin <hpa@linux.intel.com>
|
||||
Cc: Andrew Morton <akpm@linux-foundation.org>
|
||||
Cc: <stable@vger.kernel.org>
|
||||
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
|
||||
---
|
||||
Patch status: upstream
|
||||
|
||||
kernel/timeconst.pl | 6 ++----
|
||||
1 file changed, 2 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/kernel/timeconst.pl b/kernel/timeconst.pl
|
||||
index eb51d76..3f42652 100644
|
||||
--- a/kernel/timeconst.pl
|
||||
+++ b/kernel/timeconst.pl
|
||||
@@ -369,10 +369,8 @@ if ($hz eq '--can') {
|
||||
die "Usage: $0 HZ\n";
|
||||
}
|
||||
|
||||
- @val = @{$canned_values{$hz}};
|
||||
- if (!defined(@val)) {
|
||||
- @val = compute_values($hz);
|
||||
- }
|
||||
+ $cv = $canned_values{$hz};
|
||||
+ @val = defined($cv) ? @$cv : compute_values($hz);
|
||||
output($hz, @val);
|
||||
}
|
||||
exit 0;
|
||||
--
|
||||
2.4.10
|
||||
|
106
device/linux-sony-seagull/05_psmouse_base.patch
Normal file
106
device/linux-sony-seagull/05_psmouse_base.patch
Normal file
|
@ -0,0 +1,106 @@
|
|||
From ae4fef6fc558b0621532d0de6ebaaeaabe861792 Mon Sep 17 00:00:00 2001
|
||||
From: sub77 <sub77@ymail.com>
|
||||
Date: Fri, 31 Jul 2015 17:47:45 +0200
|
||||
Subject: [PATCH] fix build error: PS2MOUSE fsp_detect & lifebook
|
||||
|
||||
---
|
||||
drivers/input/mouse/psmouse-base.c | 62 +++++++++++++++++++-------------------
|
||||
1 file changed, 31 insertions(+), 31 deletions(-)
|
||||
|
||||
diff --git a/drivers/input/mouse/psmouse-base.c b/drivers/input/mouse/psmouse-base.c
|
||||
index a19c183557d..ad3d2e861d0 100644
|
||||
--- a/drivers/input/mouse/psmouse-base.c
|
||||
+++ b/drivers/input/mouse/psmouse-base.c
|
||||
@@ -708,14 +708,14 @@ static int psmouse_extensions(struct psmouse *psmouse,
|
||||
/*
|
||||
* We always check for lifebook because it does not disturb mouse
|
||||
* (it only checks DMI information).
|
||||
+ *
|
||||
+ * if (psmouse_do_detect(lifebook_detect, psmouse, set_properties) == 0) {
|
||||
+ * if (max_proto > PSMOUSE_IMEX) {
|
||||
+ * if (!set_properties || lifebook_init(psmouse) == 0)
|
||||
+ * return PSMOUSE_LIFEBOOK;
|
||||
+ * }
|
||||
+ * }
|
||||
*/
|
||||
- if (psmouse_do_detect(lifebook_detect, psmouse, set_properties) == 0) {
|
||||
- if (max_proto > PSMOUSE_IMEX) {
|
||||
- if (!set_properties || lifebook_init(psmouse) == 0)
|
||||
- return PSMOUSE_LIFEBOOK;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
/*
|
||||
* Try Kensington ThinkingMouse (we try first, because synaptics probe
|
||||
* upsets the thinkingmouse).
|
||||
@@ -821,19 +821,19 @@ static int psmouse_extensions(struct psmouse *psmouse,
|
||||
/*
|
||||
* Try Finger Sensing Pad. We do it here because its probe upsets
|
||||
* Trackpoint devices (causing TP_READ_ID command to time out).
|
||||
- */
|
||||
- if (max_proto > PSMOUSE_IMEX) {
|
||||
- if (psmouse_do_detect(fsp_detect,
|
||||
- psmouse, set_properties) == 0) {
|
||||
- if (!set_properties || fsp_init(psmouse) == 0)
|
||||
- return PSMOUSE_FSP;
|
||||
-/*
|
||||
+ *
|
||||
+ * if (max_proto > PSMOUSE_IMEX) {
|
||||
+ * if (psmouse_do_detect(fsp_detect,
|
||||
+ * psmouse, set_properties) == 0) {
|
||||
+ * if (!set_properties || fsp_init(psmouse) == 0)
|
||||
+ * return PSMOUSE_FSP;
|
||||
+ *
|
||||
* Init failed, try basic relative protocols
|
||||
+ *
|
||||
+ * max_proto = PSMOUSE_IMEX;
|
||||
+ * }
|
||||
+ * }
|
||||
*/
|
||||
- max_proto = PSMOUSE_IMEX;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
/*
|
||||
* Reset to defaults in case the device got confused by extended
|
||||
* protocol probes. Note that we follow up with full reset because
|
||||
@@ -944,12 +944,12 @@ static const struct psmouse_protocol psmouse_protocols[] = {
|
||||
},
|
||||
#endif
|
||||
#ifdef CONFIG_MOUSE_PS2_LIFEBOOK
|
||||
- {
|
||||
- .type = PSMOUSE_LIFEBOOK,
|
||||
- .name = "LBPS/2",
|
||||
- .alias = "lifebook",
|
||||
- .init = lifebook_init,
|
||||
- },
|
||||
+/* {
|
||||
+* .type = PSMOUSE_LIFEBOOK,
|
||||
+* .name = "LBPS/2",
|
||||
+* .alias = "lifebook",
|
||||
+* .init = lifebook_init,
|
||||
+* },*/
|
||||
#endif
|
||||
#ifdef CONFIG_MOUSE_PS2_TRACKPOINT
|
||||
{
|
||||
@@ -985,13 +985,13 @@ static const struct psmouse_protocol psmouse_protocols[] = {
|
||||
},
|
||||
#endif
|
||||
#ifdef CONFIG_MOUSE_PS2_SENTELIC
|
||||
- {
|
||||
- .type = PSMOUSE_FSP,
|
||||
- .name = "FSPPS/2",
|
||||
- .alias = "fsp",
|
||||
- .detect = fsp_detect,
|
||||
- .init = fsp_init,
|
||||
- },
|
||||
+/* {
|
||||
+* .type = PSMOUSE_FSP,
|
||||
+* .name = "FSPPS/2",
|
||||
+* .alias = "fsp",
|
||||
+* .detect = fsp_detect,
|
||||
+* .init = fsp_init,
|
||||
+* },*/
|
||||
#endif
|
||||
{
|
||||
.type = PSMOUSE_CORTRON,
|
103
device/linux-sony-seagull/APKBUILD
Normal file
103
device/linux-sony-seagull/APKBUILD
Normal file
|
@ -0,0 +1,103 @@
|
|||
# Kernel config based on:
|
||||
# arch/arm/configs/{msm8226_defconfig,proj_SEAGULL_3G_defconfig,proj_SEAGULL_3G_defconfig}
|
||||
# (combined in that order)
|
||||
|
||||
pkgname="linux-sony-seagull"
|
||||
pkgver=3.4.0
|
||||
pkgrel=0
|
||||
pkgdesc="Sony Xperia T3 kernel fork"
|
||||
arch="armhf"
|
||||
_carch="arm"
|
||||
_flavor="sony-seagull"
|
||||
url="https://kernel.org"
|
||||
license="GPL2"
|
||||
options="!strip !check !tracedeps"
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev dtbtool"
|
||||
HOSTCC="${CC:-gcc}"
|
||||
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_sony_seagull"
|
||||
_commit="e39e9203b59a21cac634a86641b0413b0100ed48"
|
||||
_srcurl="https://github.com/pmsourcedump/${_repository}/archive/${_commit}.tar.gz"
|
||||
_config="config-${_flavor}.${arch}"
|
||||
source="
|
||||
$pkgname-$pkgver.tar.gz::${_srcurl}
|
||||
$_config
|
||||
compiler-gcc6.h
|
||||
01_fix_return_address.patch
|
||||
02_gpu-msm-fix-gcc5-compile.patch
|
||||
03_fix_various_include_directives.patch
|
||||
04_timeconst_fix.patch
|
||||
05_psmouse_base.patch
|
||||
"
|
||||
builddir="$srcdir/${_repository}-${_commit}/"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
|
||||
# gcc6 support
|
||||
cp -v "$srcdir/compiler-gcc6.h" "$builddir/include/linux/"
|
||||
|
||||
# Remove -Werror from all makefiles
|
||||
local i
|
||||
local makefiles="$(find . -type f -name Makefile)
|
||||
$(find . -type f -name Kbuild)"
|
||||
for i in $makefiles; do
|
||||
sed -i 's/-Werror-/-W/g' "$i"
|
||||
sed -i 's/-Werror//g' "$i"
|
||||
done
|
||||
|
||||
# Prepare kernel config ('yes ""' for kernels lacking olddefconfig)
|
||||
cp "$srcdir"/$_config "$builddir"/.config
|
||||
yes "" | make ARCH="$_carch" HOSTCC="$HOSTCC" oldconfig
|
||||
}
|
||||
|
||||
menuconfig() {
|
||||
cd "$builddir"
|
||||
make ARCH="$_carch" menuconfig
|
||||
cp .config "$startdir"/$_config
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS" \
|
||||
CONFIG_NO_ERROR_ON_MISMATCH=y
|
||||
|
||||
# Generate master DTB (deviceinfo_bootimg_qcdt)
|
||||
dtbTool -s 2048 -p "scripts/dtc/" -o "arch/arm/boot/dt.img" "arch/arm/boot/"
|
||||
}
|
||||
|
||||
package() {
|
||||
# kernel.release
|
||||
install -D "$builddir/include/config/kernel.release" \
|
||||
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||
|
||||
# zImage (find the right one)
|
||||
cd "$builddir/arch/$_carch/boot"
|
||||
_target="$pkgdir/boot/vmlinuz-$_flavor"
|
||||
for _zimg in zImage-dtb Image.gz-dtb *zImage Image; do
|
||||
[ -e "$_zimg" ] || continue
|
||||
msg "zImage found: $_zimg"
|
||||
install -Dm644 "$_zimg" "$_target"
|
||||
break
|
||||
done
|
||||
if ! [ -e "$_target" ]; then
|
||||
error "Could not find zImage in $PWD!"
|
||||
return 1
|
||||
fi
|
||||
|
||||
# Master DTB (deviceinfo_bootimg_qcdt)
|
||||
install -Dm644 "$builddir/arch/arm/boot/dt.img" \
|
||||
"$pkgdir/boot/dt.img"
|
||||
}
|
||||
|
||||
sha512sums="d060cd2ac73d5fd645ee3d9aff1b5912e2e237606d78be4180de0da850143458c8dc1bc425ed6201f9d6bff941364a722ea84e3c2a5b8404bc2e79cecf7c88e8 linux-sony-seagull-3.4.0.tar.gz
|
||||
7aa575bfcd157e993bf3935e29039ad857cd1624a4ee3e53e3ed31d0f2fec05abac5bcd59d2f95c7ee4dc378c958ff88aef48c0ee38f63d9a3361037a45696ee config-sony-seagull.armhf
|
||||
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h
|
||||
ea1d3b5a234fa565e3c1a792de48f4fc4e6023d281d303c8e319c7ef28edc5739ab0e4dea0139a41f0a5c7d03e27921ccaa214fd0ac5c72245a094ce60128864 01_fix_return_address.patch
|
||||
7be03a9e78b7ac330a54b1f00509caa0621a95c0c55901878ad757f9dd69cc05ba2c8b5ea987063ae1224f92c4d090d515fa5d369e7755181a4871b0d0f82881 02_gpu-msm-fix-gcc5-compile.patch
|
||||
f3a3b9a2e4f390b7b6bb5e986172db4258c6ce3babf76df7eb19aa7197ef9d16cf5e3bda5996b2d6d5be86a25ee984f1ea601a838c1b61724cbb6659da127e03 03_fix_various_include_directives.patch
|
||||
a2bb98fb8d988bbb659cae00fbaca360828300e9b98b90aed5ee0dd839c3f740696df4094a9021b813cbada06820d115aabed581a47cdd2c947e8d853c20b145 04_timeconst_fix.patch
|
||||
f7e31cfe422696922aec52002e56c58103183966edee3bb8e1995d33f8d37b07c32280a8ecc213874e358a6ff367418556a4542fba7e3c17e4b8e82e05c3a543 05_psmouse_base.patch"
|
69
device/linux-sony-seagull/compiler-gcc6.h
Normal file
69
device/linux-sony-seagull/compiler-gcc6.h
Normal file
|
@ -0,0 +1,69 @@
|
|||
// SOURCE:
|
||||
// https://github.com/NextThingCo/CHIP-u-boot/issues/10#issuecomment-287515505
|
||||
|
||||
#ifndef __LINUX_COMPILER_H
|
||||
#error "Please don't include <linux/compiler-gcc6.h> directly, include <linux/compiler.h> instead."
|
||||
#endif
|
||||
|
||||
#define __used __attribute__((__used__))
|
||||
#define __must_check __attribute__((warn_unused_result))
|
||||
#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||
|
||||
/* Mark functions as cold. gcc will assume any path leading to a call
|
||||
to them will be unlikely. This means a lot of manual unlikely()s
|
||||
are unnecessary now for any paths leading to the usual suspects
|
||||
like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||
older compilers]
|
||||
|
||||
Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||
in the preprocessor, but we can live with this because they're unreleased.
|
||||
Maketime probing would be overkill here.
|
||||
|
||||
gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||
a special section, but I don't see any sense in this right now in
|
||||
the kernel context */
|
||||
#define __cold __attribute__((__cold__))
|
||||
|
||||
#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||
|
||||
#ifndef __CHECKER__
|
||||
# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||
# define __compiletime_error(message) __attribute__((error(message)))
|
||||
#endif /* __CHECKER__ */
|
||||
|
||||
/*
|
||||
* Mark a position in code as unreachable. This can be used to
|
||||
* suppress control flow warnings after asm blocks that transfer
|
||||
* control elsewhere.
|
||||
*
|
||||
* Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||
* this in the preprocessor, but we can live with this because they're
|
||||
* unreleased. Really, we need to have autoconf for the kernel.
|
||||
*/
|
||||
#define unreachable() __builtin_unreachable()
|
||||
|
||||
/* Mark a function definition as prohibited from being cloned. */
|
||||
#define __noclone __attribute__((__noclone__))
|
||||
|
||||
/*
|
||||
* Tell the optimizer that something else uses this function or variable.
|
||||
*/
|
||||
#define __visible __attribute__((externally_visible))
|
||||
|
||||
/*
|
||||
* GCC 'asm goto' miscompiles certain code sequences:
|
||||
*
|
||||
* http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||
*
|
||||
* Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||
*
|
||||
* (asm goto is automatically volatile - the naming reflects this.)
|
||||
*/
|
||||
#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||
|
||||
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||
#define __HAVE_BUILTIN_BSWAP32__
|
||||
#define __HAVE_BUILTIN_BSWAP64__
|
||||
#define __HAVE_BUILTIN_BSWAP16__
|
||||
#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||
|
3724
device/linux-sony-seagull/config-sony-seagull.armhf
Normal file
3724
device/linux-sony-seagull/config-sony-seagull.armhf
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue