temp/dino: drop (MR 3575)
For whatever reason, Alpine includes the mobile adaptivity patches for
this app:
cb88c5701f/community/dino/mobile-ui.patch
As such, drop our fork since it's unnecessary.
Reported-by: Airtower
This commit is contained in:
parent
445e530314
commit
665bcc199d
2 changed files with 0 additions and 74 deletions
|
@ -1,61 +0,0 @@
|
|||
# Forked from Alpine Linux: unreleased branch of Dino that has been optimized
|
||||
# for mobile displays
|
||||
pkgname=dino
|
||||
pkgver=9999_git20211230
|
||||
pkgrel=2
|
||||
# feature/handy branch
|
||||
_commit="c848191a034a920266687002045abc5e1f42b070"
|
||||
pkgdesc="Modern Jabber/XMPP client"
|
||||
url="https://dino.im"
|
||||
arch="all"
|
||||
license="GPL-3.0-only"
|
||||
makedepends="
|
||||
glib-dev
|
||||
glib-networking
|
||||
gtk+3.0-dev
|
||||
gpgme-dev
|
||||
gspell-dev
|
||||
gstreamer-dev
|
||||
gst-plugins-base-dev
|
||||
libgee-dev
|
||||
libsignal-protocol-c-dev
|
||||
libgcrypt-dev
|
||||
libhandy1-dev
|
||||
libnice-dev
|
||||
libsoup-dev
|
||||
libsrtp-dev
|
||||
sqlite-dev
|
||||
libqrencode-dev
|
||||
cmake
|
||||
vala
|
||||
"
|
||||
subpackages="$pkgname-lang"
|
||||
source="
|
||||
https://github.com/dino/dino/archive/$_commit.tar.gz
|
||||
bump-signal-version.patch
|
||||
"
|
||||
builddir="$srcdir/$pkgname-$_commit"
|
||||
build() {
|
||||
./configure \
|
||||
--build=$CBUILD \
|
||||
--host=$CHOST \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--mandir=/usr/share/man \
|
||||
--localstatedir=/var \
|
||||
--with-tests
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
build/xmpp-vala-test
|
||||
build/signal-protocol-vala-test
|
||||
}
|
||||
|
||||
package() {
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
sha512sums="
|
||||
1157c2221b0b127b151b79d6a5b1dd0a4141b9022cd148e2e347be026af950744d8a1030bb02ff27c3410653e3f18b30a5d2659fe2b24620e64004e95343e31d c848191a034a920266687002045abc5e1f42b070.tar.gz
|
||||
838ccba8d97db8bc43de26afd259e4bdaf3afea786bf40a7ed9ae63f4fb7c2190e8bf6de7b41880602113df87831d01467547f8bfd1f88b50d35287822cb5f4c bump-signal-version.patch
|
||||
"
|
|
@ -1,13 +0,0 @@
|
|||
diff --git a/plugins/signal-protocol/CMakeLists.txt b/plugins/signal-protocol/CMakeLists.txt
|
||||
index 400de03..0d776de 100644
|
||||
--- a/plugins/signal-protocol/CMakeLists.txt
|
||||
+++ b/plugins/signal-protocol/CMakeLists.txt
|
||||
@@ -32,7 +32,7 @@ if(NOT BUILD_LIBSIGNAL_IN_TREE)
|
||||
# libsignal-protocol-c has a history of breaking compatibility on the patch level
|
||||
# we'll have to check compatibility for every new release
|
||||
# distro maintainers may update this dependency after compatibility tests
|
||||
- find_package(SignalProtocol 2.3.2 REQUIRED)
|
||||
+ find_package(SignalProtocol 2.3.3 REQUIRED)
|
||||
else()
|
||||
add_subdirectory(libsignal-protocol-c EXCLUDE_FROM_ALL)
|
||||
set_property(TARGET curve25519 PROPERTY POSITION_INDEPENDENT_CODE ON)
|
Loading…
Reference in a new issue