lg-w7: new device (MR 2704)
[ci:skip-build] already built successfully in CI
This commit is contained in:
parent
bc7dbe4288
commit
5eaad55060
9 changed files with 4072 additions and 0 deletions
29
device/testing/device-lg-w7/APKBUILD
Normal file
29
device/testing/device-lg-w7/APKBUILD
Normal file
|
@ -0,0 +1,29 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-lg-w7
|
||||
pkgdesc="LG Optimus L90"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="armv7"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-lg-w7
|
||||
mesa-dri-gallium
|
||||
mkbootimg
|
||||
postmarketos-base
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
13d8884114b71066d2e630282ea95f9c696166ca023578d889dfe2476705b77b6e62d0c0d3a7bc132f58942f2ebe35fc0b8230dbf4e11fdac32096f72b0005e1 deviceinfo
|
||||
"
|
31
device/testing/device-lg-w7/deviceinfo
Normal file
31
device/testing/device-lg-w7/deviceinfo
Normal file
|
@ -0,0 +1,31 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="LG Optimus L90"
|
||||
deviceinfo_manufacturer="LG"
|
||||
deviceinfo_codename="lg-w7"
|
||||
deviceinfo_year="2014"
|
||||
deviceinfo_arch="armv7"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="handset"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="960"
|
||||
deviceinfo_screen_height="540"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="console=ttyHSL0,115200,n8 androidboot.console=ttyHSL0 user_debug=31 msm_rtb.filter=0x37 androidboot.hardware=qcom androidboot.selinux=permissive buildvariant=userdebug"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="true"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_flash_offset_base="0x00000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
16
device/testing/linux-lg-w7/01_msm_section_mismatch.patch
Normal file
16
device/testing/linux-lg-w7/01_msm_section_mismatch.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
diff --git a/arch/arm/mach-msm/pm-boot.h b/arch/arm/mach-msm/pm-boot.h
|
||||
index 2d5110d3..8b5f69e4 100644
|
||||
--- a/arch/arm/mach-msm/pm-boot.h
|
||||
+++ b/arch/arm/mach-msm/pm-boot.h
|
||||
@@ -31,9 +31,9 @@ struct msm_pm_boot_platform_data {
|
||||
};
|
||||
|
||||
#ifdef CONFIG_PM
|
||||
-int __init msm_pm_boot_init(struct msm_pm_boot_platform_data *pdata);
|
||||
+int __devinit msm_pm_boot_init(struct msm_pm_boot_platform_data *pdata);
|
||||
#else
|
||||
-static inline int __init msm_pm_boot_init(
|
||||
+static inline int __devinit msm_pm_boot_init(
|
||||
struct msm_pm_boot_platform_data *pdata)
|
||||
{
|
||||
return 0;
|
71
device/testing/linux-lg-w7/APKBUILD
Normal file
71
device/testing/linux-lg-w7/APKBUILD
Normal file
|
@ -0,0 +1,71 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm/configs/(w7ds_lineageos_defconfig)
|
||||
|
||||
pkgname=linux-lg-w7
|
||||
pkgver=3.4.0
|
||||
pkgrel=0
|
||||
pkgdesc="LG Optimus L90 kernel fork"
|
||||
arch="armv7"
|
||||
_carch="arm"
|
||||
_flavor="lg-w7"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
dtbtool
|
||||
flex
|
||||
openssl-dev
|
||||
perl
|
||||
"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_lge_msm8226"
|
||||
_commit="bf756279493c2cc4656b784afa29822b30838e98"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
gcc8-fix-put-user.patch
|
||||
gcc10-extern_YYLOC_global_declaration.patch
|
||||
kernel-use-the-gnu89-standard-explicitly.patch
|
||||
01_msm_section_mismatch.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
|
||||
# Master DTB (deviceinfo_bootimg_qcdt)
|
||||
dtbTool -o "$_outdir/arch/$_carch/boot"/dt.img \
|
||||
"$_outdir/arch/$_carch/boot/"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" \
|
||||
"$_flavor" "$_outdir"
|
||||
install -Dm644 "$_outdir/arch/$_carch/boot"/dt.img \
|
||||
"$pkgdir"/boot/dt.img
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
6406689c9fe29ab7bc6874cd7ed0d3770fd15a3befc90f1d2fef26b100c581c0dd99ec3bd30f83ff42f2ba8b29239ac7254ebc8f359fbe70348d862b07057e79 linux-lg-w7-bf756279493c2cc4656b784afa29822b30838e98.tar.gz
|
||||
e1b7a513a9e5a8c5a041b01ff866576c78aedfe05882a43da06c916c11c48e2a082998efd275f4b25e1c872bb94c292765d4fbc1f9806dd977cd255d04c14b4f config-lg-w7.armv7
|
||||
77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7 gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||
ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c kernel-use-the-gnu89-standard-explicitly.patch
|
||||
2a96a93e31fe30bcab14b99f124054f727549ed80b342069758a0c645379ea3c19b84d9aa9c834640969472f4dfd44486cee4e91ab4c2cdbe4fe8b4b68fdcb78 01_msm_section_mismatch.patch
|
||||
"
|
3921
device/testing/linux-lg-w7/config-lg-w7.armv7
Normal file
3921
device/testing/linux-lg-w7/config-lg-w7.armv7
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc7-give-up-on-ilog2-const-optimizations.patch
|
1
device/testing/linux-lg-w7/gcc8-fix-put-user.patch
Symbolic link
1
device/testing/linux-lg-w7/gcc8-fix-put-user.patch
Symbolic link
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc8-fix-put-user.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/kernel-use-the-gnu89-standard-explicitly.patch
|
Loading…
Reference in a new issue