kde/itinerary: new aport (!849)
Not the newest commit because that requires the next frameworks version.
This commit is contained in:
parent
a3a63f2151
commit
5b660d9451
3 changed files with 119 additions and 0 deletions
|
@ -0,0 +1,49 @@
|
|||
From e692d7c6cc5ebe441377875270248cb81c8a5cd3 Mon Sep 17 00:00:00 2001
|
||||
From: Volker Krause <vkrause@kde.org>
|
||||
Date: Sun, 15 Dec 2019 20:11:10 +0100
|
||||
Subject: [PATCH] Adapt to KPublicTransport API changes
|
||||
|
||||
---
|
||||
autotests/timelinedelegatecontrollertest.cpp | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/autotests/timelinedelegatecontrollertest.cpp b/autotests/timelinedelegatecontrollertest.cpp
|
||||
index 962cd84..7c91378 100644
|
||||
--- a/autotests/timelinedelegatecontrollertest.cpp
|
||||
+++ b/autotests/timelinedelegatecontrollertest.cpp
|
||||
@@ -68,7 +68,7 @@ private Q_SLOTS:
|
||||
QCOMPARE(controller.effectiveEndTime(), QDateTime());
|
||||
QCOMPARE(controller.isLocationChange(), false);
|
||||
QCOMPARE(controller.isPublicTransport(), false);
|
||||
- QVERIFY(controller.journeyRequest().isEmpty());
|
||||
+ QVERIFY(!controller.journeyRequest().isValid());
|
||||
|
||||
controller.setBatchId(QStringLiteral("foo"));
|
||||
QCOMPARE(controller.isCurrent(), false);
|
||||
@@ -174,20 +174,20 @@ private Q_SLOTS:
|
||||
TimelineDelegateController controller;
|
||||
controller.setReservationManager(&mgr);
|
||||
controller.setBatchId(mgr.batches().at(0)); // flight
|
||||
- QVERIFY(controller.journeyRequest().isEmpty());
|
||||
+ QVERIFY(!controller.journeyRequest().isValid());
|
||||
|
||||
controller.setBatchId(mgr.batches().at(1)); // first train segment
|
||||
QCOMPARE(controller.isLocationChange(), true);
|
||||
QCOMPARE(controller.isPublicTransport(), true);
|
||||
|
||||
auto jnyReq = controller.journeyRequest();
|
||||
- QCOMPARE(jnyReq.isEmpty(), false);
|
||||
+ QCOMPARE(jnyReq.isValid(), true);
|
||||
QCOMPARE(jnyReq.from().name(), QStringLiteral("Zürich Flughafen"));
|
||||
QCOMPARE(jnyReq.to().name(), QLatin1String("Randa"));
|
||||
|
||||
controller.setBatchId(mgr.batches().at(2)); // second train segment
|
||||
jnyReq = controller.journeyRequest();
|
||||
- QCOMPARE(jnyReq.isEmpty(), false);
|
||||
+ QCOMPARE(jnyReq.isValid(), true);
|
||||
QCOMPARE(jnyReq.from().name(), QLatin1String("Visp"));
|
||||
QCOMPARE(jnyReq.to().name(), QLatin1String("Randa"));
|
||||
}
|
||||
--
|
||||
2.24.1
|
||||
|
25
kde/itinerary/0001-Fix-build.patch
Normal file
25
kde/itinerary/0001-Fix-build.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From 6a0d7e507709e71361c67d1b923674423bbdd50e Mon Sep 17 00:00:00 2001
|
||||
From: Volker Krause <vkrause@kde.org>
|
||||
Date: Wed, 18 Dec 2019 18:35:47 +0100
|
||||
Subject: [PATCH] Fix build
|
||||
|
||||
---
|
||||
src/app/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
|
||||
index ae6b977..8f393cd 100644
|
||||
--- a/src/app/CMakeLists.txt
|
||||
+++ b/src/app/CMakeLists.txt
|
||||
@@ -160,7 +160,7 @@ if (ANDROID)
|
||||
weather-storm
|
||||
)
|
||||
else ()
|
||||
- target_link_libraries(itinerary PRIVATE Qt5::Positioning Qt5::DBus)
|
||||
+ target_link_libraries(itinerary PRIVATE Qt5::Positioning Qt5::DBus Qt5::Widgets)
|
||||
target_link_libraries(itinerary-app PRIVATE
|
||||
KF5::DBusAddons
|
||||
Qt5::Widgets
|
||||
--
|
||||
2.24.1
|
||||
|
45
kde/itinerary/APKBUILD
Normal file
45
kde/itinerary/APKBUILD
Normal file
|
@ -0,0 +1,45 @@
|
|||
# Contributor: Bart Ribbers <bribbers@disroot.org>
|
||||
# Maintainer: Bart Ribbers <bribbers@disroot.org>
|
||||
pkgname=itinerary
|
||||
pkgver=0_git20191214
|
||||
_commit="63caaf2daae0a105982ee774de9a3797aae3ad33"
|
||||
pkgrel=0
|
||||
pkgdesc="Application to assist with usage of Travel Reservations"
|
||||
url="https://github.com/KDE/itinerary"
|
||||
arch="all"
|
||||
license="LGPL-2.1"
|
||||
depends="prison"
|
||||
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtquickcontrols2-dev
|
||||
qt5-qtlocation-dev ki18n-dev kcontacts-dev kpkpass-dev kitinerary-dev
|
||||
kpublictransport-dev kdbusaddons-dev solid-dev shared-mime-info"
|
||||
source="$pkgname-$_commit.tar.gz::https://github.com/KDE/itinerary/archive/$_commit.tar.gz
|
||||
0001-Fix-build.patch
|
||||
0001-Adapt-to-KPublicTransport-API-changes.patch"
|
||||
builddir="$srcdir/$pkgname-$_commit"
|
||||
options="!check" # Tests fail
|
||||
|
||||
build() {
|
||||
if [ "$CBUILD" != "$CHOST" ]; then
|
||||
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
|
||||
fi
|
||||
cmake \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib \
|
||||
-DBUILD_SHARED_LIBS=True \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
|
||||
-DCMAKE_C_FLAGS="$CFLAGS" \
|
||||
${CMAKE_CROSSOPTS}
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
|
||||
}
|
||||
|
||||
package() {
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
sha512sums="4d0ac75d96cfe9c996ea6b41472945d827d612fe817dff342dffbb22588753cf96d307c9132a693ab77a24819afcc4af1a35e1b59af9d406a758c7663132ebd2 itinerary-63caaf2daae0a105982ee774de9a3797aae3ad33.tar.gz
|
||||
ac2eca31b0dc066ff174f6bdb612d5387e7d31bc31b5d0e28814be4932c69dbd9cec4975420757d5b70c14d9828ee4a7a175da4eae4124840fff26f68e0df20f 0001-Fix-build.patch
|
||||
619bf1ef7c3eb2b9f8de717f291ba7aac8f038adea38b5ef0c2406d57aff6d850e57d7d720f993242ac2fd6bf8ceebf647996c32bda1105652560818e7387ff7 0001-Adapt-to-KPublicTransport-API-changes.patch"
|
Loading…
Reference in a new issue