wiko-v12bnlite: new device (MR 2439)
[ci:skip-build] Already built on CI in MR
This commit is contained in:
parent
23ee2f2dd3
commit
5a4c8d7583
7 changed files with 4767 additions and 0 deletions
30
device/testing/device-wiko-v12bnlite/APKBUILD
Normal file
30
device/testing/device-wiko-v12bnlite/APKBUILD
Normal file
|
@ -0,0 +1,30 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-wiko-v12bnlite
|
||||
pkgdesc="Wiko View"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="aarch64"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-wiko-v12bnlite
|
||||
mkbootimg
|
||||
postmarketos-base
|
||||
mesa-dri-gallium
|
||||
mdss-fb-init-hack
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
11f3a4e79609af71a0f7bf2dfd9b8baea036c4376655423c7378221b85b488a922e4cc1e36396a26ff9093f85cad3f0c9cdd79595398d8bf9a6a08c4f47a656c deviceinfo
|
||||
"
|
34
device/testing/device-wiko-v12bnlite/deviceinfo
Normal file
34
device/testing/device-wiko-v12bnlite/deviceinfo
Normal file
|
@ -0,0 +1,34 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Wiko View"
|
||||
deviceinfo_manufacturer="Wiko"
|
||||
deviceinfo_codename="wiko-v12bnlite"
|
||||
deviceinfo_year="2017"
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_arch="aarch64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="handset"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="720"
|
||||
deviceinfo_screen_height="1440"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="console=ttyHSL0,115200,n8 androidboot.console=ttyHSL0 androidboot.hardware=qcom msm_rtb.filter=0x237 ehci-hcd.park=3 lpm_levels.sleep_disabled=1 androidboot.bootdevice=7824900.sdhci earlycon=msm_hsl_uart,0x78B0000 buildvariant=user"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_flash_offset_base="0x80000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_sparse=true
|
67
device/testing/linux-wiko-v12bnlite/APKBUILD
Normal file
67
device/testing/linux-wiko-v12bnlite/APKBUILD
Normal file
|
@ -0,0 +1,67 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm64/configs/v12bnlite-perf_defconfig
|
||||
|
||||
pkgname=linux-wiko-v12bnlite
|
||||
pkgver=3.18.31
|
||||
pkgrel=0
|
||||
pkgdesc="Wiko View kernel fork"
|
||||
arch="aarch64"
|
||||
_carch="arm64"
|
||||
_flavor="wiko-v12bnlite"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
flex
|
||||
openssl-dev
|
||||
perl
|
||||
gcc6
|
||||
"
|
||||
|
||||
# Compiler: GCC 6 (doesn't boot when compiled with newer versions)
|
||||
if [ "${CC:0:5}" != "gcc6-" ]; then
|
||||
CC="gcc6-$CC"
|
||||
HOSTCC="gcc6-gcc"
|
||||
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
|
||||
fi
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_wiko_v12bnlite"
|
||||
_commit="e9c55996a1067e310b21e9855b91db1efe9a5568"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/Firstbober/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
gcc10-extern_YYLOC_global_declaration.patch
|
||||
fix_fp_driver_path_makefile.patch
|
||||
fix_ft5364i_makefile.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
c71b4172e344aad579a988b379b3f5d5276574248032b09c69be437d1c734fb3f3c844badbe5c50a4f805691c366731ce5b41afcdcf91a5fa73192a60cf51c3c linux-wiko-v12bnlite-e9c55996a1067e310b21e9855b91db1efe9a5568.tar.gz
|
||||
471a503dda855fe0dfc2c9b32531ceadac66f38f22589a27cfb9ece860aa9e5506be46e64605f46f30ba91f430b1218736b425985ea1d68ecb23a9045044a6b6 config-wiko-v12bnlite.aarch64
|
||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||
751cc042c000dfb9ff9230a9f1d2120ae185eaeb2eb76dde371014007f8cf3a42e7e3bc2a976c88227839c7a25eecfd793b267837ba9da5cb4ad62d66be061d0 fix_fp_driver_path_makefile.patch
|
||||
ea925d3956d6e3f39d5e88423e9eb89002a22a00346ed82860b53b2c2713772e10e126f043d8b3d4944137340f169a9accd865234bd48bcde197c1af12ebe38c fix_ft5364i_makefile.patch
|
||||
"
|
4592
device/testing/linux-wiko-v12bnlite/config-wiko-v12bnlite.aarch64
Normal file
4592
device/testing/linux-wiko-v12bnlite/config-wiko-v12bnlite.aarch64
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1,18 @@
|
|||
commit e52824b6ce950050b5dca60cf86ad3f42a5211e5
|
||||
Author: Firstbober <firstbober@tutanota.com>
|
||||
Date: Sat Aug 14 15:29:30 2021 +0200
|
||||
|
||||
Fix path to fingerprint driver in makefile.
|
||||
|
||||
diff --git a/drivers/input/Makefile b/drivers/input/Makefile
|
||||
index e1e0bb21..a0d102fd 100644
|
||||
--- a/drivers/input/Makefile
|
||||
+++ b/drivers/input/Makefile
|
||||
@@ -40,6 +40,6 @@ else
|
||||
include $(PWD)/vendor/tinno/Fingerprint-N/kernel_macro_cfg
|
||||
endif
|
||||
ifneq ($(strip $(TINNO_FINGERPRINT_SUPPORT)),)
|
||||
-obj-y += ../../../../$(kernel_fp_source_dir)/
|
||||
+obj-y += ../../$(kernel_fp_source_dir)/
|
||||
endif
|
||||
#TINNO END
|
|
@ -0,0 +1,25 @@
|
|||
commit 2e4d471d6bc1f092227638d590735a7e905fd798
|
||||
Author: Firstbober <firstbober@tutanota.com>
|
||||
Date: Sat Aug 14 20:49:43 2021 +0200
|
||||
|
||||
fix_ft5364i_makefile
|
||||
|
||||
diff --git a/drivers/input/touchscreen/ft5364i/Makefile b/drivers/input/touchscreen/ft5364i/Makefile
|
||||
index b0d3513b..0372e325 100644
|
||||
--- a/drivers/input/touchscreen/ft5364i/Makefile
|
||||
+++ b/drivers/input/touchscreen/ft5364i/Makefile
|
||||
@@ -3,9 +3,11 @@
|
||||
#
|
||||
|
||||
# Each configuration option enables a list of files.
|
||||
-obj-$(CONFIG_TOUCHSCREEN_FT5364I) += fts_ts.o
|
||||
+obj-$(CONFIG_TOUCHSCREEN_FT5364I) += fts_ts.o $(fts_ts-y)
|
||||
#obj-y += fts_ts.o
|
||||
fts_ts-y += focaltech_core.o focaltech_ctl.o focaltech_ex_fun.o focaltech_gesture.o focaltech_flash.o
|
||||
extlibs :=$(PWD)/drivers/input/touchscreen/ft5364i/ft_gesture_64bit_lib_v1.0_20140820.a
|
||||
-ldflagobj-y += fts_ts.o
|
||||
-obj-y s-y +=--whole-archive $(extlibs) --no-whole-archive
|
||||
+#LDFLAGS += --whole-archive $(extlibs) --no-whole-archive
|
||||
+#ldflagobj-y += fts_ts.o
|
||||
+#obj-y s-y +=--whole-archive $(extlibs) --no-whole-archive
|
||||
+
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
Loading…
Reference in a new issue