linux-postmarketos-qcom-msm8994: update dt for h815 (MR 4915)
- add volume up/down, power key - add hall sensor - add sd card support - fix normal boot [ci:skip-build]: already built successfully in CI
This commit is contained in:
parent
a2cd4434b6
commit
59b3c1af1d
2 changed files with 57 additions and 53 deletions
|
@ -1,8 +1,8 @@
|
|||
diff --git a/arch/arm64/boot/dts/qcom/Makefile b/arch/arm64/boot/dts/qcom/Makefile
|
||||
index 2cca20563..5b6e78015 100644
|
||||
index 39889d5f8..019d7a157 100644
|
||||
--- a/arch/arm64/boot/dts/qcom/Makefile
|
||||
+++ b/arch/arm64/boot/dts/qcom/Makefile
|
||||
@@ -52,6 +52,7 @@ dtb-$(CONFIG_ARCH_QCOM) += msm8956-sony-xperia-loire-kugo.dtb
|
||||
@@ -58,6 +58,7 @@ dtb-$(CONFIG_ARCH_QCOM) += msm8956-sony-xperia-loire-kugo.dtb
|
||||
dtb-$(CONFIG_ARCH_QCOM) += msm8956-sony-xperia-loire-suzu.dtb
|
||||
dtb-$(CONFIG_ARCH_QCOM) += msm8992-lg-bullhead-rev-10.dtb
|
||||
dtb-$(CONFIG_ARCH_QCOM) += msm8992-lg-bullhead-rev-101.dtb
|
||||
|
@ -12,10 +12,10 @@ index 2cca20563..5b6e78015 100644
|
|||
dtb-$(CONFIG_ARCH_QCOM) += msm8994-huawei-angler-rev-101.dtb
|
||||
diff --git a/arch/arm64/boot/dts/qcom/msm8992-lg-h815.dts b/arch/arm64/boot/dts/qcom/msm8992-lg-h815.dts
|
||||
new file mode 100644
|
||||
index 000000000..b5b7b9c79
|
||||
index 000000000..6767e9be1
|
||||
--- /dev/null
|
||||
+++ b/arch/arm64/boot/dts/qcom/msm8992-lg-h815.dts
|
||||
@@ -0,0 +1,382 @@
|
||||
@@ -0,0 +1,386 @@
|
||||
+// SPDX-License-Identifier: GPL-2.0-only
|
||||
+
|
||||
+/dts-v1/;
|
||||
|
@ -25,11 +25,9 @@ index 000000000..b5b7b9c79
|
|||
+#include "pmi8994.dtsi"
|
||||
+
|
||||
+/delete-node/ &cont_splash_mem;
|
||||
+/delete-node/ &peripheral_region;
|
||||
+/delete-node/ &adsp_mem;
|
||||
+// /delete-node/ &audio_mem;
|
||||
+
|
||||
+/* disabled downstream */
|
||||
+/delete-node/ &dfps_data_mem;
|
||||
+/delete-node/ &mpss_mem;
|
||||
+
|
||||
+/ {
|
||||
+ model = "LG G4 (H815)";
|
||||
|
@ -41,8 +39,40 @@ index 000000000..b5b7b9c79
|
|||
+ qcom,pmic-id = <0x10009 0x1000a 0x00 0x00>;
|
||||
+ qcom,board-id = <0xb64 0>;
|
||||
+
|
||||
+ /* psci is broken */
|
||||
+ /delete-node/ psci;
|
||||
+
|
||||
+ chosen {};
|
||||
+
|
||||
+ gpio-hall-sensor {
|
||||
+ compatible = "gpio-keys";
|
||||
+
|
||||
+ pinctrl-0 = <&hall_sensor_default>;
|
||||
+ pinctrl-names = "default";
|
||||
+
|
||||
+ event-hall-sensor {
|
||||
+ gpios = <&tlmm 75 GPIO_ACTIVE_LOW>;
|
||||
+ label = "hall effect sensor";
|
||||
+ linux,input-type = <EV_SW>;
|
||||
+ linux,code = <SW_LID>;
|
||||
+ linux,can-disable;
|
||||
+ wakeup-source;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ gpio-keys {
|
||||
+ compatible = "gpio-keys";
|
||||
+ autorepeat;
|
||||
+
|
||||
+ key-vol-up {
|
||||
+ label = "volume up";
|
||||
+ gpios = <&pm8994_gpios 3 GPIO_ACTIVE_LOW>;
|
||||
+ linux,code = <KEY_VOLUMEUP>;
|
||||
+ wakeup-source;
|
||||
+ debounce-interval = <15>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ reserved-memory {
|
||||
+ #address-cells = <2>;
|
||||
+ #size-cells = <2>;
|
||||
|
@ -63,53 +93,17 @@ index 000000000..b5b7b9c79
|
|||
+ no-map;
|
||||
+ };
|
||||
+
|
||||
+ peripheral_mem: peripheral@7400000 {
|
||||
+ reg = <0 0x7400000 0 0x1c00000>;
|
||||
+ no-map;
|
||||
+ };
|
||||
+
|
||||
+ // audio_mem: audio@cb800000 {
|
||||
+ // reg = <0 0xcb800000 0 0x400000>;
|
||||
+ // no-map;
|
||||
+ // };
|
||||
+
|
||||
+ qseecom_mem: qseecom@cbc00000 {
|
||||
+ reg = <0 0xcbc00000 0 0x1800000>;
|
||||
+ no-mem;
|
||||
+ };
|
||||
+
|
||||
+ secure_mem: secure@cd400000 {
|
||||
+ reg = <0 0xcd400000 0 0x12c00000>;
|
||||
+ no-mem;
|
||||
+ };
|
||||
+
|
||||
+ memory_hole: reserved@6400000 {
|
||||
+ reg = <0 0x6400000 0 0xe00000>;
|
||||
+ no-mem;
|
||||
+ };
|
||||
+
|
||||
+ modem_mem: modem@9000000 {
|
||||
+ reg = <0 0x9000000 0 0x6400000>;
|
||||
+ no-mem;
|
||||
+ };
|
||||
+
|
||||
+ crash_fb_mem: crash_fb@4000000 {
|
||||
+ reg = <0 0x4000000 0 0xc00000>;
|
||||
+ no-mem;
|
||||
+ no-map;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&pm8994_spmi_regulators {
|
||||
+ // vdd_s2-supply = <&vph_pwr>;
|
||||
+ vdd_s8-supply = <&vph_pwr>;
|
||||
+ vdd_s11-supply = <&vph_pwr>;
|
||||
+
|
||||
+ // vdd_gfx: s2 {
|
||||
+ // regulator-min-microvolt = <980000>;
|
||||
+ // regulator-max-microvolt = <980000>;
|
||||
+ // };
|
||||
+
|
||||
+ pm8994_s8: s8 {
|
||||
+ regulator-min-microvolt = <700000>;
|
||||
+ regulator-max-microvolt = <1180000>;
|
||||
|
@ -378,23 +372,33 @@ index 000000000..b5b7b9c79
|
|||
+ };
|
||||
+};
|
||||
+
|
||||
+// &mmcc {
|
||||
+// vdd-gfx-supply = <&vdd_gfx>;
|
||||
+// };
|
||||
+&pm8994_pon {
|
||||
+ resin {
|
||||
+ status = "okay";
|
||||
+ linux,code = <KEY_VOLUMEDOWN>;
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&tlmm {
|
||||
+ hall_sensor_default: hall-sensor-default-state {
|
||||
+ pins = "gpio75";
|
||||
+ function = "gpio";
|
||||
+ drive-strength = <2>;
|
||||
+ bias-pull-up;
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+/* internal storage */
|
||||
+&sdhc1 {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ mmc-hs400-1_8v;
|
||||
+ vmmc-supply = <&pm8994_l20>;
|
||||
+ vqmmc-supply = <&pm8994_s4>;
|
||||
+ non-removable;
|
||||
+};
|
||||
+
|
||||
+/* external storage */
|
||||
+&sdhc2 {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ vmmc-supply = <&pm8994_l21>;
|
||||
+ vqmmc-supply = <&pm8994_l13>;
|
||||
+ cd-gpios = <&pm8994_gpios 8 GPIO_ACTIVE_LOW>;
|
||||
+};
|
||||
|
|
|
@ -62,5 +62,5 @@ sha512sums="
|
|||
17991b3e0cd69e910416e8b11ba48919a4ee179bf1bb8a66516897218f1bafb297754777ebee77e75f6f844a6ec79a748b10371e33ae5374a4f4accab6c6b8f7 linux-6.8.tar.gz
|
||||
18045ce30abc81bbfada6ac999fd2f49f8a4ba82ce60952b9e8d62dc6374d7dd5072adeb323efc5be37cbba1a495ad44d1bd4a9f6d195be55e11752f0fda262f config-postmarketos-qcom-msm8994.aarch64
|
||||
4dc3de184eac5cfb593a308278e3a5ab27f5e94b5dec8b288c053070f788fdb8d8fad8628b5a996701eacc11b1015999b99f8d279b207e214dd0e63f97cfb4d6 0001-arm64-dts-qcom-msm8994-huawei-angler-Add-regulators.patch
|
||||
ccb27539814382dcaea29e294c2c2ca931496f27643ce87c3cd76c3fecd5babe4a4504bd174df33e2e0c034cafbae5a4c98ed50abfa317455c5667e98fe753a3 0002-arm64-dts-qcom-msm8992-lg-h815.patch
|
||||
1293b1db2fa485f1e5fd11b6e44d71e42a3c6a2fc46b49498fc12c261729055c94edb0b081a8d0495658ba04353ac70c32377e5228c4ed2c1e43de321c628f78 0002-arm64-dts-qcom-msm8992-lg-h815.patch
|
||||
"
|
||||
|
|
Loading…
Reference in a new issue