diff --git a/device/main/device-purism-librem5/APKBUILD b/device/main/device-purism-librem5/APKBUILD
index 4eea65e6b..17d4c7271 100644
--- a/device/main/device-purism-librem5/APKBUILD
+++ b/device/main/device-purism-librem5/APKBUILD
@@ -3,9 +3,9 @@
 # Co-Maintainer: Bhushan Shah <bshah@kde.org>
 pkgname=device-purism-librem5
 pkgdesc="Purism Librem 5 Phone"
-pkgver=1.35
+pkgver=1.36
 pkgrel=0
-_confver=52
+_confver=54
 _purismrel=1
 # <librem5-base ver>.<purism release>
 _purismver=${_confver}pureos$_purismrel
@@ -42,6 +42,7 @@ source="
 	70-librem5-xwayland-accel.sh
 	0002-udev-cameras-use-correct-path-for-modprobe-on-Alpine.patch
 	l5-ship-mode.initd
+	l5-lockdown-support.initd
 "
 subpackages="
 	$pkgname-nonfree-firmware:nonfree_firmware
@@ -127,7 +128,7 @@ package() {
 	for f in "$builddir"/debian/*.udev; do
 		# rename the udev rules, dropping the default prefix and (arbitrarily...) using "85-"
 		install -Dm644 "$f" \
-			"$pkgdir"/usr/lib/udev/rules.d/85-"$(basename ${f//librem5-base-defaults./})"
+			"$pkgdir"/usr/lib/udev/rules.d/85-"$(basename ${f//librem5-base-defaults./}).rules"
 	done
 
 	# Wifi / PM
@@ -150,6 +151,14 @@ package() {
 	install -D -m755 "$srcdir"/l5-ship-mode.initd \
 		"$pkgdir"/etc/init.d/l5-ship-mode
 
+	# lockdown support
+	install -Dm755 "$builddir"/default/lockdown-support/lockdown-support.sh \
+		-t "$pkgdir"/usr/sbin/
+	install -Dm755 "$builddir"/default/lockdown-support/modprobe.d/librem5-lsm9ds1.conf \
+		-t "$pkgdir"/etc/modprobe.d/
+	install -Dm755 "$srcdir"/l5-lockdown-support.initd \
+		"$pkgdir"/etc/init.d/l5-lockdown-support
+
 	devicepkg_package $startdir $pkgname
 }
 
@@ -160,7 +169,7 @@ nonfree_firmware() {
 }
 
 sha512sums="
-fb1bf84a36db29dcd70753e6f5b3d5b574f89efd2277676d89574400da84ca825fae548cbc3d76af1b3a8a38430fc611933ecb7c27ee78c47957313f057ce754  librem5-base-pureos-52pureos1.tar.gz
+bd479afaa9bfc96bfd0719654947ff031f060c988d20e5de8c170bf51ab32dd0ca9a499f24cdc95abf1a3bc131acdf94cd9aab12bd5eb43f222cb676f4efd19b  librem5-base-pureos-54pureos1.tar.gz
 2e72d9a084ecd6c96cafbbd8fda461ae8b2ebd14ffda601d9f36d73f08f04088213de17da078293ddd958d4c76d33148c7af6e252eb0709f6934855a55578509  00-mesa.sh
 8b6fa7b12c15f439c561901f3ffe24a1ef2a0c343401c0a79281060854ab29e08a1fb5e7adae8684b12aa9f535ed99e2dad993dce9724822cb0fbf2497dd86e5  70-wifi-pm.rules
 00355d9ad085a77e157f3c62eb4f1bcac2823d3b341e34d1128edbfb1444fba83e8eacd263ea61da9f6d853f1328ab7fbe5ea63bd08c8a1bc9b8eaf44ae1f1c6  77-mm-broadmobi-port-types.rules
@@ -175,4 +184,5 @@ a0740e405781ec6ef765fdc9f5700c95adbb241c45c97b9384ba68cdece662cb216ca5918640042f
 fad386071fc45f9880a94cc8004fabd5d98b3e6a12606c98d8e72e0208f22ab54f03b921f5967a959782507e2bff67d2fa92e46d8cd242011a3afcdbda529279  70-librem5-xwayland-accel.sh
 b45749fcddfd65a302b502bcabfa5828d1b63e45d844fd50e44009a756b919db20fe9526102947c0f0dfcdffe4a037e5050fe1b24fb915933ce0837f49759378  0002-udev-cameras-use-correct-path-for-modprobe-on-Alpine.patch
 c723764d507ccd4b04aa5ce79b1d1ebc131873cdc37a943cb0f92b8a08a3c69eb9e0d31fcd4589fd8c40a9676bae9897e4f12ec2ebe4db8214ac85669ef35a53  l5-ship-mode.initd
+f4b314d553655f7975445ac0a33099923e20dabb082c07e2cf6a78e4118c143d777dd4ad2c09cbc388600bdefe8deb3073fbd15b238772ddf09c66ac46415590  l5-lockdown-support.initd
 "
diff --git a/device/main/device-purism-librem5/device-purism-librem5.post-install b/device/main/device-purism-librem5/device-purism-librem5.post-install
index c478280b0..83d6a19d1 100644
--- a/device/main/device-purism-librem5/device-purism-librem5.post-install
+++ b/device/main/device-purism-librem5/device-purism-librem5.post-install
@@ -6,6 +6,7 @@ sed -i 's|# nmea-socket=/var/run/gps-share.sock|nmea-socket=/var/run/gnss-share.
 rc-update -qq del gpsd
 rc-update -q add gnss-share
 rc-update -q add l5-ship-mode shutdown
+rc-update -q add l5-lockdown-support
 
 # Clean up any old, unneeded legacy u-boot images from /boot
 for f in uInitrd uImage; do
diff --git a/device/main/device-purism-librem5/l5-lockdown-support.initd b/device/main/device-purism-librem5/l5-lockdown-support.initd
new file mode 100644
index 000000000..4035569f8
--- /dev/null
+++ b/device/main/device-purism-librem5/l5-lockdown-support.initd
@@ -0,0 +1,9 @@
+#!/sbin/openrc-run
+name="Purism Librem 5 Lockdown Support"
+
+start()
+{
+	ebegin "Enabling lockdown support"
+        /usr/sbin/lockdown-support.sh
+	eend 0
+}