asus-x00p: new device (Asus Max M1) (MR 5028)
Signed-off-by: Saalim Quadri <danascape@gmail.com>
This commit is contained in:
parent
c0e3ea11e0
commit
583ab0a2fe
8 changed files with 4874 additions and 0 deletions
33
device/testing/device-asus-x00p/APKBUILD
Normal file
33
device/testing/device-asus-x00p/APKBUILD
Normal file
|
@ -0,0 +1,33 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-asus-x00p
|
||||
pkgdesc="Asus Max M1"
|
||||
pkgver=1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="aarch64"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-asus-x00p
|
||||
mkbootimg
|
||||
postmarketos-base
|
||||
msm-fb-refresher
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
source="
|
||||
deviceinfo
|
||||
initfs-hook.sh
|
||||
"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
ece85df3931736b933e934a46ec6aa2a84fb7511d2c6000a60b5f9064f4d8a0d53b11c7356de6bee3d57e29776b67000c50c5a88311ce0490857effcbb60aebd deviceinfo
|
||||
23d8031d87e3e01a76886d0ad091c51f3146cd2ded947f32e47bcf84413882c3be0fcbdd559a7fc3d3372c42510c276d37741e836ca9aa4549142e43a625cc79 initfs-hook.sh
|
||||
"
|
29
device/testing/device-asus-x00p/deviceinfo
Normal file
29
device/testing/device-asus-x00p/deviceinfo
Normal file
|
@ -0,0 +1,29 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Asus Max M1"
|
||||
deviceinfo_manufacturer="Asus"
|
||||
deviceinfo_codename="asus-x00p"
|
||||
deviceinfo_year="2018"
|
||||
deviceinfo_arch="aarch64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="handset"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="androidboot.hardware=qcom msm_rtb.filter=0x237 ehci-hcd.park=3 lpm_levels.sleep_disabled=1 androidboot.bootdevice=7824900.sdhci loop.max_part=7 androidboot.init_fatal_reboot_target=recovery buildvariant=userdebug"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_flash_offset_base="0x80000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x80000000"
|
||||
deviceinfo_flash_offset_second="0x80000000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
4
device/testing/device-asus-x00p/initfs-hook.sh
Normal file
4
device/testing/device-asus-x00p/initfs-hook.sh
Normal file
|
@ -0,0 +1,4 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Enable Display
|
||||
cat /sys/class/graphics/fb0/modes > /sys/class/graphics/fb0/mode
|
62
device/testing/linux-asus-x00p/APKBUILD
Normal file
62
device/testing/linux-asus-x00p/APKBUILD
Normal file
|
@ -0,0 +1,62 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm64/configs/X00P_defconfig
|
||||
|
||||
pkgname=linux-asus-x00p
|
||||
pkgver=3.18.140
|
||||
pkgrel=0
|
||||
pkgdesc="Asus Max M1 kernel fork"
|
||||
arch="aarch64"
|
||||
_carch="arm64"
|
||||
_flavor="asus-x00p"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
findutils
|
||||
flex
|
||||
openssl-dev
|
||||
perl
|
||||
"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_asus_msm8937"
|
||||
_commit="d6a60bdad63f7b50edcd93ebc7790c1dab7ce09f"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
always-boot-to-initramfs.patch
|
||||
linux3.7to4.5-ARM64-remove-Sun-Solaris-style-flag-on-section.patch
|
||||
fix_mdp3_ctrl_off.patch
|
||||
"
|
||||
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" \
|
||||
"$_flavor" "$_outdir"
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
09b02b3a2e4d99e717170ff4ef6d7fe2bf71bece23d2e5acccfb7a15a110f8c89f2b14ba6aab8f39482ab4e3e7929ef3c5a910107caa408d6ad3e8b7ca0196e7 linux-asus-x00p-d6a60bdad63f7b50edcd93ebc7790c1dab7ce09f.tar.gz
|
||||
5163960433de3064bcaa1651fa73fb10848a6f04fdb09bcd57185cc24ba1cb8eaea5c417de7f0739a4be8b82c9b8479b2af903865c6d1cb6b39a335200a2352d config-asus-x00p.aarch64
|
||||
8c10d536075009ef3fc636db50c706820751eebf8c581c06e16f2e68776b73e7c2369fcfc0c7bbb7f4be462df39fd82234efaacd7654de96367aaf117a98fd5a always-boot-to-initramfs.patch
|
||||
75545ccd0082a119b9ad95fcef3523c939a5c946f8f3a5c3dde15cee1502f6c1011050a0ad5359426f018bb7ceea1c97a28c7665941bc89f365c8d11065ce0f6 linux3.7to4.5-ARM64-remove-Sun-Solaris-style-flag-on-section.patch
|
||||
fbc61e379403990167853f4c4fbdfa22d7e9661a7eedecf2a75eec2a8008991a82d0a61be844ab4b1c88383f3fa79b43eff10b1039e44ad5a758a173cbf6386b fix_mdp3_ctrl_off.patch
|
||||
"
|
|
@ -0,0 +1,22 @@
|
|||
From c8eaf96c743d667806eceeca238c247770b2029f Mon Sep 17 00:00:00 2001
|
||||
From: r3vn <giuseppe.corti@protonmail.com>
|
||||
Date: Fri, 4 Sep 2020 00:20:30 +0200
|
||||
Subject: [PATCH] (halium) always boot to initramfs
|
||||
|
||||
---
|
||||
init/initramfs.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/init/initramfs.c b/init/initramfs.c
|
||||
index bf3af10c500a..858631138dd0 100644
|
||||
--- a/init/initramfs.c
|
||||
+++ b/init/initramfs.c
|
||||
@@ -613,7 +613,7 @@ static int __init skip_initramfs_param(char *str)
|
||||
{
|
||||
if (*str)
|
||||
return 0;
|
||||
- do_skip_initramfs = 1;
|
||||
+ do_skip_initramfs = 0;
|
||||
return 1;
|
||||
}
|
||||
__setup("skip_initramfs", skip_initramfs_param);
|
4710
device/testing/linux-asus-x00p/config-asus-x00p.aarch64
Normal file
4710
device/testing/linux-asus-x00p/config-asus-x00p.aarch64
Normal file
File diff suppressed because it is too large
Load diff
13
device/testing/linux-asus-x00p/fix_mdp3_ctrl_off.patch
Normal file
13
device/testing/linux-asus-x00p/fix_mdp3_ctrl_off.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/drivers/video/msm/mdss/mdp3_ctrl.c b/drivers/video/msm/mdss/mdp3_ctrl.c
|
||||
index f9f55138..ccaebcb6 100644
|
||||
--- a/drivers/video/msm/mdss/mdp3_ctrl.c
|
||||
+++ b/drivers/video/msm/mdss/mdp3_ctrl.c
|
||||
@@ -1832,7 +1832,7 @@ int mdp3_ctrl_init(struct msm_fb_data_type *mfd)
|
||||
splash_mismatch = 1;
|
||||
|
||||
mdp3_interface->on_fnc = mdp3_ctrl_on;
|
||||
- mdp3_interface->off_fnc = mdp3_ctrl_off;
|
||||
+ mdp3_interface->off_fnc = NULL;
|
||||
mdp3_interface->do_histogram = NULL;
|
||||
mdp3_interface->cursor_update = NULL;
|
||||
mdp3_interface->dma_fnc = mdp3_ctrl_pan_display;
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/linux3.7to4.5-ARM64-remove-Sun-Solaris-style-flag-on-section.patch
|
Loading…
Reference in a new issue