temp/phosh: copy fork from v20.05 branch (MR 1546)
Set pkgver to 9999, so it is always preferred over the Alpine edge version.
This commit is contained in:
parent
7cf6bae884
commit
4e59a58aa2
5 changed files with 139 additions and 0 deletions
26
temp/phosh/0001-PMOS-Hide-Logout-action.patch
Normal file
26
temp/phosh/0001-PMOS-Hide-Logout-action.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From d0ed89ba5902a5f301f102f8073098525e3c11ad Mon Sep 17 00:00:00 2001
|
||||
From: Luca Weiss <luca@z3ntu.xyz>
|
||||
Date: Thu, 23 Jul 2020 22:10:18 +0200
|
||||
Subject: [PATCH 2/2] PMOS: Hide Logout action
|
||||
|
||||
It doesn't work on pmOS and we don't need it.
|
||||
---
|
||||
src/ui/top-panel.ui | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/ui/top-panel.ui b/src/ui/top-panel.ui
|
||||
index a91e9c4..7c6791b 100644
|
||||
--- a/src/ui/top-panel.ui
|
||||
+++ b/src/ui/top-panel.ui
|
||||
@@ -17,7 +17,7 @@
|
||||
</child>
|
||||
<child>
|
||||
<object class="GtkModelButton">
|
||||
- <property name="visible">True</property>
|
||||
+ <property name="visible">False</property>
|
||||
<property name="action-name">panel.logout</property>
|
||||
<property name="text" translatable="yes">Logout</property>
|
||||
</object>
|
||||
--
|
||||
2.27.0
|
||||
|
|
@ -0,0 +1,34 @@
|
|||
Patch from upstream:
|
||||
https://source.puri.sm/Librem5/phosh/-/commit/d1da5ea7d18c6794c9a7d2f41355fe90d4115ac1
|
||||
|
||||
From 3036049454349fee74867b42c159a8eb49b5b00f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Guido=20G=C3=BCnther?= <agx@sigxcpu.org>
|
||||
Date: Tue, 4 Aug 2020 08:22:39 +0200
|
||||
Subject: [PATCH] timestamp-label: Unbreak build on 32 bit platforms
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Use a G_ format specifier for GTimeSpan.
|
||||
|
||||
Signed-off-by: Guido Günther <guido.gunther@puri.sm>
|
||||
---
|
||||
src/notifications/timestamp-label.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/notifications/timestamp-label.c b/src/notifications/timestamp-label.c
|
||||
index 0aa04ce..a5a4d5e 100644
|
||||
--- a/src/notifications/timestamp-label.c
|
||||
+++ b/src/notifications/timestamp-label.c
|
||||
@@ -255,7 +255,7 @@ phosh_timestamp_label_calc_timeout (PhoshTimestampLabel *self)
|
||||
break;
|
||||
}
|
||||
timeout_diff = g_date_time_difference (timeout_time, time_now);
|
||||
- g_debug ("time out duration = %ld", timeout_diff);
|
||||
+ g_debug ("time out duration: %" G_GINT64_FORMAT, timeout_diff);
|
||||
return timeout_diff;
|
||||
}
|
||||
|
||||
--
|
||||
2.20.1
|
||||
|
56
temp/phosh/APKBUILD
Normal file
56
temp/phosh/APKBUILD
Normal file
|
@ -0,0 +1,56 @@
|
|||
# Forked from Alpine to apply Hide-Logout-action patch
|
||||
pkgname=phosh
|
||||
pkgver=9999
|
||||
_pkgver=0.4.3
|
||||
pkgrel=0
|
||||
pkgdesc="Shell PoC for the Librem5"
|
||||
# Blocked on mips and s390x by gnome-session, gnome-settings-daemon, squeekboard and libhandy
|
||||
# Blocked on ppc64le by gnome-session
|
||||
arch="all !s390x !ppc64le !mips !mips64"
|
||||
url="https://source.puri.sm/Librem5/phosh"
|
||||
license="GPL-3.0-only"
|
||||
depends="wayland-protocols phoc gnome-session bash dbus-x11 gnome-settings-daemon
|
||||
squeekboard libpulse dbus:org.freedesktop.Secrets elogind gnome-control-center"
|
||||
makedepends="gtk+3.0-dev meson ninja gnome-desktop-dev libhandy-dev gcr-dev upower-dev
|
||||
linux-pam-dev git cmake pulseaudio-dev networkmanager-dev polkit-elogind-dev
|
||||
libsecret-dev feedbackd-dev"
|
||||
subpackages="$pkgname-lang"
|
||||
source="$pkgname-$_pkgver.tar.xz::https://repo.pureos.net/pureos/pool/main/p/phosh/phosh_$_pkgver.tar.xz
|
||||
phosh.desktop
|
||||
sm.puri.OSK0.desktop
|
||||
0001-PMOS-Hide-Logout-action.patch
|
||||
0002-timestamp-label-Unbreak-build-on-32-bit-platforms.patch
|
||||
"
|
||||
options="!check" # Needs a running Wayland compositor
|
||||
builddir="$srcdir/$pkgname-$_pkgver"
|
||||
|
||||
build() {
|
||||
meson \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--mandir=/usr/share/man \
|
||||
--localstatedir=/var \
|
||||
--buildtype=plain \
|
||||
. output
|
||||
ninja -C output
|
||||
}
|
||||
|
||||
check() {
|
||||
ninja -C output test
|
||||
}
|
||||
|
||||
package() {
|
||||
DESTDIR="$pkgdir/" ninja -C output install
|
||||
|
||||
install -D -m644 "$srcdir"/phosh.desktop \
|
||||
"$pkgdir"/usr/share/wayland-sessions/phosh.desktop
|
||||
|
||||
install -D -m644 "$srcdir"/sm.puri.OSK0.desktop \
|
||||
"$pkgdir"/usr/share/applications/sm.puri.OSK0.desktop
|
||||
|
||||
}
|
||||
sha512sums="43eec9987daec6f220e853021a8e32cfdb00f73e097479847e846ab318d506419f8d4d0712ff8f12d2e7b1b863a9edbf4465ad430df092b593f0b06d24bc27b1 phosh-0.4.3.tar.xz
|
||||
6644870edbbbc6b88d6e19f7771d81dba1a11066c2b34e4c22736db73a2dfd0d4909b4967503059c35385c5139a834a5c06a3c56b148ba1275d7f089c0c5f33c phosh.desktop
|
||||
f97019598323276cf97ae62f04b6245983198e04b228ddc605835ee46845d9b88c6890fb86e97e4bb6f1ad73361437d9ed18c91e81fe1284a88cdcb92d3fdc69 sm.puri.OSK0.desktop
|
||||
f289c8a9db01741058881ca6b20c386fcd87f00d3f638f1d32d181bed70d36e9696d84f4c210b581138fff6fceeafa5dcbcb4e1097f04eb29d8cee2930ca4446 0001-PMOS-Hide-Logout-action.patch
|
||||
3e7eae0a9b9977a38f7a894cc0e4e319d3b7a8a6fdc02cc3ce1d14461c998e44da9bced494c8c820584709da6e25a48347f530ef0237239fd88e52a862aae92f 0002-timestamp-label-Unbreak-build-on-32-bit-platforms.patch"
|
11
temp/phosh/phosh.desktop
Normal file
11
temp/phosh/phosh.desktop
Normal file
|
@ -0,0 +1,11 @@
|
|||
[Desktop Entry]
|
||||
Name=Phosh
|
||||
Name[en]=Phosh
|
||||
Comment=This session logs you into Phosh
|
||||
Comment[en]=This session logs in you into Phosh
|
||||
Exec=dbus-run-session /usr/bin/phosh
|
||||
TryExec=/usr/bin/phosh
|
||||
Icon=
|
||||
Type=Application
|
||||
X-DesktopNames=Phosh
|
||||
Keywords=launch;Phosh;desktop;session;
|
12
temp/phosh/sm.puri.OSK0.desktop
Normal file
12
temp/phosh/sm.puri.OSK0.desktop
Normal file
|
@ -0,0 +1,12 @@
|
|||
[Desktop Entry]
|
||||
Type=Application
|
||||
Name=On-screen keyboard
|
||||
Comment=Default on-screen keyboard
|
||||
Exec=/usr/bin/osk-wayland
|
||||
Categories=GNOME;Core;
|
||||
OnlyShowIn=GNOME;
|
||||
NoDisplay=true
|
||||
X-GNOME-Autostart-Phase=Panel
|
||||
X-GNOME-Provides=inputmethod
|
||||
X-GNOME-Autostart-Notify=true
|
||||
X-GNOME-AutoRestart=true
|
Loading…
Reference in a new issue