xiaomi-scorpio: new device (Xiaomi Mi Note 2) (MR 1576)
* use shared multiple yylloc definition patch (MR 1576)
This commit is contained in:
parent
2a34837dc7
commit
4d8473e255
6 changed files with 4752 additions and 0 deletions
30
device/testing/device-xiaomi-scorpio/APKBUILD
Normal file
30
device/testing/device-xiaomi-scorpio/APKBUILD
Normal file
|
@ -0,0 +1,30 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-xiaomi-scorpio
|
||||
pkgdesc="Xiaomi Mi Note 2"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="aarch64"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-xiaomi-scorpio
|
||||
mdss-fb-init-hack
|
||||
mesa-dri-gallium
|
||||
mkbootimg
|
||||
postmarketos-base
|
||||
reboot-mode
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="06a42c3ebd24b96498a10ec87a8ce4b6c3e5663082b556da5033c1556364f35cca2a808d5bd257c70e541334d35e32cd01c65a1bebf6b34aa4c4c6eb034a6676 deviceinfo"
|
32
device/testing/device-xiaomi-scorpio/deviceinfo
Normal file
32
device/testing/device-xiaomi-scorpio/deviceinfo
Normal file
|
@ -0,0 +1,32 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Xiaomi Mi Note 2"
|
||||
deviceinfo_manufacturer="Xiaomi"
|
||||
deviceinfo_codename="xiaomi-scorpio"
|
||||
deviceinfo_year="2016"
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_arch="aarch64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="handset"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="false"
|
||||
deviceinfo_screen_width="1080"
|
||||
deviceinfo_screen_height="1920"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_flash_sparse="true"
|
||||
deviceinfo_kernel_cmdline="androidboot.hardware=qcom ehci-hcd.park=3 lpm_levels.sleep_disabled=1 cma=32M@0-0xffffffff loop.max_part=7 buildvariant=userdebug"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_offset_base="0x80000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="4096"
|
||||
deviceinfo_rootfs_image_sector_size="4096"
|
54
device/testing/linux-xiaomi-scorpio/APKBUILD
Normal file
54
device/testing/linux-xiaomi-scorpio/APKBUILD
Normal file
|
@ -0,0 +1,54 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm64/configs/scorpio_defconfig
|
||||
|
||||
pkgname=linux-xiaomi-scorpio
|
||||
pkgver=3.18.124
|
||||
pkgrel=0
|
||||
pkgdesc="Xiaomi Mi Note 2 kernel fork"
|
||||
arch="aarch64"
|
||||
_carch="arm64"
|
||||
_flavor="xiaomi-scorpio"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="bash bc bison devicepkg-dev flex openssl-dev perl gcc6"
|
||||
|
||||
# Compiler: GCC 6 (doesn't boot when compiled with newer versions)
|
||||
if [ "${CC:0:5}" != "gcc6-" ]; then
|
||||
CC="gcc6-$CC"
|
||||
HOSTCC="gcc6-gcc"
|
||||
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
|
||||
fi
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_xiaomi_msm8996"
|
||||
_commit="8e27b438e8da6c6713b65da75f035438c45b05b9"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
gcc10-extern_YYLOC_global_declaration.patch
|
||||
struct-rndis-incomplete-type.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
}
|
||||
|
||||
sha512sums="97e9ef9f930923cee2351eeb22bc99c2df438701c17b88c221879fa336f84beb0328b772f0f19b2f39713a8d4f2d22139634f57ca6ade00f5190d7553db58002 linux-xiaomi-scorpio-8e27b438e8da6c6713b65da75f035438c45b05b9.tar.gz
|
||||
6062ed789e5da3491badbbbadc40b259524f688cea63f09502fa1e57c93a89ac397e29335375ccb80b71f55a0b021f6283a8c5f7b0c09ca64dbea08270c64935 config-xiaomi-scorpio.aarch64
|
||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||
c64c63702c1638987640cf80dc8c36488ad0bc1c4ce6a875b9b98f3de1f1ae1435be7ff7f8b0b164f28ac79a22cf70f3d3fb6c28d8c162b7162ef8ac6f95e02d struct-rndis-incomplete-type.patch"
|
4620
device/testing/linux-xiaomi-scorpio/config-xiaomi-scorpio.aarch64
Normal file
4620
device/testing/linux-xiaomi-scorpio/config-xiaomi-scorpio.aarch64
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
|
@ -0,0 +1,15 @@
|
|||
Include needed header to fix invalid application of `sizeof' to incomplete type
|
||||
---
|
||||
diff --git a/drivers/usb/gadget/function/u_ether.c b/drivers/usb/gadget/function/u_ether.c
|
||||
index fbf3cd19ee63..a575ff81f6f7 100644
|
||||
--- a/drivers/usb/gadget/function/u_ether.c
|
||||
+++ b/drivers/usb/gadget/function/u_ether.c
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <linux/notifier.h>
|
||||
#include <linux/cpufreq.h>
|
||||
#include "u_ether.h"
|
||||
+#include "rndis.h"
|
||||
|
||||
|
||||
/*
|
||||
|
Loading…
Reference in a new issue