lg-p880: new device (LG Optimus 4X HD) (MR 2533)
https://wiki.postmarketos.org/wiki/LG_Optimus_4X_HD_(lg-p880) [ci:skip-build] Already built on CI in MR
This commit is contained in:
parent
6aea56cd98
commit
4bf9572291
9 changed files with 3684 additions and 0 deletions
29
device/testing/device-lg-p880/APKBUILD
Normal file
29
device/testing/device-lg-p880/APKBUILD
Normal file
|
@ -0,0 +1,29 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-lg-p880
|
||||
pkgdesc="LG Optimus 4X HD"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="armv7"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-lg-p880
|
||||
mesa-dri-gallium
|
||||
mkbootimg
|
||||
postmarketos-base
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
89b233829a86b3e0282cfb15a260d15da3d0e159000e2af33fd21fb16d48c329cb4f603fbf091891f748122e53bb2875b3cdbe96ac12e9b65cb914eca80eb6a2 deviceinfo
|
||||
"
|
30
device/testing/device-lg-p880/deviceinfo
Normal file
30
device/testing/device-lg-p880/deviceinfo
Normal file
|
@ -0,0 +1,30 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="LG Optimus 4X HD"
|
||||
deviceinfo_manufacturer="LG"
|
||||
deviceinfo_codename="lg-p880"
|
||||
deviceinfo_year="2012"
|
||||
deviceinfo_arch="armv7"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="handset"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="720"
|
||||
deviceinfo_screen_height="1280"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_flash_offset_base="0x10000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
17
device/testing/linux-lg-p880/0000-patch.patch
Normal file
17
device/testing/linux-lg-p880/0000-patch.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
From: Peter Foley <pefoley2@verizon.net>
|
||||
|
||||
Fix this warning by removing a unneeded use of defined
|
||||
|
||||
diff --git a/kernel/timeconst.pl b/kernel/timeconst.pl
|
||||
index eb51d76..0461239 100644
|
||||
--- a/kernel/timeconst.pl
|
||||
+++ b/kernel/timeconst.pl
|
||||
@@ -370,7 +370,7 @@ if ($hz eq '--can') {
|
||||
}
|
||||
|
||||
@val = @{$canned_values{$hz}};
|
||||
- if (!defined(@val)) {
|
||||
+ if (!@val) {
|
||||
@val = compute_values($hz);
|
||||
}
|
||||
output($hz, @val);
|
72
device/testing/linux-lg-p880/APKBUILD
Normal file
72
device/testing/linux-lg-p880/APKBUILD
Normal file
|
@ -0,0 +1,72 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm/configs/x3_defconfig
|
||||
|
||||
pkgname=linux-lg-p880
|
||||
pkgver=3.1.10
|
||||
pkgrel=0
|
||||
pkgdesc="LG Optimus 4X HD kernel fork"
|
||||
arch="armv7"
|
||||
_carch="arm"
|
||||
_flavor="lg-p880"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
flex
|
||||
gcc4
|
||||
openssl-dev
|
||||
perl
|
||||
xz
|
||||
"
|
||||
|
||||
# Compiler: GCC 4 (doesn't boot when compiled with newer versions)
|
||||
if [ "${CC:0:5}" != "gcc4-" ]; then
|
||||
CC="gcc4-$CC"
|
||||
HOSTCC="gcc4-gcc"
|
||||
CROSS_COMPILE="gcc4-$CROSS_COMPILE"
|
||||
fi
|
||||
|
||||
# Source
|
||||
_repository="lge-kernel-p880"
|
||||
_commit="413b3fc527c086450f28acbe92893c71e73ad5b6"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
gcc8-fix-put-user.patch
|
||||
gcc10-extern_YYLOC_global_declaration.patch
|
||||
kernel-use-the-gnu89-standard-explicitly.patch
|
||||
0000-patch.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
214f82f5f63eb544ef80929489853a6188bb831b25275ed71b6e2c00e48e282e81af6b9a8968532bfd155d75e3271d768f367366f84a6ae09d856042b00dacf7 linux-lg-p880-413b3fc527c086450f28acbe92893c71e73ad5b6.tar.gz
|
||||
4cd9efb7edc9d675c10bb7ed9567fa08f3d8558756dae497378c08163bb701819f939a8387406b4bc84724636d27e069ad47794e60fdbb040b211cf6dd6d3929 config-lg-p880.armv7
|
||||
77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7 gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||
ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c kernel-use-the-gnu89-standard-explicitly.patch
|
||||
41d9bf4aab6aa3f31cb13a477dadc1c35ccad9df536f495dec1065ab8152cf1fee6e18cba371d437c8d19c6b750e0c375774cc9e0e04e54268a6decd2bfe0d22 0000-patch.patch
|
||||
"
|
3532
device/testing/linux-lg-p880/config-lg-p880.armv7
Normal file
3532
device/testing/linux-lg-p880/config-lg-p880.armv7
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc7-give-up-on-ilog2-const-optimizations.patch
|
1
device/testing/linux-lg-p880/gcc8-fix-put-user.patch
Symbolic link
1
device/testing/linux-lg-p880/gcc8-fix-put-user.patch
Symbolic link
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc8-fix-put-user.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/kernel-use-the-gnu89-standard-explicitly.patch
|
Loading…
Reference in a new issue