oneplus-instantnoodlep: new device (MR 3993)
This commit is contained in:
parent
f5d3a42f1d
commit
372287e23c
13 changed files with 7353 additions and 0 deletions
43
device/testing/device-oneplus-instantnoodlep/APKBUILD
Normal file
43
device/testing/device-oneplus-instantnoodlep/APKBUILD
Normal file
|
@ -0,0 +1,43 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-oneplus-instantnoodlep
|
||||
pkgdesc="OnePlus 8 Pro"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="aarch64"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
mkbootimg
|
||||
postmarketos-base
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
subpackages="
|
||||
$pkgname-kernel-downstream:kernel_downstream
|
||||
$pkgname-nonfree-firmware:nonfree_firmware
|
||||
"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
kernel_downstream() {
|
||||
pkgdesc="Downstream kernel (not recommended, for debugging purposes)"
|
||||
depends="linux-oneplus-instantnoodlep"
|
||||
devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
|
||||
}
|
||||
|
||||
nonfree_firmware() {
|
||||
pkgdesc="Firmware for OnePlus 8 Pro"
|
||||
depends="firmware-oneplus-instantnoodlep"
|
||||
mkdir "$subpkgdir"
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
e6f01d250e86dd8f2ec60019bc470b5c6adb5e271dff9bd8420268709f33691db2a756194664539edd95f201ccf69301f953e644a87b298500561c02d0898792 deviceinfo
|
||||
"
|
42
device/testing/device-oneplus-instantnoodlep/deviceinfo
Normal file
42
device/testing/device-oneplus-instantnoodlep/deviceinfo
Normal file
|
@ -0,0 +1,42 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="OnePlus 8 Pro"
|
||||
deviceinfo_manufacturer="OnePlus"
|
||||
deviceinfo_codename="oneplus-instantnoodlep"
|
||||
deviceinfo_year="2020"
|
||||
deviceinfo_arch="aarch64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="handset"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="false"
|
||||
deviceinfo_screen_width="1440"
|
||||
deviceinfo_screen_height="3168"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline_downstream="androidboot.console=ttyMSM0 androidboot.hardware=qcom androidboot.memcg=1 androidboot.usbcontroller=a600000.dwc3 cgroup.memory=nokmem,nosocket loop.max_part=7 lpm_levels.sleep_disabled=1 msm_rtb.filter=0x237 reboot=panic_warm service_locator.enable=1 swiotlb=2048 buildvariant=userdebug printk.devkmsg=on"
|
||||
deviceinfo_kernel_cmdline_mainline="clk_ignore_unused pd_ignore_unused"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_pagesize="4096"
|
||||
deviceinfo_header_version_downstream="0"
|
||||
deviceinfo_header_version_mainline="2"
|
||||
deviceinfo_append_dtb="false"
|
||||
deviceinfo_dtb_mainline="qcom/sm8250-oneplus-instantnoodlep"
|
||||
deviceinfo_flash_offset_dtb="0x01f00000"
|
||||
deviceinfo_flash_offset_base="0x00000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00000000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_fastboot_partition_system="super"
|
||||
deviceinfo_flash_fastboot_partition_dtbo="dtbo"
|
||||
deviceinfo_super_partitions="/dev/sda14 /dev/sda14"
|
||||
deviceinfo_rootfs_image_sector_size="4096"
|
||||
deviceinfo_flash_sparse="true"
|
93
device/testing/firmware-oneplus-instantnoodlep/APKBUILD
Normal file
93
device/testing/firmware-oneplus-instantnoodlep/APKBUILD
Normal file
|
@ -0,0 +1,93 @@
|
|||
pkgname=firmware-oneplus-instantnoodlep
|
||||
pkgver=1
|
||||
pkgrel=0
|
||||
pkgdesc="Firmware for OnePlus 8 Pro (instantnoodlep)"
|
||||
url="https://github.com/pangwalla/oneplus-instantnoodlep-firmware"
|
||||
arch="aarch64"
|
||||
license="proprietary"
|
||||
options="!check !strip !archcheck !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
qca-swiss-army-knife
|
||||
pil-squasher
|
||||
"
|
||||
replaces="
|
||||
linux-firmware-ath11k
|
||||
linux-firmware-qca
|
||||
linux-firmware-qcom
|
||||
"
|
||||
subpackages="
|
||||
$pkgname-adsp:adsp
|
||||
$pkgname-bluetooth:bluetooth
|
||||
$pkgname-cdsp:cdsp
|
||||
$pkgname-gpu:gpu
|
||||
$pkgname-ipa:ipa
|
||||
$pkgname-modem:modem
|
||||
$pkgname-slpi:slpi
|
||||
$pkgname-wifi:wifi
|
||||
$pkgname-venus:venus
|
||||
"
|
||||
_commit="2dce2681689fcf615198c663555c5a7c7b3650ba"
|
||||
source="https://github.com/pangwalla/oneplus-instantnoodlep-firmware/archive/$_commit/oneplus-instantnoodlep-firmware-$_commit.tar.gz"
|
||||
builddir="$srcdir/oneplus-instantnoodlep-firmware-$_commit"
|
||||
|
||||
package() {
|
||||
mkdir -p "$pkgdir"
|
||||
}
|
||||
|
||||
adsp() {
|
||||
pil-squasher "$builddir/adsp/adsp.mbn" "$builddir/adsp/adsp.mdt"
|
||||
install -Dm644 "$builddir/adsp/adsp.mbn" -t $subpkgdir/lib/firmware/postmarketos
|
||||
}
|
||||
|
||||
bluetooth() {
|
||||
for file in $builddir/bluetooth/*; do
|
||||
install -Dm644 $file -t "$subpkgdir/lib/firmware/qca/"
|
||||
done
|
||||
}
|
||||
|
||||
cdsp() {
|
||||
pil-squasher "$builddir/cdsp/cdsp.mbn" "$builddir/cdsp/cdsp.mdt"
|
||||
install -Dm644 "$builddir/cdsp/cdsp.mbn" -t $subpkgdir/lib/firmware/postmarketos
|
||||
}
|
||||
|
||||
gpu() {
|
||||
for file in $builddir/gpu/*; do
|
||||
install -Dm644 $file -t "$subpkgdir/lib/firmware/qcom/"
|
||||
done
|
||||
}
|
||||
|
||||
ipa() {
|
||||
pil-squasher "$builddir/ipa/ipa_fws.mbn" "$builddir/ipa/ipa_fws.mdt"
|
||||
install -Dm644 "$builddir/ipa/ipa_fws.mbn" -t $subpkgdir/lib/firmware/postmarketos
|
||||
|
||||
pil-squasher "$builddir/ipa/ipa_uc.mbn" "$builddir/ipa/ipa_uc.mdt"
|
||||
install -Dm644 "$builddir/ipa/ipa_uc.mbn" -t $subpkgdir/lib/firmware/postmarketos
|
||||
}
|
||||
|
||||
modem() {
|
||||
for file in $builddir/modem/*; do
|
||||
install -Dm644 $file -t "$subpkgdir/lib/firmware/qcom/sdx55m"
|
||||
done
|
||||
}
|
||||
|
||||
slpi() {
|
||||
pil-squasher "$builddir/slpi/slpi.mbn" "$builddir/slpi/slpi.mdt"
|
||||
install -Dm644 "$builddir/slpi/slpi.mbn" -t $subpkgdir/lib/firmware/postmarketos
|
||||
}
|
||||
|
||||
wifi() {
|
||||
cd "$builddir/wlan"
|
||||
ath11k-bdencoder -c board-2.json
|
||||
install -Dm644 "$builddir/wlan/board-2.bin" -t "$subpkgdir/lib/firmware/ath11k/QCA6390/hw2.0"
|
||||
install -Dm644 "$builddir/wlan/amss.bin" -t "$subpkgdir/lib/firmware/ath11k/QCA6390/hw2.0"
|
||||
install -Dm644 "$builddir/wlan/m3.bin" -t "$subpkgdir/lib/firmware/ath11k/QCA6390/hw2.0"
|
||||
}
|
||||
|
||||
venus() {
|
||||
pil-squasher "$builddir/venus/venus.mbn" "$builddir/venus/venus.mdt"
|
||||
install -Dm644 "$builddir/venus/venus.mbn" -t $subpkgdir/lib/firmware/postmarketos
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
c2855805e6327977fbd119ed89e76010586273008260c4df827622266f42dc318abf7f61f78408596377338cf36c03dd10b7279b6e6f7986569c970fffae72da oneplus-instantnoodlep-firmware-2dce2681689fcf615198c663555c5a7c7b3650ba.tar.gz
|
||||
"
|
|
@ -0,0 +1,25 @@
|
|||
From 8d16211d0db4c4edf07c7d207c1df962e691cc66 Mon Sep 17 00:00:00 2001
|
||||
From: Pangwalla <pangwalla@protonmail.com>
|
||||
Date: Wed, 1 Mar 2023 19:21:38 -0500
|
||||
Subject: [PATCH] comment out mgeneral-regs-only flag
|
||||
|
||||
---
|
||||
arch/arm64/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm64/Makefile b/arch/arm64/Makefile
|
||||
index 7082e8cf3ac8..b4533ab57eb3 100644
|
||||
--- a/arch/arm64/Makefile
|
||||
+++ b/arch/arm64/Makefile
|
||||
@@ -52,7 +52,7 @@ endif
|
||||
ifeq ($(cc-name),clang)
|
||||
KBUILD_CFLAGS += -mno-implicit-float
|
||||
else
|
||||
-KBUILD_CFLAGS += -mgeneral-regs-only
|
||||
+#KBUILD_CFLAGS += -mgeneral-regs-only
|
||||
endif
|
||||
KBUILD_CFLAGS += $(lseinstr) $(brokengasinst) $(compat_vdso)
|
||||
KBUILD_CFLAGS += -fno-asynchronous-unwind-tables
|
||||
--
|
||||
2.39.2
|
||||
|
|
@ -0,0 +1,39 @@
|
|||
From 5618e8729c065e73a424dbc3cbf05dfa043ebd2d Mon Sep 17 00:00:00 2001
|
||||
From: Pangwalla <pangwalla@protonmail.com>
|
||||
Date: Wed, 1 Mar 2023 20:41:44 -0500
|
||||
Subject: [PATCH] remove inline usb driver
|
||||
|
||||
---
|
||||
drivers/net/usb/ax_main.c | 2 +-
|
||||
drivers/net/usb/ax_main.h | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/usb/ax_main.c b/drivers/net/usb/ax_main.c
|
||||
index 1d686c767954..837636ed1c35 100644
|
||||
--- a/drivers/net/usb/ax_main.c
|
||||
+++ b/drivers/net/usb/ax_main.c
|
||||
@@ -937,7 +937,7 @@ inline void *__rx_buf_align(void *data)
|
||||
return (void *)ALIGN((uintptr_t)data, RX_ALIGN);
|
||||
}
|
||||
|
||||
-inline void *__tx_buf_align(void *data, u8 tx_align_len)
|
||||
+void *__tx_buf_align(void *data, u8 tx_align_len)
|
||||
{
|
||||
return (void *)ALIGN((uintptr_t)data, tx_align_len);
|
||||
}
|
||||
diff --git a/drivers/net/usb/ax_main.h b/drivers/net/usb/ax_main.h
|
||||
index 44a64b562088..47c1c04b4c2c 100644
|
||||
--- a/drivers/net/usb/ax_main.h
|
||||
+++ b/drivers/net/usb/ax_main.h
|
||||
@@ -530,7 +530,7 @@ int ax_get_mac_pass(struct ax_device *axdev, u8 *mac);
|
||||
void ax_set_tx_qlen(struct ax_device *dev);
|
||||
|
||||
inline void *__rx_buf_align(void *data);
|
||||
-inline void *__tx_buf_align(void *data, u8 tx_align_len);
|
||||
+void *__tx_buf_align(void *data, u8 tx_align_len);
|
||||
inline struct net_device_stats *ax_get_stats(struct net_device *dev);
|
||||
void ax_write_bulk_callback(struct urb *urb);
|
||||
|
||||
--
|
||||
2.39.2
|
||||
|
|
@ -0,0 +1,39 @@
|
|||
From 39116bad0b493e732e9bc2ac4ed771ce0959a622 Mon Sep 17 00:00:00 2001
|
||||
From: Pangwalla <pangwalla@protonmail.com>
|
||||
Date: Wed, 1 Mar 2023 21:57:28 -0500
|
||||
Subject: [PATCH] remove inline techpack dispay driver
|
||||
|
||||
---
|
||||
techpack/display/oplus/oplus_adfr.c | 2 +-
|
||||
techpack/display/oplus/oplus_adfr.h | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/techpack/display/oplus/oplus_adfr.c b/techpack/display/oplus/oplus_adfr.c
|
||||
index 1bd798c82449..0ebf2fa27552 100644
|
||||
--- a/techpack/display/oplus/oplus_adfr.c
|
||||
+++ b/techpack/display/oplus/oplus_adfr.c
|
||||
@@ -155,7 +155,7 @@ enum oplus_vsync_mode oplus_adfr_get_vsync_mode(void)
|
||||
return (enum oplus_vsync_mode)ADFR_GET_VSYNC_SWITCH_MODE(oplus_adfr_config);
|
||||
}
|
||||
|
||||
-inline bool oplus_adfr_is_support(void)
|
||||
+bool oplus_adfr_is_support(void)
|
||||
{
|
||||
return (bool)(ADFR_GET_GLOBAL_CONFIG(oplus_adfr_config) &&
|
||||
!(oplus_adfr_debug & OPLUS_ADFR_DEBUG_GLOBAL_DISABLE));
|
||||
diff --git a/techpack/display/oplus/oplus_adfr.h b/techpack/display/oplus/oplus_adfr.h
|
||||
index 76eb5b4d1ee2..dfe9dea0abdc 100644
|
||||
--- a/techpack/display/oplus/oplus_adfr.h
|
||||
+++ b/techpack/display/oplus/oplus_adfr.h
|
||||
@@ -74,7 +74,7 @@ extern bool oplus_adfr_compatibility_mode;
|
||||
|
||||
/* --------------- adfr misc ---------------*/
|
||||
void oplus_adfr_init(void *dsi_panel);
|
||||
-inline bool oplus_adfr_is_support(void);
|
||||
+bool oplus_adfr_is_support(void);
|
||||
ssize_t oplus_adfr_get_debug(struct device *dev,
|
||||
struct device_attribute *attr, char *buf);
|
||||
ssize_t oplus_adfr_set_debug(struct device *dev,
|
||||
--
|
||||
2.39.2
|
||||
|
|
@ -0,0 +1,25 @@
|
|||
From d3c48515dedef5d59b138d007136b76b58091f44 Mon Sep 17 00:00:00 2001
|
||||
From: Pangwalla <pangwalla@protonmail.com>
|
||||
Date: Wed, 1 Mar 2023 22:10:32 -0500
|
||||
Subject: [PATCH] fix enum with attempted integer subclass syntax issue
|
||||
|
||||
---
|
||||
techpack/display/oplus/oplus_display_panel.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/techpack/display/oplus/oplus_display_panel.h b/techpack/display/oplus/oplus_display_panel.h
|
||||
index 30aae7ccb5b1..c201acb07f50 100644
|
||||
--- a/techpack/display/oplus/oplus_display_panel.h
|
||||
+++ b/techpack/display/oplus/oplus_display_panel.h
|
||||
@@ -53,7 +53,7 @@ static struct cdev panel_cdev;
|
||||
|
||||
#define APOLLO_BACKLIGHT_LENS 4096*19
|
||||
|
||||
-enum APOLLO_BL_ID : int {
|
||||
+enum APOLLO_BL_ID {
|
||||
APOLLO_BL_4096 = 4096,
|
||||
APOLLO_BL_8192 = 8192,
|
||||
APOLLO_BL_14336 = 14336,
|
||||
--
|
||||
2.39.2
|
||||
|
|
@ -0,0 +1,39 @@
|
|||
From 73ee594491beeaa8bf76c2e930c8ca0509c14222 Mon Sep 17 00:00:00 2001
|
||||
From: Pangwalla <pangwalla@protonmail.com>
|
||||
Date: Wed, 1 Mar 2023 22:19:33 -0500
|
||||
Subject: [PATCH] remove inline usb driver ax_get_stats
|
||||
|
||||
---
|
||||
drivers/net/usb/ax_main.c | 2 +-
|
||||
drivers/net/usb/ax_main.h | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/usb/ax_main.c b/drivers/net/usb/ax_main.c
|
||||
index 837636ed1c35..27c558b2f686 100644
|
||||
--- a/drivers/net/usb/ax_main.c
|
||||
+++ b/drivers/net/usb/ax_main.c
|
||||
@@ -711,7 +711,7 @@ void ax_mdio_write(struct net_device *netdev, int phy_id, int reg, int val)
|
||||
ax_write_cmd(axdev, AX_ACCESS_PHY, phy_id, (__u16)reg, 2, &res);
|
||||
}
|
||||
|
||||
-inline struct net_device_stats *ax_get_stats(struct net_device *netdev)
|
||||
+struct net_device_stats *ax_get_stats(struct net_device *netdev)
|
||||
{
|
||||
return &netdev->stats;
|
||||
}
|
||||
diff --git a/drivers/net/usb/ax_main.h b/drivers/net/usb/ax_main.h
|
||||
index 47c1c04b4c2c..6e88c362b7c9 100644
|
||||
--- a/drivers/net/usb/ax_main.h
|
||||
+++ b/drivers/net/usb/ax_main.h
|
||||
@@ -531,7 +531,7 @@ void ax_set_tx_qlen(struct ax_device *dev);
|
||||
|
||||
inline void *__rx_buf_align(void *data);
|
||||
void *__tx_buf_align(void *data, u8 tx_align_len);
|
||||
-inline struct net_device_stats *ax_get_stats(struct net_device *dev);
|
||||
+struct net_device_stats *ax_get_stats(struct net_device *dev);
|
||||
void ax_write_bulk_callback(struct urb *urb);
|
||||
|
||||
void ax_get_drvinfo(struct net_device *net, struct ethtool_drvinfo *info);
|
||||
--
|
||||
2.39.2
|
||||
|
|
@ -0,0 +1,39 @@
|
|||
From bf7c9c36b612f7bf11cad67e4b693775e0f46f8a Mon Sep 17 00:00:00 2001
|
||||
From: Pangwalla <pangwalla@protonmail.com>
|
||||
Date: Wed, 1 Mar 2023 22:47:31 -0500
|
||||
Subject: [PATCH] remove inline driver lowmem_dbg
|
||||
|
||||
---
|
||||
drivers/soc/oplus/lowmem_dbg/lowmem_dbg.h | 2 +-
|
||||
include/soc/oplus/lowmem_dbg.h | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/soc/oplus/lowmem_dbg/lowmem_dbg.h b/drivers/soc/oplus/lowmem_dbg/lowmem_dbg.h
|
||||
index fd07654302b2..843223bde364 100644
|
||||
--- a/drivers/soc/oplus/lowmem_dbg/lowmem_dbg.h
|
||||
+++ b/drivers/soc/oplus/lowmem_dbg/lowmem_dbg.h
|
||||
@@ -11,7 +11,7 @@
|
||||
void oplus_lowmem_dbg(bool critical);
|
||||
|
||||
#ifndef CONFIG_MTK_ION
|
||||
-inline int oplus_is_dma_buf_file(struct file *file);
|
||||
+int oplus_is_dma_buf_file(struct file *file);
|
||||
#endif /* CONFIG_MTK_ION */
|
||||
#ifdef CONFIG_KSWAPD_DEBUG_STATISTICS
|
||||
int kswapd_debug_init(struct proc_dir_entry *parent);
|
||||
diff --git a/include/soc/oplus/lowmem_dbg.h b/include/soc/oplus/lowmem_dbg.h
|
||||
index fd07654302b2..843223bde364 100644
|
||||
--- a/include/soc/oplus/lowmem_dbg.h
|
||||
+++ b/include/soc/oplus/lowmem_dbg.h
|
||||
@@ -11,7 +11,7 @@
|
||||
void oplus_lowmem_dbg(bool critical);
|
||||
|
||||
#ifndef CONFIG_MTK_ION
|
||||
-inline int oplus_is_dma_buf_file(struct file *file);
|
||||
+int oplus_is_dma_buf_file(struct file *file);
|
||||
#endif /* CONFIG_MTK_ION */
|
||||
#ifdef CONFIG_KSWAPD_DEBUG_STATISTICS
|
||||
int kswapd_debug_init(struct proc_dir_entry *parent);
|
||||
--
|
||||
2.39.2
|
||||
|
|
@ -0,0 +1,45 @@
|
|||
From 0498b33266c9e45fe1e73b5942ea92f9aed631c2 Mon Sep 17 00:00:00 2001
|
||||
From: Pangwalla <pangwalla@protonmail.com>
|
||||
Date: Wed, 1 Mar 2023 23:11:56 -0500
|
||||
Subject: [PATCH] fix variably sized array initialization
|
||||
|
||||
---
|
||||
drivers/soc/oplus/system/theia/powerkey_monitor.c | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/soc/oplus/system/theia/powerkey_monitor.c b/drivers/soc/oplus/system/theia/powerkey_monitor.c
|
||||
index 2a1633279d11..90f37c575616 100644
|
||||
--- a/drivers/soc/oplus/system/theia/powerkey_monitor.c
|
||||
+++ b/drivers/soc/oplus/system/theia/powerkey_monitor.c
|
||||
@@ -4,6 +4,7 @@
|
||||
*/
|
||||
#include "powerkey_monitor.h"
|
||||
#include "theia_kevent_kernel.h"
|
||||
+#include <linux/string.h>
|
||||
|
||||
#define POWER_MONITOR_DEBUG_PRINTK(a, arg...)\
|
||||
do{\
|
||||
@@ -225,7 +226,9 @@ static void print_all_buffer(void)
|
||||
static ssize_t theia_powerkey_report_proc_read(struct file *file, char __user *buf,
|
||||
size_t count,loff_t *off)
|
||||
{
|
||||
- char stages[stage_total_size] = {0};
|
||||
+ char stages[stage_total_size];
|
||||
+ memset(stages, 0, sizeof(stages));
|
||||
+
|
||||
int stages_len;
|
||||
|
||||
POWER_MONITOR_DEBUG_PRINTK("enter theia_powerkey_report_proc_read %d %d",count,*off);
|
||||
@@ -265,7 +268,8 @@ static ssize_t theia_powerkey_report_proc_write(struct file *file, const char __
|
||||
size_t count,loff_t *off)
|
||||
{
|
||||
|
||||
- char buffer[stage_brief_size] = {0};
|
||||
+ char buffer[stage_brief_size];
|
||||
+ memset(buffer, 0, sizeof(buffer));
|
||||
|
||||
if(g_black_data.status == BLACK_STATUS_INIT || g_black_data.status == BLACK_STATUS_INIT_FAIL){
|
||||
POWER_MONITOR_DEBUG_PRINTK("%s init not finish: status = %d\n", __func__, g_black_data.status);
|
||||
--
|
||||
2.39.2
|
||||
|
84
device/testing/linux-oneplus-instantnoodlep/APKBUILD
Normal file
84
device/testing/linux-oneplus-instantnoodlep/APKBUILD
Normal file
|
@ -0,0 +1,84 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm64/configs/vendor/kona_defconfig
|
||||
|
||||
pkgname=linux-oneplus-instantnoodlep
|
||||
pkgver=4.19.272
|
||||
pkgrel=0
|
||||
pkgdesc="OnePlus 8 Pro kernel fork"
|
||||
arch="aarch64"
|
||||
_carch="arm64"
|
||||
_flavor="oneplus-instantnoodlep"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
android-mkdtboimg
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
dtc
|
||||
flex
|
||||
linux-headers
|
||||
openssl-dev
|
||||
perl
|
||||
xz
|
||||
"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_oneplus_sm8250"
|
||||
_commit="28048669da64fdc5c7d9b1697531ed25d62ea9aa"
|
||||
_config="config-$_flavor.$arch"
|
||||
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
0001-comment-out-mgeneral-regs-only-flag.patch
|
||||
0002-remove-inline-from-fn-usb-driver.patch
|
||||
0003-remove-inline-techpack-dispay-driver.patch
|
||||
0004-fix-enum-with-attempted-integer-subclass-syntax-issue.patch
|
||||
0005-remove-inline-usb-driver-ax_get_stats.patch
|
||||
0006-remove-inline-driver-lowmem_dbg.patch
|
||||
0007-fix-variably-sized-array-initialization.patch
|
||||
Suppress-error-about-static-buffer-overflow.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
REPLACE_GCCH=0 . downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package \
|
||||
"$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
|
||||
install -Dm644 "$_outdir/arch/arm64/boot/Image-dtb" \
|
||||
"$pkgdir/boot/vmlinuz"
|
||||
|
||||
make O="$_outdir" \
|
||||
ARCH="$_carch" \
|
||||
INSTALL_MOD_STRIP=1 \
|
||||
INSTALL_MOD_PATH="$pkgdir" \
|
||||
modules_install
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
8b291904ba7ea00fe32da7803415fa2e889cd2d964b454fb457923c2c462ab4ee02a843e6286f2a69f8530b4d09965ad21683b771c180124605bc7d15cfa07fb linux-oneplus-instantnoodlep-28048669da64fdc5c7d9b1697531ed25d62ea9aa.tar.gz
|
||||
8f8e2c0e34229bc0958b711c6a6509e6ff1f3535146954ea927f023ce707d56cc548424732dd458556dd2851a7add584f78ccf67a9cefaf7d690f693f7639a1e config-oneplus-instantnoodlep.aarch64
|
||||
bbd3790b58b1f0c28bac25cd50533fa9bb60d5727480ee3ff0063fbcc83c1b188d820cd7de736ca6bb67821b76071f54c46e5e5292a79e744af122bdc1a17ac0 0001-comment-out-mgeneral-regs-only-flag.patch
|
||||
37ff67b6aadcc8cf432c1e41d5ea9cecd882986df274a02ad7978401d86ef821809d6cb195881192626e5545e6b0668cb475ebe9cb42e583452e424854ddec78 0002-remove-inline-from-fn-usb-driver.patch
|
||||
c0524cdbe0e92af4a1a8b1e569d04c78fdab10e5e1ba09c3415439dfe3dacb2e89eef3cdf42fb77fe34155b872cd5871f8d2d0e2efd63918cdac6d93fae75b72 0003-remove-inline-techpack-dispay-driver.patch
|
||||
4487cb6b25eb08a55858bf21de9c9e26c55dafba4bd770259dc826fcee213215ebaae879b5c202e033d5bb014c5184f80455dd8bdadc0c608d7540d8b45fdda1 0004-fix-enum-with-attempted-integer-subclass-syntax-issue.patch
|
||||
39d4ab48c95369e6b1af8dc28301312096d9f2bc705266d9e0952f52f841dfe396ada2ff47afe01d88d7259aed8de339db29c87dc14496b4978da3a4b69f45fc 0005-remove-inline-usb-driver-ax_get_stats.patch
|
||||
a87b4f7065d9f34097bf2c283068b18c8e22a11394d54b8c941e243bada00e3f0fa2300f68192d13345a20ca360dedc84a006cbb4b86e43ace07c468fe498ee9 0006-remove-inline-driver-lowmem_dbg.patch
|
||||
c35ad50b595b4ac16551527dc585d6e9e47736ac216e512c91e73d8e5351d9516a197527f144df398687b198c1f3c008a6e629910740609ee24586ecc528ff6a 0007-fix-variably-sized-array-initialization.patch
|
||||
4e7a73a1c6e8424a34d317899525ca3d783de1a5e65cc0ecdf6334bbb233d165b476107e599cbd86868ed91a5a60d2ef0eff975861d61cb2c403b572314b4a94 Suppress-error-about-static-buffer-overflow.patch
|
||||
"
|
|
@ -0,0 +1,22 @@
|
|||
From e950e514cd6b45f8d1512eef1c959769183caf56 Mon Sep 17 00:00:00 2001
|
||||
From: Alexandros Feuerstein <32029275+afeuerstein@users.noreply.github.com>
|
||||
Date: Tue, 13 Jul 2021 11:19:58 +0200
|
||||
Subject: [PATCH] Update ipa_hw_stats.c
|
||||
|
||||
---
|
||||
drivers/platform/msm/ipa/ipa_v3/ipa_hw_stats.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/platform/msm/ipa/ipa_v3/ipa_hw_stats.c b/drivers/platform/msm/ipa/ipa_v3/ipa_hw_stats.c
|
||||
index 1b900a27173b..d1e40689709a 100644
|
||||
--- a/drivers/platform/msm/ipa/ipa_v3/ipa_hw_stats.c
|
||||
+++ b/drivers/platform/msm/ipa/ipa_v3/ipa_hw_stats.c
|
||||
@@ -2253,7 +2253,7 @@ static ssize_t ipa_debugfs_enable_disable_drop_stats(struct file *file,
|
||||
goto bail;
|
||||
}
|
||||
|
||||
- missing = copy_from_user(dbg_buff, ubuf, count);
|
||||
+ missing = _copy_from_user(dbg_buff, ubuf, count);
|
||||
if (missing) {
|
||||
ret = -EFAULT;
|
||||
goto bail;
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue