samsung-jackpotlte: Add new device (Samsung Galaxy A8 (2018)) (MR 1664)

This commit is contained in:
VDavid003 2020-10-30 00:59:23 +01:00 committed by Oliver Smith
parent 85e0b12f0d
commit 35e50b29f7
No known key found for this signature in database
GPG key ID: 5AE7F5513E0885CB
5 changed files with 5329 additions and 0 deletions

View file

@ -0,0 +1,22 @@
# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-samsung-jackpotlte
pkgdesc="Samsung Galaxy A8 (2018)"
pkgver=0.1
pkgrel=0
url="https://postmarketos.org"
license="MIT"
arch="aarch64"
options="!check !archcheck"
depends="postmarketos-base linux-samsung-jackpotlte mkbootimg mesa-dri-gallium"
makedepends="devicepkg-dev"
source="deviceinfo"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
sha512sums="26194837ca66607030ad14654ab21fe373db8d068f8b0f1820fb3f1aa45a22590e06265abe6f478df50c78932a53a20c5b36f57986a442762d1cb0f07f920682 deviceinfo"

View file

@ -0,0 +1,34 @@
# Reference: <https://postmarketos.org/deviceinfo>
# Please use double quotes only. You can source this file in shell scripts.
deviceinfo_format_version="0"
deviceinfo_name="Samsung Galaxy A8 (2018)"
deviceinfo_manufacturer="Samsung"
deviceinfo_codename="samsung-jackpotlte"
deviceinfo_year="2018"
deviceinfo_dtb=""
deviceinfo_modules_initfs=""
deviceinfo_arch="aarch64"
# Device related
deviceinfo_chassis="handset"
deviceinfo_keyboard="false"
deviceinfo_external_storage="true"
deviceinfo_screen_width="1080"
deviceinfo_screen_height="2220"
# Bootloader related
deviceinfo_flash_method="heimdall-bootimg"
deviceinfo_kernel_cmdline=""
deviceinfo_generate_bootimg="true"
deviceinfo_bootimg_qcdt="true"
deviceinfo_bootimg_mtk_mkimage="false"
deviceinfo_bootimg_dtb_second="false"
deviceinfo_flash_offset_base="0x10000000"
deviceinfo_flash_offset_kernel="0x00008000"
deviceinfo_flash_offset_ramdisk="0x01000000"
deviceinfo_flash_offset_second="0x00f00000"
deviceinfo_flash_offset_tags="0x00000100"
deviceinfo_flash_pagesize="2048"
deviceinfo_flash_heimdall_partition_kernel="BOOT"
deviceinfo_flash_heimdall_partition_system="SYSTEM"

View file

@ -0,0 +1,57 @@
# Reference: <https://postmarketos.org/vendorkernel>
# Kernel config based on: arch/arm64/configs/exynos7885-jackpotlte_defconfig
pkgname=linux-samsung-jackpotlte
pkgver=4.4.177
pkgrel=0
pkgdesc="Samsung Galaxy A8 (2018) kernel fork"
arch="aarch64"
_carch="arm64"
_flavor="samsung-jackpotlte"
url="https://kernel.org"
license="GPL-2.0-only"
options="!strip !check !tracedeps pmb:cross-native"
makedepends="bash bc bison devicepkg-dev flex openssl-dev perl dtbtool-exynos"
# Source
_repository="Universal7885_native_linux"
_commit="8ab619fec5ab7fadc8dfb2cf8e994d4a89b212c3"
_config="config-$_flavor.$arch"
source="
$pkgname-$_commit.tar.gz::https://github.com/VDavid003/$_repository/archive/$_commit.tar.gz
kernel-define-android-version.patch
$_config
"
builddir="$srcdir/$_repository-$_commit"
_outdir="out"
prepare() {
default_prepare
. downstreamkernel_prepare
}
build() {
unset LDFLAGS
# Needed for the SoC's power management. When booting without it, the kernel is
# unusably slow and glitchy.
objcopy -I binary -O ihex firmware/exynos7885_acpm_fvp.fw firmware/exynos7885_acpm_fvp.fw.ihex
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
dtbTool-exynos --pagesize 2048 --platform 0x50a6 --subtype 0x217584da \
-o "$_outdir/arch/arm64/boot/dtb.img" $(find "$_outdir/arch/arm64/boot/dts/exynos/" -name *jackpotlte_eur*.dtb)
}
package() {
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
# Master DTB (deviceinfo_bootimg_qcdt)
install -Dm644 "$_outdir/arch/arm64/boot/dtb.img" \
"$pkgdir/boot/dt.img"
}
sha512sums="2ed2ec274982a52736942fd88dc79e57fefa17151460c2d143d6eef5511fc018fc9d498d972e770350b454c206ea11c0d5b84d8a8a22218f684fa3c70ff238eb linux-samsung-jackpotlte-8ab619fec5ab7fadc8dfb2cf8e994d4a89b212c3.tar.gz
f3161f62a6ba0de56342b1410e509dce8320e43f788ae2670ebd59d93e5504aab77a913eecdebae33ff9135228869c5fd0559211c511f503fdc25f2fbab48351 kernel-define-android-version.patch
d97a6b08b432d71ed2dd26fc2a82f7fcaa5a53ab15fdc5c05d0722231c6143f88b83e2d883b4fec4d97643f032fefffaf62c1fa0d9ef7b4d7a490cb325a2c087 config-samsung-jackpotlte.aarch64"

File diff suppressed because it is too large Load diff

View file

@ -0,0 +1,14 @@
Defines PLATFORM_VERSION, which is needed for compillation.
diff --git a/Makefile b/Makefile
index 45ce83161..fdb71c8ec 100755
--- a/Makefile
+++ b/Makefile
@@ -469,6 +469,7 @@ asm-generic:
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.asm-generic \
src=uapi/asm obj=arch/$(SRCARCH)/include/generated/uapi/asm
+PLATFORM_VERSION=9
ifneq ($(PLATFORM_VERSION), )
PLATFORM_VERSION_NUMBER=$(shell $(CONFIG_SHELL) $(srctree)/scripts/android-version.sh $(PLATFORM_VERSION))
MAJOR_VERSION=$(shell $(CONFIG_SHELL) $(srctree)/scripts/android-major-version.sh $(PLATFORM_VERSION))