chuwi-hi10plus: drop (MR 2989)
I'd say this is not appropriate to be in postmarketOS because this is just a bog standard x86 computer, it has UEFI BIOS and everything, and you can just boot a Linux distro on a USB stick. It also has a 64-bit UEFI unlike some other tablet, so there should be no issue installing a Linux distro with a fairly modern kernel these days. So, let's just drop it and forget this port even existed.
This commit is contained in:
parent
2db41b939e
commit
3536cf549a
12 changed files with 0 additions and 9278 deletions
|
@ -1,51 +0,0 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-chuwi-hi10plus
|
||||
pkgdesc="CHUWI Hi10 Plus"
|
||||
pkgver=0.2
|
||||
pkgrel=8
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="x86_64"
|
||||
options="!check !archcheck"
|
||||
depends="postmarketos-base linux-chuwi-hi10plus mkbootimg mesa-dri-intel libva-intel-driver wireless-regdb pulseaudio pulseaudio-alsa alsa-plugins-pulse"
|
||||
makedepends="devicepkg-dev"
|
||||
subpackages="
|
||||
$pkgname-nonfree-firmware:nonfree_firmware
|
||||
$pkgname-x11
|
||||
$pkgname-weston
|
||||
"
|
||||
source="deviceinfo
|
||||
initfs-hook.sh
|
||||
weston.ini"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
x11() {
|
||||
install_if="$pkgname xorg-server"
|
||||
depends="xf86-video-intel gstreamer-vaapi"
|
||||
mkdir "$subpkgdir"
|
||||
}
|
||||
|
||||
weston() {
|
||||
install_if="$pkgname weston"
|
||||
install -Dm644 "$srcdir"/weston.ini \
|
||||
"$subpkgdir"/etc/xdg/weston/weston.ini
|
||||
}
|
||||
|
||||
nonfree_firmware() {
|
||||
pkgdesc="Touch, Wi-Fi, Bluetooth, Sound Firmware"
|
||||
depends="firmware-chuwi-hi10plus linux-firmware-intel linux-firmware-rtlwifi linux-firmware-rtl_bt"
|
||||
mkdir "$subpkgdir"
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
151b60e4e5192aa5f747c550d7114fe9b0e49d7f9c2b151e36e18be73e3c5ed8ca52f642c955b0f8e43e5c3a98914f97c3bea9885d95266536ddbf370384b016 deviceinfo
|
||||
8191c479588ccd0c44d23a06cee975635ad9353a7469489c3436ca22051410ff5153dccfb38284dd3976fd6bb8ea6979d32224b652ce68b51f4448c2aa8fc9dd initfs-hook.sh
|
||||
15497cf556750d2b91ef81dab7c4071dc5d1d62bab6f98db0b240e74d8b26ebcda5af2f80fe998518c3b53e72e0daa762d063c87dff46d73d70a8d879cb9aaa8 weston.ini
|
||||
"
|
|
@ -1,32 +0,0 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="CHUWI Hi10 Plus"
|
||||
deviceinfo_manufacturer="CHUWI"
|
||||
deviceinfo_codename="chuwi-hi10plus"
|
||||
deviceinfo_year="2016"
|
||||
deviceinfo_modules_initfs="silead"
|
||||
deviceinfo_arch="x86_64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_gpu_accelerated="true"
|
||||
deviceinfo_chassis="tablet"
|
||||
deviceinfo_keyboard="true"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="1920"
|
||||
deviceinfo_screen_height="1280"
|
||||
deviceinfo_dev_touchscreen="/dev/input/event4"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="add_efi_memmap PMOS_NO_OUTPUT_REDIRECT"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_flash_sparse=true
|
||||
deviceinfo_flash_offset_base="0x10000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
|
@ -1,14 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# If the device is booted from kernelflinger bootloader,
|
||||
# there is a watchdog running as soon the device load it's kernel.
|
||||
#
|
||||
# When watchdog is running, the system will reboot after 100 seconds,
|
||||
#
|
||||
# The script below will run "Magic Close", which will stop the timer. (thanks lambdadroid)
|
||||
# http://lxr.free-electrons.com/source/Documentation/watchdog/watchdog-api.txt
|
||||
|
||||
# snip from device-nokia-n9 (initfs-hook.sh)
|
||||
for wd in /dev/watchdog*; do
|
||||
[ -c $wd ] && echo V > $wd
|
||||
done
|
|
@ -1,6 +0,0 @@
|
|||
# DRM is enabled on this tablet, so we'll use DRM as backend on Weston.
|
||||
[core]
|
||||
xwayland=true
|
||||
backend=drm-backend.so
|
||||
[shell]
|
||||
background-image=/usr/share/wallpapers/postmarketos.jpg
|
|
@ -1 +0,0 @@
|
|||
/lib/firmware/silead/gsl1680-chuwi-hi10plus.fw
|
|
@ -1,22 +0,0 @@
|
|||
pkgname=firmware-chuwi-hi10plus
|
||||
pkgver=0.1
|
||||
pkgrel=2
|
||||
_commit="2ab861d875105d0b88402d596e3d197dd47135df"
|
||||
pkgdesc="Firmware for Chuwi Hi10 Plus"
|
||||
url="https://github.com/onitake/gsl-firmware"
|
||||
arch="x86_64"
|
||||
license="proprietary"
|
||||
source="$pkgname-$_commit.tar.gz::https://github.com/Danct12/gsl-firmware/archive/$_commit.tar.gz
|
||||
20-touchscreen-firmware.files"
|
||||
options="!strip !check !archcheck !spdx !tracedeps pmb:cross-native"
|
||||
builddir="$srcdir/gsl-firmware-$_commit"
|
||||
|
||||
package() {
|
||||
install -Dm644 firmware/chuwi/hi10_plus/firmware.fw \
|
||||
"$pkgdir"/lib/firmware/silead/gsl1680-chuwi-hi10plus.fw
|
||||
install -Dm644 "$srcdir"/20-touchscreen-firmware.files \
|
||||
"$pkgdir"/etc/postmarketos-mkinitfs/files/20-touchscreen-firmware.files
|
||||
}
|
||||
|
||||
sha512sums="5d2f447403941475542aac6110086117ddf031ad96cf1081cc7c63db465c609e2983c34f269fce86598198ab68826f8c8768232aedb8eaaa4b9a61037c61e610 firmware-chuwi-hi10plus-2ab861d875105d0b88402d596e3d197dd47135df.tar.gz
|
||||
85eda4c0a90f4d9aaf34dff36b08534e27962acd0214873a6b73039a663dd5bfd7de084833b07f2a56314466e2466ad68ce7b6ecbfe496c0578020847bc9b6e6 20-touchscreen-firmware.files"
|
|
@ -1,40 +0,0 @@
|
|||
From df6d4f9db79c1a5d6f48b59db35ccd1e9ff9adfc Mon Sep 17 00:00:00 2001
|
||||
From: "H.J. Lu" <hjl.tools@gmail.com>
|
||||
Date: Thu, 16 Jan 2020 12:46:51 -0800
|
||||
Subject: [PATCH] x86/boot/compressed: Don't declare __force_order in
|
||||
kaslr_64.c
|
||||
|
||||
GCC 10 changed the default to -fno-common, which leads to
|
||||
|
||||
LD arch/x86/boot/compressed/vmlinux
|
||||
ld: arch/x86/boot/compressed/pgtable_64.o:(.bss+0x0): multiple definition of `__force_order'; \
|
||||
arch/x86/boot/compressed/kaslr_64.o:(.bss+0x0): first defined here
|
||||
make[2]: *** [arch/x86/boot/compressed/Makefile:119: arch/x86/boot/compressed/vmlinux] Error 1
|
||||
|
||||
Since __force_order is already provided in pgtable_64.c, there is no
|
||||
need to declare __force_order in kaslr_64.c.
|
||||
|
||||
Signed-off-by: H.J. Lu <hjl.tools@gmail.com>
|
||||
Signed-off-by: Borislav Petkov <bp@suse.de>
|
||||
Link: https://lkml.kernel.org/r/20200124181811.4780-1-hjl.tools@gmail.com
|
||||
---
|
||||
arch/x86/boot/compressed/kaslr_64.c | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/arch/x86/boot/compressed/kaslr_64.c b/arch/x86/boot/compressed/kaslr_64.c
|
||||
index 748456c365f4..9557c5a15b91 100644
|
||||
--- a/arch/x86/boot/compressed/kaslr_64.c
|
||||
+++ b/arch/x86/boot/compressed/kaslr_64.c
|
||||
@@ -29,9 +29,6 @@
|
||||
#define __PAGE_OFFSET __PAGE_OFFSET_BASE
|
||||
#include "../../mm/ident_map.c"
|
||||
|
||||
-/* Used by pgtable.h asm code to force instruction serialization. */
|
||||
-unsigned long __force_order;
|
||||
-
|
||||
/* Used to track our page table allocation area. */
|
||||
struct alloc_pgt_data {
|
||||
unsigned char *pgt_buf;
|
||||
--
|
||||
2.29.2
|
||||
|
|
@ -1,66 +0,0 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: <https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux>
|
||||
|
||||
pkgname=linux-chuwi-hi10plus
|
||||
pkgver=5.1.7
|
||||
pkgrel=1
|
||||
pkgdesc="Chuwi Hi10 Plus stable kernel"
|
||||
arch="x86_64"
|
||||
_carch="x86"
|
||||
_flavor="chuwi-hi10plus"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev
|
||||
devicepkg-dev bison flex openssl-dev xz coreutils findutils"
|
||||
subpackages="$pkgname-dev"
|
||||
|
||||
# Source
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$pkgver.tar.gz::https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/linux-$pkgver.tar.gz
|
||||
$_config
|
||||
input-silead-Add-MSSL0017-to-acpi_device_id.patch
|
||||
platform-x86-touchscreen_dmi-Add-info-for-the-CHUWI-.patch
|
||||
linux4.17-gcc10-extern_YYLOC_global_declaration.patch
|
||||
0001-x86-boot-compressed-Don-t-declare-__force_order-in-k.patch
|
||||
"
|
||||
builddir="$srcdir/linux-$pkgver"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
REPLACE_GCCH=0 \
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor"
|
||||
|
||||
make -j1 modules_install \
|
||||
ARCH="$_carch" \
|
||||
INSTALL_MOD_PATH="$pkgdir" \
|
||||
INSTALL_DTBS_PATH="$pkgdir/usr/share/dtb"
|
||||
|
||||
}
|
||||
|
||||
dev() {
|
||||
cd "$builddir"
|
||||
|
||||
# https://github.com/torvalds/linux/blob/master/Documentation/kbuild/headers_install.txt
|
||||
make -j1 headers_install \
|
||||
ARCH="$_carch" \
|
||||
INSTALL_HDR_PATH="$subpkgdir"/usr
|
||||
}
|
||||
|
||||
sha512sums="8d84560e22a6473653efa1dc229c8f8c4f95da8c2f61050583bb1285efa774c958fb13da1cf83a4f9c2cd2e73f2075569da346fa64399ccd058e793754da066a linux-chuwi-hi10plus-5.1.7.tar.gz
|
||||
c591fbe7eef35cd62eed569782cdafb06a07d216d3657b007469502119426b3f52eccd268f02d5fd60e461bc96b262ca3f5f4b1ab9a7122d7af27d83db6cadc6 config-chuwi-hi10plus.x86_64
|
||||
cffb4b1dc204a15697aa26749df49b3f450de808cb630cf53d4718d933031a42789b79e94d39a9fe44a75e385f609c70aa8ccfb2e91e4fe473e0ee5245146c66 input-silead-Add-MSSL0017-to-acpi_device_id.patch
|
||||
b97509150d4061001e90e1a595723c479252647b5f94f50b7be0673d11556b28a90fa0afff9f0961a4512c3cbc8d4b02b827e75f75385cbb3ad63b378f3931e3 platform-x86-touchscreen_dmi-Add-info-for-the-CHUWI-.patch
|
||||
27827877040007fc1c4c719f7e2e19e5c272d44972415cfc53feba0313d87e4074f8204bdb13cbc5fe21ea61bf595314b68f10c081e7b7bac3c888b60f008acf linux4.17-gcc10-extern_YYLOC_global_declaration.patch
|
||||
e049afcae29e24f9c63c926f18036250f9362e8ec713034631d983357685c3841e8bd9779417654a24a88f88d913a59a9043659eeb919c4ebb5d9a0689176494 0001-x86-boot-compressed-Don-t-declare-__force_order-in-k.patch"
|
File diff suppressed because it is too large
Load diff
|
@ -1,27 +0,0 @@
|
|||
From ef2c8011be280a926c59198eff073e5e96697d1f Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Smith <danct12@disroot.org>
|
||||
Date: Wed, 22 May 2019 10:39:41 +0700
|
||||
Subject: [PATCH] input: silead: Add MSSL0017 to acpi_device_id.
|
||||
|
||||
On Chuwi Hi10 Plus, the Silead device id is MSSL0017.
|
||||
|
||||
Signed-off-by: Daniel Smith <danct12@disroot.org>
|
||||
---
|
||||
drivers/input/touchscreen/silead.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/drivers/input/touchscreen/silead.c b/drivers/input/touchscreen/silead.c
|
||||
index 09241d4cdebc..06f0eb04a8fd 100644
|
||||
--- a/drivers/input/touchscreen/silead.c
|
||||
+++ b/drivers/input/touchscreen/silead.c
|
||||
@@ -617,6 +617,7 @@ static const struct acpi_device_id silead_ts_acpi_match[] = {
|
||||
{ "MSSL1680", 0 },
|
||||
{ "MSSL0001", 0 },
|
||||
{ "MSSL0002", 0 },
|
||||
+ { "MSSL0017", 0 },
|
||||
{ }
|
||||
};
|
||||
MODULE_DEVICE_TABLE(acpi, silead_ts_acpi_match);
|
||||
--
|
||||
2.21.0
|
||||
|
|
@ -1 +0,0 @@
|
|||
../../.shared-patches/linux/linux4.17-gcc10-extern_YYLOC_global_declaration.patch
|
|
@ -1,59 +0,0 @@
|
|||
From 472b35c7960a2aa93c19a96550913d413f9f2da2 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Smith <danct12@disroot.org>
|
||||
Date: Wed, 22 May 2019 13:22:49 +0700
|
||||
Subject: [PATCH] platform/x86: touchscreen_dmi: Add info for the CHUWI Hi10
|
||||
Plus tablet.
|
||||
|
||||
Added touch screen info for CHUWI Hi10 Plus tablet.
|
||||
|
||||
Signed-off-by: Daniel Smith <danct12@disroot.org>
|
||||
---
|
||||
drivers/platform/x86/touchscreen_dmi.c | 25 +++++++++++++++++++++++++
|
||||
1 file changed, 25 insertions(+)
|
||||
|
||||
diff --git a/drivers/platform/x86/touchscreen_dmi.c b/drivers/platform/x86/touchscreen_dmi.c
|
||||
index bd0856d2e825..1dbb53c3f1e7 100644
|
||||
--- a/drivers/platform/x86/touchscreen_dmi.c
|
||||
+++ b/drivers/platform/x86/touchscreen_dmi.c
|
||||
@@ -91,6 +91,22 @@ static const struct ts_dmi_data chuwi_hi10_air_data = {
|
||||
.properties = chuwi_hi10_air_props,
|
||||
};
|
||||
|
||||
+static const struct property_entry chuwi_hi10_plus_props[] = {
|
||||
+ PROPERTY_ENTRY_U32("touchscreen-min-x", 0),
|
||||
+ PROPERTY_ENTRY_U32("touchscreen-min-y", 5),
|
||||
+ PROPERTY_ENTRY_U32("touchscreen-size-x", 1914),
|
||||
+ PROPERTY_ENTRY_U32("touchscreen-size-y", 1283),
|
||||
+ PROPERTY_ENTRY_STRING("firmware-name", "gsl1680-chuwi-hi10plus.fw"),
|
||||
+ PROPERTY_ENTRY_U32("silead,max-fingers", 10),
|
||||
+ PROPERTY_ENTRY_BOOL("silead,home-button"),
|
||||
+ { }
|
||||
+};
|
||||
+
|
||||
+static const struct ts_dmi_data chuwi_hi10_plus_data = {
|
||||
+ .acpi_name = "MSSL0017:00",
|
||||
+ .properties = chuwi_hi10_plus_props,
|
||||
+};
|
||||
+
|
||||
static const struct property_entry chuwi_vi8_props[] = {
|
||||
PROPERTY_ENTRY_U32("touchscreen-min-x", 4),
|
||||
PROPERTY_ENTRY_U32("touchscreen-min-y", 6),
|
||||
@@ -605,6 +621,15 @@ static const struct dmi_system_id touchscreen_dmi_table[] = {
|
||||
DMI_MATCH(DMI_PRODUCT_SKU, "P1W6_C109D_B"),
|
||||
},
|
||||
},
|
||||
+ {
|
||||
+ /* Chuwi Hi10 Plus (CWI527) */
|
||||
+ .driver_data = (void *)&chuwi_hi10_plus_data,
|
||||
+ .matches = {
|
||||
+ DMI_MATCH(DMI_BOARD_VENDOR, "Hampoo"),
|
||||
+ DMI_MATCH(DMI_PRODUCT_NAME, "Hi10 plus tablet"),
|
||||
+ DMI_MATCH(DMI_BOARD_NAME, "Cherry Trail CR"),
|
||||
+ },
|
||||
+ },
|
||||
{
|
||||
/* Chuwi Vi8 (CWI506) */
|
||||
.driver_data = (void *)&chuwi_vi8_data,
|
||||
--
|
||||
2.21.0
|
||||
|
Loading…
Reference in a new issue