modem/tqftpserv: upgrade to 1.1 (MR 5370)
Includes support for compressed firmware, among other nice things. [ci:skip-build]: already built successfully in CI
This commit is contained in:
parent
f36f567c85
commit
343c982087
2 changed files with 5 additions and 74 deletions
|
@ -1,65 +0,0 @@
|
|||
From 7bdf6439bbb3418a648dcd4575647648959ccf1e Mon Sep 17 00:00:00 2001
|
||||
From: Alexey Minnekhanov <alexey.min@gmail.com>
|
||||
Date: Sun, 28 Apr 2024 15:39:14 +0300
|
||||
Subject: [PATCH] meson.build: Make systemd dep optional
|
||||
|
||||
Some distros still don't use SystemD (yet), make it optional.
|
||||
|
||||
It is not required to build the binary, just to install systemd
|
||||
unit file.
|
||||
|
||||
Signed-off-by: Alexey Minnekhanov <alexey.min@gmail.com>
|
||||
---
|
||||
meson.build | 32 +++++++++++++++++++-------------
|
||||
1 file changed, 19 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index f991c48..5b57249 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -6,12 +6,16 @@ project('tqftpserv',
|
||||
])
|
||||
|
||||
prefix = get_option('prefix')
|
||||
-systemd = dependency('systemd')
|
||||
-systemd_system_unit_dir = get_option('systemd-unit-prefix')
|
||||
-if systemd_system_unit_dir == ''
|
||||
- systemd_system_unit_dir = systemd.get_variable(
|
||||
- pkgconfig : 'systemdsystemunitdir',
|
||||
- pkgconfig_define: ['prefix', prefix])
|
||||
+
|
||||
+# Not required to build the executable, only to install unit file
|
||||
+systemd = dependency('systemd', required : false)
|
||||
+if systemd.found()
|
||||
+ systemd_system_unit_dir = get_option('systemd-unit-prefix')
|
||||
+ if systemd_system_unit_dir == ''
|
||||
+ systemd_system_unit_dir = systemd.get_variable(
|
||||
+ pkgconfig : 'systemdsystemunitdir',
|
||||
+ pkgconfig_define: ['prefix', prefix])
|
||||
+ endif
|
||||
endif
|
||||
|
||||
qrtr_dep = dependency('qrtr')
|
||||
@@ -23,10 +27,12 @@ executable('tqftpserv',
|
||||
dependencies : qrtr_dep,
|
||||
install : true)
|
||||
|
||||
-systemd_unit_conf = configuration_data()
|
||||
-systemd_unit_conf.set('prefix', prefix)
|
||||
-configure_file(
|
||||
- input : 'tqftpserv.service.in',
|
||||
- output : 'tqftpserv.service',
|
||||
- configuration : systemd_unit_conf,
|
||||
- install_dir : systemd_system_unit_dir)
|
||||
+if systemd.found()
|
||||
+ systemd_unit_conf = configuration_data()
|
||||
+ systemd_unit_conf.set('prefix', prefix)
|
||||
+ configure_file(
|
||||
+ input : 'tqftpserv.service.in',
|
||||
+ output : 'tqftpserv.service',
|
||||
+ configuration : systemd_unit_conf,
|
||||
+ install_dir : systemd_system_unit_dir)
|
||||
+endif
|
||||
--
|
||||
2.43.2
|
||||
|
|
@ -1,19 +1,16 @@
|
|||
# Maintainer: Luca Weiss <luca@lucaweiss.eu>
|
||||
pkgname=tqftpserv
|
||||
pkgver=0_git20240423
|
||||
pkgrel=1
|
||||
_commit="5f9f263ae291fbbb9fc86756911e4185aa059964"
|
||||
pkgver=1.1
|
||||
pkgrel=0
|
||||
pkgdesc="Trivial File Transfer Protocol server over AF_QIPCRTR"
|
||||
url="https://github.com/linux-msm/tqftpserv"
|
||||
arch="all"
|
||||
license="BSD-3-Clause"
|
||||
makedepends="meson qrtr-dev"
|
||||
source="https://github.com/linux-msm/tqftpserv/archive/$_commit/tqftpserv-$_commit.tar.gz
|
||||
0001-meson.build-Make-systemd-dep-optional.patch
|
||||
makedepends="meson qrtr-dev zstd-dev"
|
||||
source="https://github.com/linux-msm/tqftpserv/archive/v$pkgver/tqftpserv-v$pkgver.tar.gz
|
||||
tqftpserv.initd
|
||||
"
|
||||
subpackages="$pkgname-doc $pkgname-openrc"
|
||||
builddir="$srcdir/tqftpserv-$_commit"
|
||||
options="!check" # No test suite
|
||||
|
||||
build() {
|
||||
|
@ -29,7 +26,6 @@ package() {
|
|||
}
|
||||
|
||||
sha512sums="
|
||||
69b603691a636ea6203b8aba98b8600b32c89f1e3864710f7b5664ec787509c19dbd46c40a38c49d1f17aa80699ef98acb68d6442c2046b4ed5873ecce468699 tqftpserv-5f9f263ae291fbbb9fc86756911e4185aa059964.tar.gz
|
||||
501cdbaeb6167ef87b60e891a79229df2756c5e043e064aeba1343a296cdb5f72f5242d9871cc41721f78aa5d32dd3aee20f284bd9f1a57e139e03861109a237 0001-meson.build-Make-systemd-dep-optional.patch
|
||||
99625c8623f5d9140d4f773366ab98854154bb005f1795a4ce437c3feb968b3304623b30ffa05aacc22ba12fc27f635b8d055300f2695a0df63684168ae6123f tqftpserv-v1.1.tar.gz
|
||||
9fde613a1ed53e633ab676e37245d40598deb4b6896c379054389adad5af9f110fcf95871fe31bad3f0ed9321ba3cee8a2160b95e56873719382f81063a85721 tqftpserv.initd
|
||||
"
|
||||
|
|
Loading…
Reference in a new issue