Remove dbus-nox11
It made problems, see #956 and #952. Originally this was added, so our plasma mobile packaging - which targets wayland - doesn't need to depend on X11 stuff. And because dbus-x11 caused a 1 minute wait for an X server (#377). We have yet to figure out if this problem returns, but even if that happens, it's better than having it completely broken. And we can probably figure out a better way to fix it (for real).
This commit is contained in:
parent
8b2710cd90
commit
31df88c66b
7 changed files with 3 additions and 335 deletions
|
@ -1,64 +0,0 @@
|
|||
pkgbase=dbus
|
||||
pkgname=dbus-nox11
|
||||
pkgver=1.10.18
|
||||
pkgrel=1
|
||||
pkgdesc="Freedesktop.org message bus system"
|
||||
provides="dbus dbus-dev dbus-doc dbus-x11"
|
||||
replaces="dbus dbus-dev dbus-doc dbus-x11"
|
||||
url="http://www.freedesktop.org/Software/dbus"
|
||||
pkggroups="messagebus"
|
||||
arch="all"
|
||||
license="GPL custom"
|
||||
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
|
||||
triggers="$pkgname.trigger=/etc/dbus-1/system.d"
|
||||
depends=
|
||||
depends_dev="util-linux-dev"
|
||||
makedepends="$depends_dev expat-dev libx11-dev autoconf automake libtool"
|
||||
install="$pkgname.pre-install $pkgname.post-install"
|
||||
source="http://dbus.freedesktop.org/releases/$pkgbase/$pkgbase-$pkgver.tar.gz
|
||||
fix-int64-print.patch
|
||||
$pkgbase.initd"
|
||||
builddir=$srcdir/$pkgbase-$pkgver
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
autoreconf -vif
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/$pkgbase-$pkgver
|
||||
./configure \
|
||||
--build=$CBUILD \
|
||||
--host=$CHOST \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--with-xml=expat \
|
||||
--with-dbus-user=messagebus \
|
||||
--with-system-pid-file=/var/run/dbus.pid \
|
||||
--disable-verbose-mode \
|
||||
--disable-static \
|
||||
--enable-inotify \
|
||||
--disable-dnotify \
|
||||
--disable-tests \
|
||||
--disable-asserts
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir"/$pkgbase-$pkgver
|
||||
make -j1 DESTDIR="$pkgdir" install
|
||||
install -Dm755 "$srcdir"/dbus.initd "$pkgdir"/etc/init.d/dbus
|
||||
}
|
||||
|
||||
libs() {
|
||||
pkgdesc="Libraries for acces D-BUS"
|
||||
provides="dbus dbus-dev dbus-doc dbus-x11 dbus-libs"
|
||||
replaces="dbus dbus-dev dbus-doc dbus-x11 dbus-libs"
|
||||
mkdir -p "$subpkgdir"/usr/lib
|
||||
mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib/
|
||||
}
|
||||
|
||||
sha512sums="726f97d0a2016f4f0625ba332e93e2d33bb16857cd35cb6c79da0f44fff297df948c3df62c31ffbec34713a7b85b3ff5b65f31517fe3511ddbd3bf18bd4748ed dbus-1.10.18.tar.gz
|
||||
5f07d8cb377ab80c927a77236c3f3437f08351161e594c62a1ad43f0324c2dba3cc98d50257ae27b9a4f5148571c5f26f35db8b40f13c72e92f267d5356c87f0 fix-int64-print.patch
|
||||
5cdea3473afa62056b5b085b99105e420d672a4be853ea23f161c10dbc98862461f9ba67cd9ee112b54177876f94152a5db3a94f6f98793143c134d3f81d7ce0 dbus.initd"
|
|
@ -1,4 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
exec dbus-uuidgen --ensure
|
||||
|
|
@ -1,7 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
addgroup -S messagebus 2>/dev/null
|
||||
adduser -S -D -H -h /dev/null -s /sbin/nologin -G messagebus -g messagebus messagebus 2>/dev/null
|
||||
|
||||
exit 0
|
||||
|
|
@ -1,4 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
dbus-send --system --type=method_call --dest=org.freedesktop.DBus / \
|
||||
org.freedesktop.DBUS.ReloadConfig >/dev/null 2>&1 || :
|
|
@ -1,51 +0,0 @@
|
|||
#!/sbin/openrc-run
|
||||
# Copyright 1999-2011 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License, v2 or later
|
||||
# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/files/dbus.initd,v 1.1 2011/11/05 13:56:10 ssuominen Exp $
|
||||
|
||||
extra_started_commands="reload"
|
||||
|
||||
depend() {
|
||||
need localmount
|
||||
after bootmisc
|
||||
}
|
||||
|
||||
start() {
|
||||
ebegin "Starting D-BUS system messagebus"
|
||||
/usr/bin/dbus-uuidgen --ensure=/etc/machine-id
|
||||
|
||||
# We need to test if /var/run/dbus exists, since script will fail if it does not
|
||||
[ ! -e /var/run/dbus ] && mkdir /var/run/dbus
|
||||
|
||||
start-stop-daemon --start --pidfile /var/run/dbus.pid --exec /usr/bin/dbus-daemon -- --system
|
||||
eend $?
|
||||
}
|
||||
|
||||
stop() {
|
||||
local retval
|
||||
|
||||
ebegin "Stopping D-BUS system messagebus"
|
||||
|
||||
start-stop-daemon --stop --pidfile /var/run/dbus.pid
|
||||
retval=$?
|
||||
|
||||
eend ${retval}
|
||||
|
||||
[ -S /var/run/dbus/system_bus_socket ] && rm -f /var/run/dbus/system_bus_socket
|
||||
|
||||
return ${retval}
|
||||
}
|
||||
|
||||
reload() {
|
||||
local retval
|
||||
|
||||
ebegin "Reloading D-BUS messagebus config"
|
||||
|
||||
/usr/bin/dbus-send --print-reply --system --type=method_call \
|
||||
--dest=org.freedesktop.DBus \
|
||||
/ org.freedesktop.DBus.ReloadConfig > /dev/null
|
||||
retval=$?
|
||||
eend ${retval}
|
||||
return ${retval}
|
||||
}
|
||||
|
|
@ -1,203 +0,0 @@
|
|||
From 855409c57d160e03ccd9e6a663884362a777b076 Mon Sep 17 00:00:00 2001
|
||||
From: Natanael Copa <ncopa@alpinelinux.org>
|
||||
Date: Fri, 18 Sep 2015 15:27:50 +0200
|
||||
Subject: [PATCH] Use C99 standard PRI*64 for printing 64 bit integers
|
||||
|
||||
Use the standard C99 PRI*64 macros instead of checking for specific GNU
|
||||
libc version. We also specifically check for windows which does not have
|
||||
proper C99 support.
|
||||
|
||||
This fixes printing of int64 on non-GNU 32 bit systems (like musl libc).
|
||||
|
||||
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=92043
|
||||
---
|
||||
configure.ac | 39 --------------------------------------
|
||||
dbus/dbus-marshal-basic.c | 8 +++++---
|
||||
dbus/dbus-marshal-recursive-util.c | 8 +++++---
|
||||
tools/dbus-print-message.c | 21 ++++++++++----------
|
||||
4 files changed, 21 insertions(+), 55 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 529e960..4c1fe5b 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -337,31 +337,6 @@ if test x$enable_compiler_coverage = xyes; then
|
||||
AC_DEFINE_UNQUOTED(DBUS_GCOV_ENABLED, 1, [Defined if gcov is enabled to force a rebuild due to config.h changing])
|
||||
fi
|
||||
|
||||
-# glibc21.m4 serial 3
|
||||
-dnl Copyright (C) 2000-2002, 2004 Free Software Foundation, Inc.
|
||||
-dnl This file is free software; the Free Software Foundation
|
||||
-dnl gives unlimited permission to copy and/or distribute it,
|
||||
-dnl with or without modifications, as long as this notice is preserved.
|
||||
-
|
||||
-# Test for the GNU C Library, version 2.1 or newer.
|
||||
-# From Bruno Haible.
|
||||
-
|
||||
-AC_CACHE_CHECK(whether we are using the GNU C Library 2.1 or newer,
|
||||
- ac_cv_gnu_library_2_1,
|
||||
- [AC_EGREP_CPP([Lucky GNU user],
|
||||
- [
|
||||
-#include <features.h>
|
||||
-#ifdef __GNU_LIBRARY__
|
||||
- #if (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1) || (__GLIBC__ > 2)
|
||||
- Lucky GNU user
|
||||
- #endif
|
||||
-#endif
|
||||
- ],
|
||||
- ac_cv_gnu_library_2_1=yes,
|
||||
- ac_cv_gnu_library_2_1=no)
|
||||
- ]
|
||||
-)
|
||||
-
|
||||
#### Integer sizes
|
||||
|
||||
AC_CHECK_SIZEOF(char)
|
||||
@@ -380,32 +355,21 @@ $ac_cv_sizeof_int)
|
||||
dbusint64=int
|
||||
dbusint64_constant='(val)'
|
||||
dbusuint64_constant='(val)'
|
||||
- dbusint64_printf_modifier='""'
|
||||
;;
|
||||
$ac_cv_sizeof_long)
|
||||
dbusint64=long
|
||||
dbusint64_constant='(val##L)'
|
||||
dbusuint64_constant='(val##UL)'
|
||||
- dbusint64_printf_modifier='"l"'
|
||||
;;
|
||||
$ac_cv_sizeof_long_long)
|
||||
dbusint64='long long'
|
||||
dbusint64_constant='(val##LL)'
|
||||
dbusuint64_constant='(val##ULL)'
|
||||
- # Ideally we discover what the format is, but this is
|
||||
- # only used in verbose mode, so eh...
|
||||
- if test x"$ac_cv_gnu_library_2_1" = xyes; then
|
||||
- dbusint64_printf_modifier='"ll"'
|
||||
- fi
|
||||
;;
|
||||
$ac_cv_sizeof___int64)
|
||||
dbusint64=__int64
|
||||
dbusint64_constant='(val##i64)'
|
||||
dbusuint64_constant='(val##ui64)'
|
||||
- # See above case
|
||||
- if test x"$ac_cv_gnu_library_2_1" = xyes; then
|
||||
- dbusint64_printf_modifier='"ll"'
|
||||
- fi
|
||||
;;
|
||||
esac
|
||||
|
||||
@@ -423,9 +387,6 @@ Please report a bug here with details of your platform and compiler:
|
||||
DBUS_INT64_TYPE="$dbusint64"
|
||||
DBUS_INT64_CONSTANT="$dbusint64_constant"
|
||||
DBUS_UINT64_CONSTANT="$dbusuint64_constant"
|
||||
- if test x"$dbusint64_printf_modifier" != x; then
|
||||
- AC_DEFINE_UNQUOTED(DBUS_INT64_PRINTF_MODIFIER, [$dbusint64_printf_modifier], [Define to printf modifier for 64 bit integer type])
|
||||
- fi
|
||||
AC_MSG_RESULT($DBUS_INT64_TYPE)
|
||||
])
|
||||
|
||||
diff --git a/dbus/dbus-marshal-basic.c b/dbus/dbus-marshal-basic.c
|
||||
index 74fe3f9..9315b6e 100644
|
||||
--- a/dbus/dbus-marshal-basic.c
|
||||
+++ b/dbus/dbus-marshal-basic.c
|
||||
@@ -29,6 +29,10 @@
|
||||
|
||||
#include <string.h>
|
||||
|
||||
+#if !defined(PRIx64) && defined(DBUS_WIN)
|
||||
+#define PRIx64 "%I64x"
|
||||
+#endif
|
||||
+
|
||||
#if defined(__GNUC__) && (__GNUC__ >= 4)
|
||||
# define _DBUS_ASSERT_ALIGNMENT(type, op, val) \
|
||||
_DBUS_STATIC_ASSERT (__extension__ __alignof__ (type) op val)
|
||||
@@ -1334,10 +1338,8 @@ _dbus_verbose_bytes (const unsigned char *data,
|
||||
if (i > 7 &&
|
||||
_DBUS_ALIGN_ADDRESS (&data[i], 8) == &data[i])
|
||||
{
|
||||
-#ifdef DBUS_INT64_PRINTF_MODIFIER
|
||||
- _dbus_verbose (" u64: 0x%" DBUS_INT64_PRINTF_MODIFIER "x",
|
||||
+ _dbus_verbose (" u64: 0x%" PRIx64,
|
||||
*(dbus_uint64_t*)&data[i-8]);
|
||||
-#endif
|
||||
_dbus_verbose (" dbl: %g",
|
||||
*(double*)&data[i-8]);
|
||||
}
|
||||
diff --git a/dbus/dbus-marshal-recursive-util.c b/dbus/dbus-marshal-recursive-util.c
|
||||
index 3bc26a8..4d57f49 100644
|
||||
--- a/dbus/dbus-marshal-recursive-util.c
|
||||
+++ b/dbus/dbus-marshal-recursive-util.c
|
||||
@@ -31,6 +31,10 @@
|
||||
#include "dbus-internals.h"
|
||||
#include <string.h>
|
||||
|
||||
+#if !defined(PRIx64) && defined(DBUS_WIN)
|
||||
+#define PRIx64 "%I64x"
|
||||
+#endif
|
||||
+
|
||||
static void
|
||||
basic_value_zero (DBusBasicValue *value)
|
||||
{
|
||||
@@ -2644,12 +2648,10 @@ double_read_value (TestTypeNode *node,
|
||||
|
||||
if (!_DBUS_DOUBLES_BITWISE_EQUAL (v, expected))
|
||||
{
|
||||
-#ifdef DBUS_INT64_PRINTF_MODIFIER
|
||||
- _dbus_warn ("Expected double %g got %g\n bits = 0x%" DBUS_INT64_PRINTF_MODIFIER "x vs.\n bits = 0x%" DBUS_INT64_PRINTF_MODIFIER "x)\n",
|
||||
+ _dbus_warn ("Expected double %g got %g\n bits = 0x%" PRIx64 " vs.\n bits = 0x%" PRIx64 ")\n",
|
||||
expected, v,
|
||||
*(dbus_uint64_t*)(char*)&expected,
|
||||
*(dbus_uint64_t*)(char*)&v);
|
||||
-#endif
|
||||
_dbus_assert_not_reached ("test failed");
|
||||
}
|
||||
|
||||
diff --git a/tools/dbus-print-message.c b/tools/dbus-print-message.c
|
||||
index 80c9698..04b817e 100644
|
||||
--- a/tools/dbus-print-message.c
|
||||
+++ b/tools/dbus-print-message.c
|
||||
@@ -39,6 +39,15 @@
|
||||
|
||||
#include "tool-common.h"
|
||||
|
||||
+#if defined(DBUS_WIN)
|
||||
+#if !defined(PRId64)
|
||||
+#define PRId64 "%I64d"
|
||||
+#endif
|
||||
+#if !defined(PRIu64)
|
||||
+#define PRIu64 "%I64u"
|
||||
+#endif
|
||||
+#endif
|
||||
+
|
||||
static const char*
|
||||
type_to_name (int message_type)
|
||||
{
|
||||
@@ -384,11 +393,7 @@ print_iter (DBusMessageIter *iter, dbus_bool_t literal, int depth)
|
||||
{
|
||||
dbus_int64_t val;
|
||||
dbus_message_iter_get_basic (iter, &val);
|
||||
-#ifdef DBUS_INT64_PRINTF_MODIFIER
|
||||
- printf ("int64 %" DBUS_INT64_PRINTF_MODIFIER "d\n", val);
|
||||
-#else
|
||||
- printf ("int64 (omitted)\n");
|
||||
-#endif
|
||||
+ printf ("int64 %" PRId64 "\n", val);
|
||||
break;
|
||||
}
|
||||
|
||||
@@ -396,11 +401,7 @@ print_iter (DBusMessageIter *iter, dbus_bool_t literal, int depth)
|
||||
{
|
||||
dbus_uint64_t val;
|
||||
dbus_message_iter_get_basic (iter, &val);
|
||||
-#ifdef DBUS_INT64_PRINTF_MODIFIER
|
||||
- printf ("uint64 %" DBUS_INT64_PRINTF_MODIFIER "u\n", val);
|
||||
-#else
|
||||
- printf ("uint64 (omitted)\n");
|
||||
-#endif
|
||||
+ printf ("uint64 %" PRIu64 "\n", val);
|
||||
break;
|
||||
}
|
||||
|
||||
--
|
||||
2.5.3
|
||||
|
|
@ -1,11 +1,12 @@
|
|||
pkgname=postmarketos-ui-plasma-mobile
|
||||
pkgver=1
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
pkgdesc="(Wayland) Mobile variant of KDE Plasma, optimized for touchscreen (COMPILING TAKES FOREVER)"
|
||||
url="https://wiki.postmarketos.org/wiki/Plasma_Mobile"
|
||||
arch="noarch"
|
||||
license="GPL3+"
|
||||
depends="plasma-phone-components dbus-nox11 qmltermwidget plasma-settings
|
||||
# dbus-x11 provides dbus-launch
|
||||
depends="plasma-phone-components dbus dbus-x11 qmltermwidget plasma-settings
|
||||
breeze-icons postmarketos-demos kscreen qt5-qtvirtualkeyboard
|
||||
plasma-camera elisa pulseaudio pulseaudio-utils consolekit2"
|
||||
makedepends=""
|
||||
|
|
Loading…
Reference in a new issue