fujitsu-m532: new device (Fujitsu Stylistic M532) (!914)
This commit is contained in:
parent
0d82bb48dd
commit
2e1868dfa0
8 changed files with 3461 additions and 0 deletions
23
device/device-fujitsu-m532/APKBUILD
Normal file
23
device/device-fujitsu-m532/APKBUILD
Normal file
|
@ -0,0 +1,23 @@
|
|||
# Contributor: cunidev <rtranquillini@unibz.it>
|
||||
pkgname="device-fujitsu-m532"
|
||||
pkgdesc="Fujitsu Stylistic M532"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="armv7"
|
||||
options="!check !archcheck"
|
||||
depends="postmarketos-base linux-fujitsu-m532 mkbootimg mesa-dri-swrast"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
|
||||
sha512sums="03ed799156e815e369b2b5e762febd4c17ed5aa6b8e86d9b2f409f3114623b5f35a2e6708903a7e4916333197f354fc83ade19523b5b3a23b27083c320efe92c deviceinfo"
|
34
device/device-fujitsu-m532/deviceinfo
Normal file
34
device/device-fujitsu-m532/deviceinfo
Normal file
|
@ -0,0 +1,34 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="1"
|
||||
deviceinfo_name="Fujitsu Stylistic M532"
|
||||
deviceinfo_manufacturer="Fujitsu"
|
||||
deviceinfo_codename="fujitsu-m532"
|
||||
deviceinfo_date=""
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_arch="armv7"
|
||||
|
||||
# Device related
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="1280"
|
||||
deviceinfo_screen_height="800"
|
||||
deviceinfo_dev_touchscreen="/dev/input/event0"
|
||||
deviceinfo_dev_touchscreen_calibration=""
|
||||
deviceinfo_dev_keyboard=""
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline=""
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_offset_base="0x10000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
|
|
@ -0,0 +1,13 @@
|
|||
diff --git a/kernel/timeconst.pl b/kernel/timeconst.pl
|
||||
index eb51d76..0461239 100644
|
||||
--- a/kernel/timeconst.pl
|
||||
+++ b/kernel/timeconst.pl
|
||||
@@ -370,7 +370,7 @@ if ($hz eq '--can') {
|
||||
}
|
||||
|
||||
@val = @{$canned_values{$hz}};
|
||||
- if (!defined(@val)) {
|
||||
+ if (!@val) {
|
||||
@val = compute_values($hz);
|
||||
}
|
||||
output($hz, @val);
|
71
device/linux-fujitsu-m532/APKBUILD
Normal file
71
device/linux-fujitsu-m532/APKBUILD
Normal file
|
@ -0,0 +1,71 @@
|
|||
# Contributor: cunidev <rtranquillini@unibz.it>
|
||||
# Kernel config based on: /.config.beta13.1
|
||||
|
||||
pkgname="linux-fujitsu-m532"
|
||||
pkgver=3.1.10
|
||||
pkgrel=0
|
||||
pkgdesc="Fujitsu Stylistic M532 kernel fork"
|
||||
arch="armv7"
|
||||
_carch="arm"
|
||||
_flavor="fujitsu-m532"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps"
|
||||
makedepends="gcc6 perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev devicepkg-dev"
|
||||
|
||||
# Compiler: GCC 6 (doesn't boot when compiled with newer versions)
|
||||
if [ "${CC:0:5}" != "gcc6-" ]; then
|
||||
CC="gcc6-$CC"
|
||||
HOSTCC="gcc6-gcc"
|
||||
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
|
||||
fi
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_chagall"
|
||||
_commit="1bcab4a49982baea177c26994d2b67811e7b16f9"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/n5047c/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
gcc8-fix-put-user.patch
|
||||
1-5-kbuild-remove-deprecated-use-of-defined-in-timeconst.pl.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
downstreamkernel_prepare "$srcdir" "$builddir" "$_config" "$_carch" "$HOSTCC"
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
# kernel.release
|
||||
install -D "$builddir/include/config/kernel.release" \
|
||||
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||
|
||||
# zImage (find the right one)
|
||||
cd "$builddir/arch/$_carch/boot"
|
||||
_target="$pkgdir/boot/vmlinuz-$_flavor"
|
||||
for _zimg in zImage-dtb Image.gz-dtb *zImage Image; do
|
||||
[ -e "$_zimg" ] || continue
|
||||
msg "zImage found: $_zimg"
|
||||
install -Dm644 "$_zimg" "$_target"
|
||||
break
|
||||
done
|
||||
if ! [ -e "$_target" ]; then
|
||||
error "Could not find zImage in $PWD!"
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
sha512sums="7effec2a47246e65063d9bd60c547a8622aa9c934fd812ac189b9aa44f9c59628741c33b13ca99253d25e845aed24ccf56ae4492b70aff75f0651870f5e6447f linux-fujitsu-m532-1bcab4a49982baea177c26994d2b67811e7b16f9.tar.gz
|
||||
bdd4419c2ec011123510815edee295c088142bdc05cb73a24317bf643a100cd95a83254a407aeda704ef9e1333af310337708dc404ee3ae8507627bf4991399d config-fujitsu-m532.armv7
|
||||
77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7 gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||
88f5b9341839cae62940330f5cb822f363ddca5773555b6bd7b19d380e329c128fe878ebd9233dd1aafc931fb1c1839fbe327fd7d623265fba51a782928cbcdf 1-5-kbuild-remove-deprecated-use-of-defined-in-timeconst.pl.patch"
|
3317
device/linux-fujitsu-m532/config-fujitsu-m532.armv7
Normal file
3317
device/linux-fujitsu-m532/config-fujitsu-m532.armv7
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc7-give-up-on-ilog2-const-optimizations.patch
|
1
device/linux-fujitsu-m532/gcc8-fix-put-user.patch
Symbolic link
1
device/linux-fujitsu-m532/gcc8-fix-put-user.patch
Symbolic link
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc8-fix-put-user.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/kernel-use-the-gnu89-standard-explicitly.patch
|
Loading…
Reference in a new issue