amazon-sheldon: new device (MR 4698)
This commit is contained in:
parent
a66a9051a5
commit
2ac7ccbdb4
8 changed files with 4567 additions and 0 deletions
29
device/testing/device-amazon-sheldon/APKBUILD
Normal file
29
device/testing/device-amazon-sheldon/APKBUILD
Normal file
|
@ -0,0 +1,29 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
# Maintainer: Eli Hersha <elihersha@gmail.com>
|
||||
pkgname=device-amazon-sheldon
|
||||
pkgdesc="Amazon Fire TV Stick Lite"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="armv7"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-amazon-sheldon
|
||||
mkbootimg
|
||||
postmarketos-base
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
37620adb66743b95831a0147b8ed6cda20f977f97355738da80d9896d2454182aeb3e1f9a9d12951329db4f3cfb9b38c7600898656cf14259b3a6088c3fca473 deviceinfo
|
||||
"
|
28
device/testing/device-amazon-sheldon/deviceinfo
Normal file
28
device/testing/device-amazon-sheldon/deviceinfo
Normal file
|
@ -0,0 +1,28 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Amazon Fire TV Stick Lite"
|
||||
deviceinfo_manufacturer="Amazon"
|
||||
deviceinfo_codename="amazon-sheldon"
|
||||
deviceinfo_year="2020"
|
||||
deviceinfo_arch="armv7"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="embedded"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="false"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="bootopt=64S3,32N2,32N2 buildvariant=user veritykeyid=id:f3530e18f64d11fc25eb2dd762979f078de990bf"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_header_version="1"
|
||||
deviceinfo_flash_offset_base="0x40000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x15000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x14000000"
|
62
device/testing/linux-amazon-sheldon/APKBUILD
Normal file
62
device/testing/linux-amazon-sheldon/APKBUILD
Normal file
|
@ -0,0 +1,62 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm/configs/sheldon_defconfig
|
||||
pkgname=linux-amazon-sheldon
|
||||
pkgver=4.4.121
|
||||
pkgrel=0
|
||||
pkgdesc="Amazon Fire TV Stick Lite kernel fork"
|
||||
arch="armv7"
|
||||
_carch="arm"
|
||||
_flavor="amazon-sheldon"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
findutils
|
||||
flex
|
||||
openssl-dev
|
||||
perl
|
||||
"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_amazon_mt8695"
|
||||
_commit="119f0dd3c04a91639cc80cf46371d724d84b1048"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/mt8695/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
linux4.2-gcc10-extern_YYLOC_global_declaration.patch
|
||||
proc-v7-fix.patch
|
||||
head.s-fix.patch
|
||||
piggy.gzip.s-fix.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" \
|
||||
"$_flavor" "$_outdir"
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
0efe1eb1751d2af6013d4dbe2bee69f84f83dede7a50db1a2de41daa987e31f6fc8df0e9780d3d0a9ae865ada0f0af55ba8e391e2c56024715a62911fa2c03ef linux-amazon-sheldon-119f0dd3c04a91639cc80cf46371d724d84b1048.tar.gz
|
||||
a3f0998128a379802696ec56d5a734930ece813637837b2b5feefbcf5aec0ffebc38c5eac05349ee445ae4aca70612b39ddde8cb4c870c78381cb456d8191279 config-amazon-sheldon.armv7
|
||||
eaf2e61fcb508cdd239b8fed209d2a09ecac77287f6b46d003918fdf1c6fa2ee63f7390f3ff7c49029b8ed6cbcdd81c7e9a4b1ece9f5060b6fc84e322bd47f41 linux4.2-gcc10-extern_YYLOC_global_declaration.patch
|
||||
f1218ddaf456e53945c647cc4e3459acc2a1ec33e20f746cf3d74950fcdbfe50e0eee6e9dadc386f4aecba1495e35f2f24f30325d7fcf1e51d9bd8d648072fad proc-v7-fix.patch
|
||||
b396a1586f9746054f54534891baab8c9c20f49630f74ec99ce7c0f34fdf2f91b0891d747e7cc576be5695056a5453f6595b50e38718db84c4bde11d4dfa7c5f head.s-fix.patch
|
||||
40aac5e96cc9e2c2b5d66665b60311a2eccd001669e98415e48e6f22be344fad01bc6ef6aa125854586a7f930a0623afcbc899accae38bf7dabd457b681fc5ec piggy.gzip.s-fix.patch
|
||||
"
|
4321
device/testing/linux-amazon-sheldon/config-amazon-sheldon.armv7
Normal file
4321
device/testing/linux-amazon-sheldon/config-amazon-sheldon.armv7
Normal file
File diff suppressed because it is too large
Load diff
22
device/testing/linux-amazon-sheldon/head.s-fix.patch
Normal file
22
device/testing/linux-amazon-sheldon/head.s-fix.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
From 1e5273ea46a2869ad31d9275dc99661ef58f013b Mon Sep 17 00:00:00 2001
|
||||
From: BeastRein <80418545+BeastRein@users.noreply.github.com>
|
||||
Date: Mon, 8 Jan 2024 20:06:32 -0500
|
||||
Subject: [PATCH] Update head.S
|
||||
|
||||
---
|
||||
arch/arm/boot/compressed/head.S | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/compressed/head.S b/arch/arm/boot/compressed/head.S
|
||||
index d2e43b053d9b..002cb8ca3d40 100644
|
||||
--- a/arch/arm/boot/compressed/head.S
|
||||
+++ b/arch/arm/boot/compressed/head.S
|
||||
@@ -112,7 +112,7 @@
|
||||
#endif
|
||||
.endm
|
||||
|
||||
- .section ".start", #alloc, #execinstr
|
||||
+ .section ".start", "ax"
|
||||
/*
|
||||
* sort out different calling conventions
|
||||
*/
|
|
@ -0,0 +1,64 @@
|
|||
From 4c2e46a9ec9ec477346d9145fdeba8413ae5c515 Mon Sep 17 00:00:00 2001
|
||||
From: Dirk Mueller <dmueller@suse.com>
|
||||
Date: Tue, 14 Jan 2020 18:53:41 +0100
|
||||
Subject: [PATCH] scripts/dtc: Remove redundant YYLOC global declaration
|
||||
|
||||
gcc 10 will default to -fno-common, which causes this error at link
|
||||
time:
|
||||
|
||||
(.text+0x0): multiple definition of `yylloc'; dtc-lexer.lex.o (symbol from plugin):(.text+0x0): first defined here
|
||||
|
||||
This is because both dtc-lexer as well as dtc-parser define the same
|
||||
global symbol yyloc. Before with -fcommon those were merged into one
|
||||
defintion. The proper solution would be to to mark this as "extern",
|
||||
however that leads to:
|
||||
|
||||
dtc-lexer.l:26:16: error: redundant redeclaration of 'yylloc' [-Werror=redundant-decls]
|
||||
26 | extern YYLTYPE yylloc;
|
||||
| ^~~~~~
|
||||
In file included from dtc-lexer.l:24:
|
||||
dtc-parser.tab.h:127:16: note: previous declaration of 'yylloc' was here
|
||||
127 | extern YYLTYPE yylloc;
|
||||
| ^~~~~~
|
||||
cc1: all warnings being treated as errors
|
||||
|
||||
which means the declaration is completely redundant and can just be
|
||||
dropped.
|
||||
|
||||
Signed-off-by: Dirk Mueller <dmueller@suse.com>
|
||||
Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
|
||||
[robh: cherry-pick from upstream]
|
||||
Cc: stable@vger.kernel.org
|
||||
Signed-off-by: Rob Herring <robh@kernel.org>
|
||||
---
|
||||
scripts/dtc/dtc-lexer.l | 1 -
|
||||
scripts/dtc/dtc-lexer.lex.c_shipped | 1 -
|
||||
2 files changed, 2 deletions(-)
|
||||
|
||||
diff --git a/scripts/dtc/dtc-lexer.l b/scripts/dtc/dtc-lexer.l
|
||||
index 790fbf6cf2d7..e4e0f6a8d07b 100644
|
||||
--- a/scripts/dtc/dtc-lexer.l
|
||||
+++ b/scripts/dtc/dtc-lexer.l
|
||||
@@ -38,7 +38,6 @@ LINECOMMENT "//".*\n
|
||||
#include "srcpos.h"
|
||||
#include "dtc-parser.tab.h"
|
||||
|
||||
-YYLTYPE yylloc;
|
||||
extern bool treesource_error;
|
||||
|
||||
/* CAUTION: this will stop working if we ever use yyless() or yyunput() */
|
||||
diff --git a/scripts/dtc/dtc-lexer.lex.c_shipped b/scripts/dtc/dtc-lexer.lex.c_shipped
|
||||
index ba525c2f9fc2..750f7a4e3ece 100644
|
||||
--- a/scripts/dtc/dtc-lexer.lex.c_shipped
|
||||
+++ b/scripts/dtc/dtc-lexer.lex.c_shipped
|
||||
@@ -637,7 +637,6 @@ char *yytext;
|
||||
#include "srcpos.h"
|
||||
#include "dtc-parser.tab.h"
|
||||
|
||||
-YYLTYPE yylloc;
|
||||
extern bool treesource_error;
|
||||
|
||||
/* CAUTION: this will stop working if we ever use yyless() or yyunput() */
|
||||
--
|
||||
2.28.0
|
||||
|
19
device/testing/linux-amazon-sheldon/piggy.gzip.s-fix.patch
Normal file
19
device/testing/linux-amazon-sheldon/piggy.gzip.s-fix.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
From d4501f99a743889e89afea7f3d9675d8a5cb2907 Mon Sep 17 00:00:00 2001
|
||||
From: BeastRein <80418545+BeastRein@users.noreply.github.com>
|
||||
Date: Mon, 8 Jan 2024 20:12:08 -0500
|
||||
Subject: [PATCH] Update piggy.gzip.S
|
||||
|
||||
---
|
||||
arch/arm/boot/compressed/piggy.gzip.S | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/compressed/piggy.gzip.S b/arch/arm/boot/compressed/piggy.gzip.S
|
||||
index a68adf91a165..c71952cfe45d 100644
|
||||
--- a/arch/arm/boot/compressed/piggy.gzip.S
|
||||
+++ b/arch/arm/boot/compressed/piggy.gzip.S
|
||||
@@ -1,4 +1,4 @@
|
||||
- .section .piggydata,#alloc
|
||||
+ .section .piggydata, "a"
|
||||
.globl input_data
|
||||
input_data:
|
||||
.incbin "arch/arm/boot/compressed/piggy.gzip"
|
22
device/testing/linux-amazon-sheldon/proc-v7-fix.patch
Normal file
22
device/testing/linux-amazon-sheldon/proc-v7-fix.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
From 50f223713472d5edced4cac7b8b32db0310973fc Mon Sep 17 00:00:00 2001
|
||||
From: BeastRein <80418545+BeastRein@users.noreply.github.com>
|
||||
Date: Mon, 8 Jan 2024 19:43:05 -0500
|
||||
Subject: [PATCH] Update proc-v7.S
|
||||
|
||||
---
|
||||
arch/arm/mm/proc-v7.S | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/mm/proc-v7.S b/arch/arm/mm/proc-v7.S
|
||||
index 8e1ea433c3f1..e35a5e8cd700 100644
|
||||
--- a/arch/arm/mm/proc-v7.S
|
||||
+++ b/arch/arm/mm/proc-v7.S
|
||||
@@ -504,7 +504,7 @@ __v7_setup_stack:
|
||||
string cpu_elf_name, "v7"
|
||||
.align
|
||||
|
||||
- .section ".proc.info.init", #alloc
|
||||
+ .section ".proc.info.init", "a"
|
||||
|
||||
/*
|
||||
* Standard v7 proc info content
|
Loading…
Reference in a new issue