wexler-qc750: new device (MR 1742)
Hello there, DragonX256 here. For now, this tablet only have flashing, USB net, display and touchscreen. I will try to add other features soon, or, if I fail enough, switch to mainlining immediately :D
This commit is contained in:
parent
3fd5a9a568
commit
252466cb17
10 changed files with 3602 additions and 0 deletions
22
device/testing/device-wexler-qc750/APKBUILD
Normal file
22
device/testing/device-wexler-qc750/APKBUILD
Normal file
|
@ -0,0 +1,22 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-wexler-qc750
|
||||
pkgdesc="WEXLER Tab 7t"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="armv7"
|
||||
options="!check !archcheck"
|
||||
depends="postmarketos-base linux-wexler-qc750 mkbootimg mesa-dri-gallium"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="4f39d73cbfb1a1233bc32abe2e186d66d9c8dc7436c711b5ffd6cb5426c517d77e3e9f0fc108cd9a6a64349623843ed2d5ea8363f4f8785597e12c0a2e34bdd6 deviceinfo"
|
34
device/testing/device-wexler-qc750/deviceinfo
Normal file
34
device/testing/device-wexler-qc750/deviceinfo
Normal file
|
@ -0,0 +1,34 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="WEXLER Tab 7t"
|
||||
deviceinfo_manufacturer="WEXLER"
|
||||
deviceinfo_codename="wexler-qc750"
|
||||
deviceinfo_year="2012"
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_arch="armv7"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="tablet"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="false"
|
||||
deviceinfo_screen_width="1280"
|
||||
deviceinfo_screen_height="800"
|
||||
deviceinfo_framebuffer_landscape="true"
|
||||
deviceinfo_dev_touchscreen="/dev/input/event4"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline=""
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_offset_base="0x10000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
|
@ -0,0 +1,15 @@
|
|||
diff --git a/drivers/input/touchscreen/Novatek_TouchDriver.c b/drivers/input/touchscreen/Novatek_TouchDriver.c
|
||||
index 5cccaf03..b1eb5e69 100755
|
||||
--- a/drivers/input/touchscreen/Novatek_TouchDriver.c
|
||||
+++ b/drivers/input/touchscreen/Novatek_TouchDriver.c
|
||||
@@ -1122,8 +1122,8 @@ err_gpio_request_failed:
|
||||
}
|
||||
#endif
|
||||
|
||||
-// input_set_abs_params(ts->input_dev, ABS_X, 0, ts->abs_x_max-1, 0, 0);
|
||||
-// input_set_abs_params(ts->input_dev, ABS_Y, 0, ts->abs_y_max-1, 0, 0);
|
||||
+ input_set_abs_params(ts->input_dev, ABS_X, 0, ts->abs_x_max-1, 0, 0);
|
||||
+ input_set_abs_params(ts->input_dev, ABS_Y, 0, ts->abs_y_max-1, 0, 0);
|
||||
input_set_abs_params(ts->input_dev, ABS_PRESSURE, 0, 255, 0, 0);
|
||||
|
||||
#ifdef NOVATEK_MULTI_TOUCH
|
12
device/testing/linux-wexler-qc750/03_fix_rndis.patch
Normal file
12
device/testing/linux-wexler-qc750/03_fix_rndis.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -r -u -N android_kernel_samsung_golden-2662dc4f65ef3ad5eeb4222d3aad5dd418a04510/drivers/usb/gadget/ether.c tmp-kernel/drivers/usb/gadget/ether.c
|
||||
--- ./drivers/usb/gadget/ether.c 2018-04-19 15:50:23.962332146 +0100
|
||||
+++ ./drivers/usb/gadget/ether.c 2018-04-19 15:45:50.823455075 +0100
|
||||
@@ -246,7 +246,7 @@
|
||||
c->bmAttributes |= USB_CONFIG_ATT_WAKEUP;
|
||||
}
|
||||
|
||||
- return rndis_bind_config(c, hostaddr);
|
||||
+ return rndis_bind_config(c, hostaddr, device_desc.idVendor, device_desc.iManufacturer);
|
||||
}
|
||||
|
||||
static struct usb_configuration rndis_config_driver = {
|
63
device/testing/linux-wexler-qc750/APKBUILD
Normal file
63
device/testing/linux-wexler-qc750/APKBUILD
Normal file
|
@ -0,0 +1,63 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm/configs/morpheus_qc750_defconfig
|
||||
|
||||
pkgname=linux-wexler-qc750
|
||||
pkgver=3.1.10
|
||||
pkgrel=0
|
||||
pkgdesc="WEXLER Tab 7t kernel fork"
|
||||
arch="armv7"
|
||||
_carch="arm"
|
||||
_flavor="wexler-qc750"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="bash bc bison devicepkg-dev flex openssl-dev perl gcc6"
|
||||
|
||||
# Compiler: GCC 6 (doesn't boot when compiled with newer versions)
|
||||
if [ "${CC:0:5}" != "gcc6-" ]; then
|
||||
CC="gcc6-$CC"
|
||||
HOSTCC="gcc6-gcc"
|
||||
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
|
||||
fi
|
||||
|
||||
# Source
|
||||
_repository="morpheus_kernel_wexler_qc750"
|
||||
_commit="f1b77fa6e9553cf16f39ca8d328e1e5d45f74a62"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/DmitryADP/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
gcc8-fix-put-user.patch
|
||||
gcc10-extern_YYLOC_global_declaration.patch
|
||||
kernel-use-the-gnu89-standard-explicitly.patch
|
||||
03_fix_rndis.patch
|
||||
00-nt11003-touchscreen-fix.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make mrproper
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
}
|
||||
|
||||
sha512sums="0a09ce448b393eb1ab11a0b9b24c8cfc924d3a8c246f230cce03cf24bf9e7f501d7b116114727be0cafbcd1749d81c5bbc5e3d23e663d1f7f6c339a919424917 linux-wexler-qc750-f1b77fa6e9553cf16f39ca8d328e1e5d45f74a62.tar.gz
|
||||
1287e8b4868b22571d868be18b6bde0fdbf1bf612bb035d268bdadb571dac16007b004fbd694406f905709488d1bf057d51cb48945fd3dedf347035da40e937a config-wexler-qc750.armv7
|
||||
77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7 gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||
ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c kernel-use-the-gnu89-standard-explicitly.patch
|
||||
6585c67450f1ef6d0c165ce4cb5c64f64d779147d1390558bf72cd40da5a33d53de6fd3c67e5ab864c14b3f67602bbe3060eea07c85b19bb82a0735024b369eb 03_fix_rndis.patch
|
||||
729d57263eec3df038debd0f6abac748cee0a346d87e1bded7c905d5ae5ba224be7313488345c6e77f5f7c3d59d5f226bf9c3c2e5b331e461356c748ad1a422e 00-nt11003-touchscreen-fix.patch"
|
3452
device/testing/linux-wexler-qc750/config-wexler-qc750.armv7
Normal file
3452
device/testing/linux-wexler-qc750/config-wexler-qc750.armv7
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc7-give-up-on-ilog2-const-optimizations.patch
|
1
device/testing/linux-wexler-qc750/gcc8-fix-put-user.patch
Symbolic link
1
device/testing/linux-wexler-qc750/gcc8-fix-put-user.patch
Symbolic link
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc8-fix-put-user.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/kernel-use-the-gnu89-standard-explicitly.patch
|
Loading…
Reference in a new issue