Package the Plasma phone dialler (#1270)
* Package everything required for the Plasma dialler * Improve build scripts * Bump pkgrel of plasma-phone-components
This commit is contained in:
parent
76ed56905a
commit
23b5c7d3a1
5 changed files with 99 additions and 25 deletions
|
@ -1,6 +1,6 @@
|
|||
pkgname=plasma-phone-components
|
||||
pkgver=0_git20180123
|
||||
pkgrel=0
|
||||
pkgrel=1
|
||||
_commit=3b265922fdf8817dab9115fd128ddf731126e2c5
|
||||
pkgdesc="Modules providing phone functionality for Plasma"
|
||||
arch="all"
|
||||
|
@ -11,12 +11,12 @@ makedepends="extra-cmake-modules kpeople-dev qt5-qtdeclarative-dev kactivities-d
|
|||
plasma-framework-dev kservice-dev kdeclarative-dev ki18n-dev kio-dev kcoreaddons-dev
|
||||
kconfig-dev kbookmarks-dev kwidgetsaddons-dev kcompletion-dev kitemviews-dev
|
||||
kjobwidgets-dev solid-dev kxmlgui-dev kconfigwidgets-dev kauth-dev kcodecs-dev
|
||||
kpackage-dev kwindowsystem-dev kdbusaddons-dev knotifications-dev kwayland-dev"
|
||||
kpackage-dev kwindowsystem-dev kdbusaddons-dev knotifications-dev kwayland-dev
|
||||
telepathy-qt5-dev"
|
||||
install="$pkgname.post-install
|
||||
$pkgname.post-upgrade
|
||||
$pkgname.post-deinstall"
|
||||
source="$pkgname-$pkgver.tar.gz::https://github.com/kde/$pkgname/archive/$_commit.tar.gz
|
||||
unset-telepathy-dep.patch"
|
||||
source="$pkgname-$pkgver.tar.gz::https://github.com/kde/$pkgname/archive/$_commit.tar.gz"
|
||||
builddir="$srcdir/$pkgname-$_commit"
|
||||
|
||||
build() {
|
||||
|
@ -39,5 +39,4 @@ package() {
|
|||
make DESTDIR="$pkgdir/" install
|
||||
}
|
||||
|
||||
sha512sums="8fd57df0e5e6fd0653891c94c2121d0fef03f1ec7ae2e1f4bc6bd66e2246a88beeba6d349e1a63cae4d00cd8f784c990af383fc120a6c5703ea172eab916ba91 plasma-phone-components-0_git20180123.tar.gz
|
||||
deba478c29403c04e44a3007e64927fedaaf21e9207b834cd4c8574714d86f2e4f4bce0e6694d74eb151f11c4a8164b9a2e21c864aa823394a026395582dbccf unset-telepathy-dep.patch"
|
||||
sha512sums="8fd57df0e5e6fd0653891c94c2121d0fef03f1ec7ae2e1f4bc6bd66e2246a88beeba6d349e1a63cae4d00cd8f784c990af383fc120a6c5703ea172eab916ba91 plasma-phone-components-0_git20180123.tar.gz"
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 609ccac..a0ba2b3 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -27,7 +27,6 @@ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED Core Gui Widgets Qml Quick Te
|
||||
|
||||
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS Plasma Service Declarative I18n KIO People)
|
||||
find_package(KF5 REQUIRED COMPONENTS PlasmaQuick DBusAddons Notifications)
|
||||
-find_package(TelepathyQt5 REQUIRED)
|
||||
find_package(KF5Wayland CONFIG)
|
||||
set_package_properties(KF5Wayland PROPERTIES
|
||||
TYPE REQUIRED
|
||||
@@ -55,6 +54,5 @@ add_subdirectory(bin)
|
||||
add_subdirectory(applets)
|
||||
add_subdirectory(containments)
|
||||
add_subdirectory(components)
|
||||
-add_subdirectory(dialer)
|
||||
add_subdirectory(sounds)
|
||||
add_subdirectory(touchscreentest)
|
32
main/telepathy-farstream/APKBUILD
Normal file
32
main/telepathy-farstream/APKBUILD
Normal file
|
@ -0,0 +1,32 @@
|
|||
pkgname=telepathy-farstream
|
||||
pkgver=0.6.2
|
||||
pkgrel=0
|
||||
pkgdesc="Telepathy GLib-based client library that uses Farstream to handle Call channels"
|
||||
arch="all"
|
||||
url="https://telepathy.freedesktop.org/components/telepathy-farstream/"
|
||||
license="LGPL2.1"
|
||||
depends="telepathy-glib farstream"
|
||||
depends_dev="dbus-glib-dev telepathy-glib-dev farstream-dev gobject-introspection-dev"
|
||||
makedepends="$depends_dev autoconf automake python2 gtk-doc"
|
||||
source="https://github.com/telepathyim/$pkgname/archive/$pkgname-$pkgver.tar.gz"
|
||||
subpackages="$pkgname-dev $pkgname-doc"
|
||||
options="!check"
|
||||
builddir="$srcdir/$pkgname-$pkgname-$pkgver" # why would somebody use this naming scheme?!
|
||||
|
||||
prepare() {
|
||||
cd "$builddir"
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
}
|
||||
|
||||
build() {
|
||||
./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/telepathy \
|
||||
--disable-static --enable-gtk-doc
|
||||
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$builddir"
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
sha512sums="85554e4443cff96b0c202a3c8ff88dbe45c562bfc2b49c5504efefc2dd0aa7fa3603d06faeaa3c45813f8c555ed5e388a7d4fe24949ae7ee96a5d68b1ff97495 telepathy-farstream-0.6.2.tar.gz"
|
26
main/telepathy-glib/APKBUILD
Normal file
26
main/telepathy-glib/APKBUILD
Normal file
|
@ -0,0 +1,26 @@
|
|||
pkgname=telepathy-glib
|
||||
pkgver=0.24.1
|
||||
pkgrel=0
|
||||
pkgdesc="GLib bindings for the Telepathy D-Bus protocol"
|
||||
arch="all"
|
||||
url="http://telepathy.freedesktop.org"
|
||||
license="LGPL2.1"
|
||||
depends="dbus-glib"
|
||||
depends_dev="dbus-glib-dev gobject-introspection-dev"
|
||||
makedepends="$depends_dev python2 diffutils libxslt"
|
||||
source="https://telepathy.freedesktop.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
|
||||
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
|
||||
options="!check"
|
||||
|
||||
build() {
|
||||
PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
|
||||
--libexecdir=/usr/lib/telepathy \
|
||||
--enable-static=no
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$builddir"
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
sha512sums="2fed94f76a19d6069f671cdd45d2fd8a4b4ad27c4601aff66041ca205456be397c76a86f92cc9bf20fa4eb6d4c15a67ed8196644c143c37e945f382229a63335 telepathy-glib-0.24.1.tar.gz"
|
36
main/telepathy-qt5/APKBUILD
Normal file
36
main/telepathy-qt5/APKBUILD
Normal file
|
@ -0,0 +1,36 @@
|
|||
pkgname=telepathy-qt5
|
||||
pkgbase=${pkgname/qt5/qt}
|
||||
pkgver=0.9.7
|
||||
pkgrel=0
|
||||
arch="all"
|
||||
url="http://telepathy.freedesktop.org/wiki/"
|
||||
license="LGPL"
|
||||
pkgdesc="A library for Qt-based Telepathy clients"
|
||||
depends="qt5-qtbase"
|
||||
depends_dev="telepathy-farstream-dev telepathy-glib-dev gstreamer-dev"
|
||||
makedepends="$depends_dev cmake python2 qt5-qttools-dev dbus"
|
||||
source="https://telepathy.freedesktop.org/releases/$pkgbase/$pkgbase-$pkgver.tar.gz"
|
||||
subpackages="$pkgname-dev"
|
||||
options="!check" # Fails due to requiring a running dbus daemon
|
||||
builddir="$srcdir/$pkgbase-$pkgver"
|
||||
|
||||
build() {
|
||||
cmake \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
|
||||
-DDESIRED_QT_VERSION=5 \
|
||||
-DENABLE_EXAMPLES=OFF
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd "$builddir"
|
||||
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$builddir"
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
sha512sums="081daecb2509ea690079014bcc88eacbf2b3e4f4ac42aaf1b0cb264c01b801bc499a041482571d383f258cb3d3e2c6ffa5682fbe417fe807fcc25a06d2ead877 telepathy-qt-0.9.7.tar.gz"
|
Loading…
Reference in a new issue