linux-samsung-espresso3g: upgrade to 5.15.2 (MR 2651)
This commit is contained in:
parent
b78fcd1794
commit
1c1dbf2363
3 changed files with 141 additions and 114 deletions
|
@ -1,5 +1,5 @@
|
|||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 7e0934180..cdf76c6cd 100644
|
||||
index 7e0934180724..cdf76c6cd05c 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -880,6 +880,7 @@ dtb-$(CONFIG_ARCH_OMAP4) += \
|
||||
|
@ -12,14 +12,15 @@ index 7e0934180..cdf76c6cd 100644
|
|||
omap4-var-dvk-om44.dtb \
|
||||
diff --git a/arch/arm/boot/dts/omap4-samsung-espresso3g.dts b/arch/arm/boot/dts/omap4-samsung-espresso3g.dts
|
||||
new file mode 100644
|
||||
index 000000000..0800e182e
|
||||
index 000000000000..6a75c72d8f72
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/omap4-samsung-espresso3g.dts
|
||||
@@ -0,0 +1,550 @@
|
||||
@@ -0,0 +1,584 @@
|
||||
+// SPDX-License-Identifier: (GPL-2.0 OR MIT)
|
||||
+/dts-v1/;
|
||||
+#include "dt-bindings/gpio/gpio.h"
|
||||
+#include <dt-bindings/interrupt-controller/irq.h>
|
||||
+#include <dt-bindings/input/input.h>
|
||||
+#include "omap443x.dtsi"
|
||||
+
|
||||
+/ {
|
||||
|
@ -56,6 +57,15 @@ index 000000000..0800e182e
|
|||
+ ranges;
|
||||
+ };
|
||||
+
|
||||
+ i2c-gpio-5 {
|
||||
+ compatible = "i2c-gpio";
|
||||
+ sda-gpios = <&gpio4 2 (GPIO_ACTIVE_HIGH | GPIO_OPEN_DRAIN)>;
|
||||
+ scl-gpios = <&gpio4 3 (GPIO_ACTIVE_HIGH | GPIO_OPEN_DRAIN)>;
|
||||
+ i2c-gpio,delay-us = <10>;
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <0>;
|
||||
+ };
|
||||
+
|
||||
+ i2c-gpio-7 {
|
||||
+ compatible = "i2c-gpio";
|
||||
+ sda-gpios = <&gpio2 30 (GPIO_ACTIVE_HIGH | GPIO_OPEN_DRAIN)>;
|
||||
|
@ -125,17 +135,25 @@ index 000000000..0800e182e
|
|||
+
|
||||
+ gpio-keys {
|
||||
+ compatible = "gpio-keys";
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&gpio_keys>;
|
||||
+ //pinctrl-names = "default";
|
||||
+ //pinctrl-0 = <&gpio_keys>;
|
||||
+
|
||||
+ power {
|
||||
+ label = "power";
|
||||
+ gpios = <&gpio1 3 GPIO_ACTIVE_HIGH>;
|
||||
+ linux,code = <KEY_POWER>;
|
||||
+ wakeup-source;
|
||||
+ };
|
||||
+
|
||||
+ button-volup {
|
||||
+ linux,code = <115>;
|
||||
+ label = "VOL+"; /* GPIO30 */
|
||||
+ linux,code = <KEY_VOLUMEUP>;
|
||||
+ label = "volume_up"; /* GPIO30 */
|
||||
+ gpios = <&gpio1 30 GPIO_ACTIVE_LOW>;
|
||||
+ };
|
||||
+
|
||||
+ button-voldown {
|
||||
+ linux,code = <114>;
|
||||
+ label = "VOL-"; /* GPIO8 */
|
||||
+ linux,code = <KEY_VOLUMEDOWN>;
|
||||
+ label = "volume_down"; /* GPIO8 */
|
||||
+ gpios = <&gpio1 8 GPIO_ACTIVE_LOW>;
|
||||
+ };
|
||||
+ };
|
||||
|
@ -144,12 +162,14 @@ index 000000000..0800e182e
|
|||
+ compatible = "regulator-fixed";
|
||||
+ regulator-name = "lcd_en";
|
||||
+ gpios = <&gpio5 7 GPIO_ACTIVE_HIGH>;
|
||||
+ regulator-max-microvolt = <3300000>;
|
||||
+ regulator-min-microvolt = <3300000>;
|
||||
+ enable-active-high;
|
||||
+ //regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ pwm10: dmtimer-pwm-10 {
|
||||
+ pwm10: dmtimer-pwm@10 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pwm10_default>;
|
||||
+
|
||||
|
@ -165,7 +185,7 @@ index 000000000..0800e182e
|
|||
+ pinctrl-0 = <&backlight_pins>;
|
||||
+ pwms = <&pwm10 0 500000 0>;
|
||||
+ power-supply = <®_lcd>;
|
||||
+ enable-gpios = <&gpio3 31 0>;
|
||||
+ enable-gpios = <&gpio3 31 GPIO_ACTIVE_HIGH>;
|
||||
+ brightness-levels = <0 4 8 16 32 64 128 255>;
|
||||
+ default-brightness-level = <7>;
|
||||
+ };
|
||||
|
@ -227,6 +247,13 @@ index 000000000..0800e182e
|
|||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ vibrator {
|
||||
+ compatible = "gpio-vibrator";
|
||||
+ enable-gpios = <&gpio2 6 GPIO_ACTIVE_HIGH>;
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&vibrator_default>;
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&omap4_pmx_wkup {
|
||||
|
@ -240,56 +267,56 @@ index 000000000..0800e182e
|
|||
+&omap4_pmx_core {
|
||||
+ pwm10_default: pinmux_pwm10_default {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0X0D6, PIN_OUTPUT | PIN_OFF_OUTPUT_LOW | MUX_MODE1)
|
||||
+ OMAP4_IOPAD(0X0D6, PIN_OUTPUT | PIN_OFF_OUTPUT_LOW | MUX_MODE1)
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ backlight_pins: pinmux_backlight_pins {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0X0D8, PIN_OUTPUT | PIN_OFF_OUTPUT_LOW | MUX_MODE3)
|
||||
+ OMAP4_IOPAD(0X0D8, PIN_OUTPUT | PIN_OFF_OUTPUT_LOW | MUX_MODE3)
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ i2c1_pins: pinmux_i2c1_pins {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0x122, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c1_scl */
|
||||
+ OMAP4_IOPAD(0x124, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c1_sda */
|
||||
+ OMAP4_IOPAD(0x122, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c1_scl */
|
||||
+ OMAP4_IOPAD(0x124, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c1_sda */
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ i2c2_pins: pinmux_i2c2_pins {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0x126, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c2_scl */
|
||||
+ OMAP4_IOPAD(0x128, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c2_sda */
|
||||
+ OMAP4_IOPAD(0x126, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c2_scl */
|
||||
+ OMAP4_IOPAD(0x128, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c2_sda */
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ i2c3_pins: pinmux_i2c3_pins {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0x12a, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c3_scl */
|
||||
+ OMAP4_IOPAD(0x12c, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c3_sda */
|
||||
+ OMAP4_IOPAD(0x12a, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c3_scl */
|
||||
+ OMAP4_IOPAD(0x12c, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c3_sda */
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ i2c4_pins: pinmux_i2c4_pins {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0x12e, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c4_scl */
|
||||
+ OMAP4_IOPAD(0x130, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c4_sda */
|
||||
+ OMAP4_IOPAD(0x12e, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c4_scl */
|
||||
+ OMAP4_IOPAD(0x130, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c4_sda */
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ mmc2_pins: pinmux_mmc2_pins {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0x040, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat0 */
|
||||
+ OMAP4_IOPAD(0x042, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat1 */
|
||||
+ OMAP4_IOPAD(0x044, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat2 */
|
||||
+ OMAP4_IOPAD(0x046, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat3 */
|
||||
+ OMAP4_IOPAD(0x048, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat4 */
|
||||
+ OMAP4_IOPAD(0x04a, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat5 */
|
||||
+ OMAP4_IOPAD(0x04c, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat6 */
|
||||
+ OMAP4_IOPAD(0x04e, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat7 */
|
||||
+ OMAP4_IOPAD(0x082, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_clk */
|
||||
+ OMAP4_IOPAD(0x084, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_cmd */
|
||||
+ OMAP4_IOPAD(0x040, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat0 */
|
||||
+ OMAP4_IOPAD(0x042, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat1 */
|
||||
+ OMAP4_IOPAD(0x044, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat2 */
|
||||
+ OMAP4_IOPAD(0x046, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat3 */
|
||||
+ OMAP4_IOPAD(0x048, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat4 */
|
||||
+ OMAP4_IOPAD(0x04a, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat5 */
|
||||
+ OMAP4_IOPAD(0x04c, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat6 */
|
||||
+ OMAP4_IOPAD(0x04e, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_dat7 */
|
||||
+ OMAP4_IOPAD(0x082, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_clk */
|
||||
+ OMAP4_IOPAD(0x084, PIN_INPUT_PULLUP | MUX_MODE1) /* sdmmc2_cmd */
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
|
@ -306,47 +333,47 @@ index 000000000..0800e182e
|
|||
+
|
||||
+ mmc5_pins: pinmux_mmc5_pins {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0x148, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_clk.sdmmc5_clk */
|
||||
+ OMAP4_IOPAD(0x14a, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_cmd.sdmmc5_cmd */
|
||||
+ OMAP4_IOPAD(0x14c, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_dat0.sdmmc5_dat0 */
|
||||
+ OMAP4_IOPAD(0x14e, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_dat1.sdmmc5_dat1 */
|
||||
+ OMAP4_IOPAD(0x150, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_dat2.sdmmc5_dat2 */
|
||||
+ OMAP4_IOPAD(0x152, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_dat3.sdmmc5_dat3 */
|
||||
+ OMAP4_IOPAD(0x148, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_clk.sdmmc5_clk */
|
||||
+ OMAP4_IOPAD(0x14a, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_cmd.sdmmc5_cmd */
|
||||
+ OMAP4_IOPAD(0x14c, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_dat0.sdmmc5_dat0 */
|
||||
+ OMAP4_IOPAD(0x14e, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_dat1.sdmmc5_dat1 */
|
||||
+ OMAP4_IOPAD(0x150, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_dat2.sdmmc5_dat2 */
|
||||
+ OMAP4_IOPAD(0x152, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_dat3.sdmmc5_dat3 */
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ dss_dpi_pins: pinmux_dss_dpi_pins {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0x162, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data23 */
|
||||
+ OMAP4_IOPAD(0x164, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data22 */
|
||||
+ OMAP4_IOPAD(0x166, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data21 */
|
||||
+ OMAP4_IOPAD(0x168, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data20 */
|
||||
+ OMAP4_IOPAD(0x16a, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data19 */
|
||||
+ OMAP4_IOPAD(0x16c, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data18 */
|
||||
+ OMAP4_IOPAD(0x16e, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data15 */
|
||||
+ OMAP4_IOPAD(0x170, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data14 */
|
||||
+ OMAP4_IOPAD(0x172, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data13 */
|
||||
+ OMAP4_IOPAD(0x174, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data12 */
|
||||
+ OMAP4_IOPAD(0x176, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data11 */
|
||||
+ OMAP4_IOPAD(0x162, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data23 */
|
||||
+ OMAP4_IOPAD(0x164, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data22 */
|
||||
+ OMAP4_IOPAD(0x166, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data21 */
|
||||
+ OMAP4_IOPAD(0x168, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data20 */
|
||||
+ OMAP4_IOPAD(0x16a, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data19 */
|
||||
+ OMAP4_IOPAD(0x16c, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data18 */
|
||||
+ OMAP4_IOPAD(0x16e, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data15 */
|
||||
+ OMAP4_IOPAD(0x170, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data14 */
|
||||
+ OMAP4_IOPAD(0x172, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data13 */
|
||||
+ OMAP4_IOPAD(0x174, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data12 */
|
||||
+ OMAP4_IOPAD(0x176, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data11 */
|
||||
+
|
||||
+ OMAP4_IOPAD(0x1b4, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data10 */
|
||||
+ OMAP4_IOPAD(0x1b6, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data9 */
|
||||
+ OMAP4_IOPAD(0x1b8, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data16 */
|
||||
+ OMAP4_IOPAD(0x1ba, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data17 */
|
||||
+ OMAP4_IOPAD(0x1bc, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_hsync */
|
||||
+ OMAP4_IOPAD(0x1be, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_pclk */
|
||||
+ OMAP4_IOPAD(0x1c0, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_vsync */
|
||||
+ OMAP4_IOPAD(0x1c2, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_de */
|
||||
+ OMAP4_IOPAD(0x1c4, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data8 */
|
||||
+ OMAP4_IOPAD(0x1c6, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data7 */
|
||||
+ OMAP4_IOPAD(0x1c8, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data6 */
|
||||
+ OMAP4_IOPAD(0x1ca, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data5 */
|
||||
+ OMAP4_IOPAD(0x1cc, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data4 */
|
||||
+ OMAP4_IOPAD(0x1ce, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data3 */
|
||||
+ OMAP4_IOPAD(0x1b4, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data10 */
|
||||
+ OMAP4_IOPAD(0x1b6, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data9 */
|
||||
+ OMAP4_IOPAD(0x1b8, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data16 */
|
||||
+ OMAP4_IOPAD(0x1ba, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data17 */
|
||||
+ OMAP4_IOPAD(0x1bc, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_hsync */
|
||||
+ OMAP4_IOPAD(0x1be, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_pclk */
|
||||
+ OMAP4_IOPAD(0x1c0, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_vsync */
|
||||
+ OMAP4_IOPAD(0x1c2, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_de */
|
||||
+ OMAP4_IOPAD(0x1c4, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data8 */
|
||||
+ OMAP4_IOPAD(0x1c6, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data7 */
|
||||
+ OMAP4_IOPAD(0x1c8, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data6 */
|
||||
+ OMAP4_IOPAD(0x1ca, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data5 */
|
||||
+ OMAP4_IOPAD(0x1cc, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data4 */
|
||||
+ OMAP4_IOPAD(0x1ce, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data3 */
|
||||
+
|
||||
+ OMAP4_IOPAD(0x1d0, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data2 */
|
||||
+ OMAP4_IOPAD(0x1d2, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data1 */
|
||||
+ OMAP4_IOPAD(0x1d4, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data0 */
|
||||
+ OMAP4_IOPAD(0x1d0, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data2 */
|
||||
+ OMAP4_IOPAD(0x1d2, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data1 */
|
||||
+ OMAP4_IOPAD(0x1d4, PIN_OFF_OUTPUT_LOW | MUX_MODE5) /* dispc2_data0 */
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
|
@ -368,12 +395,13 @@ index 000000000..0800e182e
|
|||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ gpio_keys: pinmux_gpio_keys {
|
||||
+ /*gpio_keys: pinmux_gpio_keys {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0x046, WAKEUP_EN | PIN_INPUT | MUX_MODE3)
|
||||
+ OMAP4_IOPAD(0x056, WAKEUP_EN | PIN_INPUT | MUX_MODE3)
|
||||
+ OMAP4_IOPAD(0x05C, WAKEUP_EN | PIN_INPUT | MUX_MODE3)
|
||||
+ >;
|
||||
+ };
|
||||
+ };*/
|
||||
+
|
||||
+ uart2_pins: pinmux_uart2_pins {
|
||||
+ pinctrl-single,pins = <
|
||||
|
@ -398,6 +426,12 @@ index 000000000..0800e182e
|
|||
+ OMAP4_IOPAD(0x06c, PIN_INPUT | MUX_MODE3)
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ vibrator_default: pinmux_vibrator_default {
|
||||
+ pinctrl-single,pins = <
|
||||
+ OMAP4_IOPAD(0x05c, PIN_INPUT_PULLDOWN | MUX_MODE3)
|
||||
+ >;
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&i2c1 {
|
||||
|
@ -568,7 +602,7 @@ index 000000000..0800e182e
|
|||
+};
|
||||
diff --git a/arch/arm/boot/dts/twl6032.dtsi b/arch/arm/boot/dts/twl6032.dtsi
|
||||
new file mode 100644
|
||||
index 000000000..f7b371179
|
||||
index 000000000000..f7b371179e44
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/twl6032.dtsi
|
||||
@@ -0,0 +1,88 @@
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# Maintainer: Mighty <mightymb17@gmail.com>
|
||||
# Co-Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
|
||||
pkgname=linux-samsung-espresso3g
|
||||
pkgver=5.15_rc1
|
||||
pkgver=5.15.2
|
||||
pkgrel=0
|
||||
pkgdesc="Samsung Galaxy Tab 2 (7.0 inch) mainline kernel"
|
||||
arch="armv7"
|
||||
|
@ -16,10 +16,10 @@ options="!strip !check !tracedeps
|
|||
pmb:kconfigcheck-nftables
|
||||
pmb:kconfigcheck-zram"
|
||||
makedepends="openssl-dev yaml-dev mpc1-dev mpfr-dev xz findutils bison flex perl sed bash gmp-dev bc linux-headers elfutils-dev"
|
||||
_commit="7f948007463451675a274ec0abaefdd9253ae56b"
|
||||
_commit="6ba3430a6fad45bf35f2634809e4f3a12f85cb89"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/openpvrsgx-devgroup/linux_openpvrsgx/archive/$_commit.tar.gz
|
||||
$pkgname-$_commit.tar.gz::https://github.com/tmlind/linux_openpvrsgx/archive/$_commit.tar.gz
|
||||
00-add-espresso-dts.patch
|
||||
$_config
|
||||
"
|
||||
|
@ -50,7 +50,7 @@ package() {
|
|||
}
|
||||
|
||||
sha512sums="
|
||||
6af57b5b1c91b611eae2a495a014701a53db3f2f99e6f043d7640d788250555e2f5dcbf7ec3deb4ce3124dea809132dd81939be5faa73be2dda48483f341e44b linux-samsung-espresso3g-7f948007463451675a274ec0abaefdd9253ae56b.tar.gz
|
||||
34fabb12df19f26ddac5dcd8e2d943314f9ed6658823c172b822cca1d1dc131ab46345dab908c70c2889f0518736d82bc43de51fc64c37c71c64082b0a5ae734 00-add-espresso-dts.patch
|
||||
e633f289ee4900a87f3a95fdeada83ae070911e46b5220377bbb0de56f118bfb3c923187f42b33d0069539a75d0e7ed621ed8e4ccf9552bf9785ed8f79cfc8d7 config-samsung-espresso3g.armv7
|
||||
c1f1372afc303cabb55210c7c46a694eff3bc0d7871efee7a690488b782b0c2cb48dbccc43b454a7cf96cfea796397f621d338e791172a8d1f62b26b2e1d54cb linux-samsung-espresso3g-6ba3430a6fad45bf35f2634809e4f3a12f85cb89.tar.gz
|
||||
c914516703fdb42f3b33ee3f449222a81c06b3c9a3dd4f9a24ad55a9b32cf0828bf557897157296a9e5edbe92a898cdd42d147b196162750010e1d087f80ab39 00-add-espresso-dts.patch
|
||||
4afcca55621a626cfc37fc571af916e794b201417897ba19d5d9394e7b843b14f6095033a4a4b4f9c2e15bce27e687930d5dfed27253e64bf2a4c78ebbe637c8 config-samsung-espresso3g.armv7
|
||||
"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 5.15.0-rc1 Kernel Configuration
|
||||
# Linux/arm 5.15.2 Kernel Configuration
|
||||
#
|
||||
CONFIG_CC_VERSION_TEXT="armv7-alpine-linux-musleabihf-gcc (Alpine 10.3.1_git20210921) 10.3.1 20210921"
|
||||
CONFIG_CC_VERSION_TEXT="armv7-alpine-linux-musleabihf-gcc (Alpine 10.3.1_git20211027) 10.3.1 20211027"
|
||||
CONFIG_CC_IS_GCC=y
|
||||
CONFIG_GCC_VERSION=100301
|
||||
CONFIG_CLANG_VERSION=0
|
||||
|
@ -208,6 +208,7 @@ CONFIG_ELF_CORE=y
|
|||
CONFIG_BASE_FULL=y
|
||||
CONFIG_FUTEX=y
|
||||
CONFIG_FUTEX_PI=y
|
||||
CONFIG_HAVE_FUTEX_CMPXCHG=y
|
||||
CONFIG_EPOLL=y
|
||||
CONFIG_SIGNALFD=y
|
||||
CONFIG_TIMERFD=y
|
||||
|
@ -625,29 +626,6 @@ CONFIG_ARM_CPU_SUSPEND=y
|
|||
CONFIG_ARCH_HIBERNATION_POSSIBLE=y
|
||||
# end of Power management options
|
||||
|
||||
#
|
||||
# Firmware Drivers
|
||||
#
|
||||
|
||||
#
|
||||
# ARM System Control and Management Interface Protocol
|
||||
#
|
||||
# CONFIG_ARM_SCMI_PROTOCOL is not set
|
||||
# end of ARM System Control and Management Interface Protocol
|
||||
|
||||
# CONFIG_ARM_SCPI_PROTOCOL is not set
|
||||
# CONFIG_FW_CFG_SYSFS is not set
|
||||
# CONFIG_QCOM_SCM is not set
|
||||
# CONFIG_TRUSTED_FOUNDATIONS is not set
|
||||
# CONFIG_GOOGLE_FIRMWARE is not set
|
||||
CONFIG_HAVE_ARM_SMCCC=y
|
||||
|
||||
#
|
||||
# Tegra firmware driver
|
||||
#
|
||||
# end of Tegra firmware driver
|
||||
# end of Firmware Drivers
|
||||
|
||||
CONFIG_ARM_CRYPTO=y
|
||||
CONFIG_CRYPTO_SHA1_ARM=m
|
||||
CONFIG_CRYPTO_SHA1_ARM_NEON=m
|
||||
|
@ -1649,7 +1627,6 @@ CONFIG_GENERIC_ARCH_TOPOLOGY=y
|
|||
# CONFIG_MOXTET is not set
|
||||
CONFIG_OMAP_INTERCONNECT=y
|
||||
CONFIG_OMAP_OCP2SCP=y
|
||||
CONFIG_SIMPLE_PM_BUS=y
|
||||
CONFIG_TI_PWMSS=y
|
||||
CONFIG_TI_SYSC=y
|
||||
# CONFIG_VEXPRESS_CONFIG is not set
|
||||
|
@ -1657,6 +1634,29 @@ CONFIG_TI_SYSC=y
|
|||
# end of Bus devices
|
||||
|
||||
CONFIG_CONNECTOR=m
|
||||
|
||||
#
|
||||
# Firmware Drivers
|
||||
#
|
||||
|
||||
#
|
||||
# ARM System Control and Management Interface Protocol
|
||||
#
|
||||
# CONFIG_ARM_SCMI_PROTOCOL is not set
|
||||
# end of ARM System Control and Management Interface Protocol
|
||||
|
||||
# CONFIG_ARM_SCPI_PROTOCOL is not set
|
||||
# CONFIG_FW_CFG_SYSFS is not set
|
||||
# CONFIG_TRUSTED_FOUNDATIONS is not set
|
||||
# CONFIG_GOOGLE_FIRMWARE is not set
|
||||
CONFIG_HAVE_ARM_SMCCC=y
|
||||
|
||||
#
|
||||
# Tegra firmware driver
|
||||
#
|
||||
# end of Tegra firmware driver
|
||||
# end of Firmware Drivers
|
||||
|
||||
# CONFIG_GNSS is not set
|
||||
CONFIG_MTD=y
|
||||
# CONFIG_MTD_TESTS is not set
|
||||
|
@ -2573,7 +2573,7 @@ CONFIG_WLAN_VENDOR_QUANTENNA=y
|
|||
#
|
||||
CONFIG_INPUT=y
|
||||
CONFIG_INPUT_LEDS=m
|
||||
CONFIG_INPUT_FF_MEMLESS=m
|
||||
CONFIG_INPUT_FF_MEMLESS=y
|
||||
# CONFIG_INPUT_SPARSEKMAP is not set
|
||||
CONFIG_INPUT_MATRIXKMAP=m
|
||||
|
||||
|
@ -2705,7 +2705,7 @@ CONFIG_INPUT_MISC=y
|
|||
# CONFIG_INPUT_MMA8450 is not set
|
||||
# CONFIG_INPUT_GPIO_BEEPER is not set
|
||||
# CONFIG_INPUT_GPIO_DECODER is not set
|
||||
# CONFIG_INPUT_GPIO_VIBRA is not set
|
||||
CONFIG_INPUT_GPIO_VIBRA=y
|
||||
CONFIG_INPUT_CPCAP_PWRBUTTON=m
|
||||
# CONFIG_INPUT_ATI_REMOTE2 is not set
|
||||
# CONFIG_INPUT_KEYSPAN_REMOTE is not set
|
||||
|
@ -4411,15 +4411,6 @@ CONFIG_DRM_TI_TPD12S015=m
|
|||
# CONFIG_DRM_MCDE is not set
|
||||
# CONFIG_DRM_TIDSS is not set
|
||||
CONFIG_SGX=y
|
||||
# CONFIG_PVRSGX_1_7_862890 is not set
|
||||
# CONFIG_PVRSGX_1_9_2188537 is not set
|
||||
# CONFIG_PVRSGX_1_9_2253347 is not set
|
||||
# CONFIG_PVRSGX_1_10_2359475 is not set
|
||||
# CONFIG_PVRSGX_1_13_3341330 is not set
|
||||
# CONFIG_PVRSGX_1_14_3699939 is not set
|
||||
# CONFIG_PVRSGX_1_14_3759903 is not set
|
||||
# CONFIG_PVRSGX_1_14_3841212 is not set
|
||||
# CONFIG_PVRSGX_1_15_4564147 is not set
|
||||
CONFIG_PVRSGX_1_17_4948957=y
|
||||
# CONFIG_SGX_DEBUG is not set
|
||||
CONFIG_SGX_DRM=y
|
||||
|
@ -5319,8 +5310,11 @@ CONFIG_USB_ZERO=m
|
|||
# CONFIG_USB_AUDIO is not set
|
||||
# CONFIG_USB_ETH is not set
|
||||
# CONFIG_USB_G_NCM is not set
|
||||
# CONFIG_USB_GADGETFS is not set
|
||||
# CONFIG_USB_FUNCTIONFS is not set
|
||||
CONFIG_USB_GADGETFS=y
|
||||
CONFIG_USB_FUNCTIONFS=y
|
||||
# CONFIG_USB_FUNCTIONFS_ETH is not set
|
||||
# CONFIG_USB_FUNCTIONFS_RNDIS is not set
|
||||
CONFIG_USB_FUNCTIONFS_GENERIC=y
|
||||
# CONFIG_USB_MASS_STORAGE is not set
|
||||
# CONFIG_USB_G_SERIAL is not set
|
||||
# CONFIG_USB_MIDI_GADGET is not set
|
||||
|
@ -6464,7 +6458,6 @@ CONFIG_ANDROID_BINDER_DEVICES="binder,hwbinder,vndbinder"
|
|||
# CONFIG_DAX is not set
|
||||
CONFIG_NVMEM=y
|
||||
CONFIG_NVMEM_SYSFS=y
|
||||
# CONFIG_NVMEM_NINTENDO_OTP is not set
|
||||
# CONFIG_NVMEM_RMEM is not set
|
||||
|
||||
#
|
||||
|
|
Loading…
Reference in a new issue