samsung-arubaslim: new device (MR 3186)
[ci:skip-build] already built successfully in CI
This commit is contained in:
parent
87d6a4cff4
commit
18f7fcc000
11 changed files with 3813 additions and 0 deletions
30
device/testing/device-samsung-arubaslim/APKBUILD
Normal file
30
device/testing/device-samsung-arubaslim/APKBUILD
Normal file
|
@ -0,0 +1,30 @@
|
||||||
|
# Reference: <https://postmarketos.org/devicepkg>
|
||||||
|
pkgname=device-samsung-arubaslim
|
||||||
|
pkgdesc="Samsung Galaxy Core"
|
||||||
|
pkgver=0.1
|
||||||
|
pkgrel=0
|
||||||
|
url="https://postmarketos.org"
|
||||||
|
license="MIT"
|
||||||
|
arch="armv7"
|
||||||
|
options="!check !archcheck"
|
||||||
|
depends="
|
||||||
|
linux-samsung-arubaslim
|
||||||
|
mesa-dri-gallium
|
||||||
|
mkbootimg
|
||||||
|
postmarketos-base
|
||||||
|
msm-fb-refresher
|
||||||
|
"
|
||||||
|
makedepends="devicepkg-dev"
|
||||||
|
source="deviceinfo"
|
||||||
|
|
||||||
|
build() {
|
||||||
|
devicepkg_build $startdir $pkgname
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
devicepkg_package $startdir $pkgname
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="
|
||||||
|
3373c15d8ebfc6467820cc1291b4456c13f2646762bd0b3f57aac1c56620e18a905d406082956f5f628ec6531d7bfb789903e4aa17008b7c40c8198826215af3 deviceinfo
|
||||||
|
"
|
33
device/testing/device-samsung-arubaslim/deviceinfo
Normal file
33
device/testing/device-samsung-arubaslim/deviceinfo
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
# Reference: <https://postmarketos.org/deviceinfo>
|
||||||
|
# Please use double quotes only. You can source this file in shell
|
||||||
|
# scripts.
|
||||||
|
|
||||||
|
deviceinfo_format_version="0"
|
||||||
|
deviceinfo_name="Samsung Galaxy Core"
|
||||||
|
deviceinfo_manufacturer="Samsung"
|
||||||
|
deviceinfo_codename="samsung-arubaslim"
|
||||||
|
deviceinfo_year="2013"
|
||||||
|
deviceinfo_arch="armv7"
|
||||||
|
|
||||||
|
# Device related
|
||||||
|
deviceinfo_chassis="handset"
|
||||||
|
deviceinfo_keyboard="false"
|
||||||
|
deviceinfo_external_storage="true"
|
||||||
|
deviceinfo_screen_width="800"
|
||||||
|
deviceinfo_screen_height="600"
|
||||||
|
|
||||||
|
# Bootloader related
|
||||||
|
deviceinfo_flash_method="heimdall-bootimg"
|
||||||
|
deviceinfo_kernel_cmdline="androidboot.hardware=qcom"
|
||||||
|
deviceinfo_generate_bootimg="true"
|
||||||
|
deviceinfo_bootimg_qcdt="false"
|
||||||
|
deviceinfo_bootimg_mtk_mkimage="false"
|
||||||
|
deviceinfo_bootimg_dtb_second="false"
|
||||||
|
deviceinfo_flash_pagesize="2048"
|
||||||
|
deviceinfo_flash_offset_base="0x00200000"
|
||||||
|
deviceinfo_flash_offset_kernel="0x00008000"
|
||||||
|
deviceinfo_flash_offset_ramdisk="0x01300000"
|
||||||
|
deviceinfo_flash_offset_second="0x00f00000"
|
||||||
|
deviceinfo_flash_offset_tags="0x00000100"
|
||||||
|
deviceinfo_flash_heimdall_partition_kernel="APPS"
|
||||||
|
deviceinfo_flash_heimdall_partition_system="SYSTEM"
|
|
@ -0,0 +1,49 @@
|
||||||
|
From aeea3592a13bf12861943e44fc48f1f270941f8d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Behan Webster <behanw@converseincode.com>
|
||||||
|
Date: Wed, 24 Sep 2014 01:06:46 +0100
|
||||||
|
Subject: [PATCH] ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h
|
||||||
|
|
||||||
|
With compilers which follow the C99 standard (like modern versions of gcc and
|
||||||
|
clang), "extern inline" does the wrong thing (emits code for an externally
|
||||||
|
linkable version of the inline function). In this case using static inline
|
||||||
|
and removing the NULL version of return_address in return_address.c does
|
||||||
|
the right thing.
|
||||||
|
|
||||||
|
Signed-off-by: Behan Webster <behanw@converseincode.com>
|
||||||
|
Reviewed-by: Mark Charlebois <charlebm@gmail.com>
|
||||||
|
Acked-by: Steven Rostedt <rostedt@goodmis.org>
|
||||||
|
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
||||||
|
---
|
||||||
|
arch/arm/include/asm/ftrace.h | 2 +-
|
||||||
|
arch/arm/kernel/return_address.c | 5 -----
|
||||||
|
2 files changed, 1 insertion(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h
|
||||||
|
index 39eb16b0066f2..bfe2a2f5a644e 100644
|
||||||
|
--- a/arch/arm/include/asm/ftrace.h
|
||||||
|
+++ b/arch/arm/include/asm/ftrace.h
|
||||||
|
@@ -45,7 +45,7 @@ void *return_address(unsigned int);
|
||||||
|
|
||||||
|
#else
|
||||||
|
|
||||||
|
-extern inline void *return_address(unsigned int level)
|
||||||
|
+static inline void *return_address(unsigned int level)
|
||||||
|
{
|
||||||
|
return NULL;
|
||||||
|
}
|
||||||
|
diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c
|
||||||
|
index fafedd86885dd..f6aa84d5b93c9 100644
|
||||||
|
--- a/arch/arm/kernel/return_address.c
|
||||||
|
+++ b/arch/arm/kernel/return_address.c
|
||||||
|
@@ -63,11 +63,6 @@ void *return_address(unsigned int level)
|
||||||
|
#warning "TODO: return_address should use unwind tables"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-void *return_address(unsigned int level)
|
||||||
|
-{
|
||||||
|
- return NULL;
|
||||||
|
-}
|
||||||
|
-
|
||||||
|
#endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */
|
||||||
|
|
||||||
|
EXPORT_SYMBOL_GPL(return_address);
|
|
@ -0,0 +1,26 @@
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -243,13 +243,8 @@
|
||||||
|
else if [ -x /bin/bash ]; then echo /bin/bash; \
|
||||||
|
else echo sh; fi ; fi)
|
||||||
|
|
||||||
|
-ifdef CONFIG_CCACHE
|
||||||
|
-HOSTCC = ccache gcc
|
||||||
|
-HOSTCXX = ccache g++
|
||||||
|
-else
|
||||||
|
HOSTCC = gcc
|
||||||
|
HOSTCXX = g++
|
||||||
|
-endif
|
||||||
|
HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer
|
||||||
|
HOSTCXXFLAGS = -O2
|
||||||
|
|
||||||
|
@@ -426,7 +421,7 @@
|
||||||
|
-fno-strict-aliasing -fno-common \
|
||||||
|
-Werror-implicit-function-declaration \
|
||||||
|
-Wno-format-security \
|
||||||
|
- -fno-delete-null-pointer-checks -Wno-array-bounds -Wno-maybe-uninitialized
|
||||||
|
+ -fno-delete-null-pointer-checks
|
||||||
|
-KBUILD_AFLAGS_KERNEL := -Wa,-mimplicit-it=thumb
|
||||||
|
+KBUILD_AFLAGS_KERNEL :=
|
||||||
|
KBUILD_CFLAGS_KERNEL :=
|
||||||
|
KBUILD_AFLAGS := -D__ASSEMBLY__
|
78
device/testing/linux-samsung-arubaslim/APKBUILD
Normal file
78
device/testing/linux-samsung-arubaslim/APKBUILD
Normal file
|
@ -0,0 +1,78 @@
|
||||||
|
# Reference: <https://postmarketos.org/vendorkernel>
|
||||||
|
# Kernel config based on: arch/arm/configs/arubaslim_defconfig
|
||||||
|
pkgname=linux-samsung-arubaslim
|
||||||
|
pkgver=3.5.1
|
||||||
|
pkgrel=0
|
||||||
|
pkgdesc="Samsung Galaxy Core kernel fork"
|
||||||
|
arch="armv7"
|
||||||
|
_carch="arm"
|
||||||
|
_flavor="samsung-arubaslim"
|
||||||
|
url="https://kernel.org"
|
||||||
|
license="GPL-2.0-only"
|
||||||
|
options="!strip !check !tracedeps pmb:cross-native"
|
||||||
|
makedepends="
|
||||||
|
bash
|
||||||
|
bc
|
||||||
|
bison
|
||||||
|
devicepkg-dev
|
||||||
|
flex
|
||||||
|
openssl-dev
|
||||||
|
perl
|
||||||
|
gcc6
|
||||||
|
"
|
||||||
|
|
||||||
|
# Source
|
||||||
|
_repository="android_kernel_arubaslim"
|
||||||
|
_commit="aade88cd972ba99b4542a2f8d504cadd3d21c268"
|
||||||
|
_config="config-$_flavor.$arch"
|
||||||
|
source="
|
||||||
|
$pkgname-$_commit.tar.gz::https://github.com/I8552-CM/$_repository/archive/$_commit.tar.gz
|
||||||
|
$_config
|
||||||
|
00_fix_return_address.patch
|
||||||
|
01_prepare_makefile.patch
|
||||||
|
linux3.4-ptrace-fix-ptrace-defect-cause-by-a-merge-fail.patch
|
||||||
|
gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||||
|
gcc8-fix-put-user.patch
|
||||||
|
gcc10-extern_YYLOC_global_declaration.patch
|
||||||
|
kernel-use-the-gnu89-standard-explicitly.patch
|
||||||
|
"
|
||||||
|
builddir="$srcdir/$_repository-$_commit"
|
||||||
|
_outdir="out"
|
||||||
|
|
||||||
|
# Compiler: this kernel was only tested with GCC6. Feel free to make a merge
|
||||||
|
# request if you find out that it is booting working with newer GCCs as
|
||||||
|
# well. See <https://postmarketos.org/vendorkernel> for instructions.
|
||||||
|
if [ "${CC:0:5}" != "gcc6-" ]; then
|
||||||
|
CC="gcc6-$CC"
|
||||||
|
HOSTCC="gcc6-gcc"
|
||||||
|
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
|
||||||
|
fi
|
||||||
|
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
default_prepare
|
||||||
|
. downstreamkernel_prepare
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
unset LDFLAGS
|
||||||
|
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||||
|
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" \
|
||||||
|
"$_flavor" "$_outdir"
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="
|
||||||
|
e6bb390a7f088afba5833b19d7ece0f086629c182b7fdbdd7ebb014040b9229eeaffd88a9c170f5b1904bb9a54878677a420318eb181846dfede77537160859b linux-samsung-arubaslim-aade88cd972ba99b4542a2f8d504cadd3d21c268.tar.gz
|
||||||
|
7956fd9195a0a60f5157cd19f1513637288291bcf84d94e2ff373421eaa2cb3f7e195e89ce3461eb14b174dd5b07d1bf611eaec0b832c38232fb564f6f9d2e47 config-samsung-arubaslim.armv7
|
||||||
|
ea1d3b5a234fa565e3c1a792de48f4fc4e6023d281d303c8e319c7ef28edc5739ab0e4dea0139a41f0a5c7d03e27921ccaa214fd0ac5c72245a094ce60128864 00_fix_return_address.patch
|
||||||
|
7c6bdfa9f926c29306cb9f744d6afdca9063ce7eca7bd19ae3460f578e1cf3530893e679273079946970e7224a637dd76f6d279ce7bf14fbdd3fa506b2d4f159 01_prepare_makefile.patch
|
||||||
|
13f82d1ca9b621f026f12f91bbe03d913be41ebed717e9c657e0f3a4d39c0201ba651a7352c2d27b98bb6641b77ccc1b3ee7d4a7c9e91ddb1e347adcb5c9a780 linux3.4-ptrace-fix-ptrace-defect-cause-by-a-merge-fail.patch
|
||||||
|
77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7 gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||||
|
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||||
|
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||||
|
ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c kernel-use-the-gnu89-standard-explicitly.patch
|
||||||
|
"
|
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
||||||
|
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
|
@ -0,0 +1 @@
|
||||||
|
../../.shared-patches/linux/gcc7-give-up-on-ilog2-const-optimizations.patch
|
1
device/testing/linux-samsung-arubaslim/gcc8-fix-put-user.patch
Symbolic link
1
device/testing/linux-samsung-arubaslim/gcc8-fix-put-user.patch
Symbolic link
|
@ -0,0 +1 @@
|
||||||
|
../../.shared-patches/linux/gcc8-fix-put-user.patch
|
|
@ -0,0 +1 @@
|
||||||
|
../../.shared-patches/linux/kernel-use-the-gnu89-standard-explicitly.patch
|
|
@ -0,0 +1 @@
|
||||||
|
../../.shared-patches/linux/linux3.4-ptrace-fix-ptrace-defect-cause-by-a-merge-fail.patch
|
Loading…
Reference in a new issue