temp/dino: fork from Alpine to build feature/handy mobile UI branch (MR 1754)
This packages the libhandy work in dino's feature/handy branch, which makes the UI quite usable on mobile displays. A couple of windows don't work well yet (e.g., the setting window), but chatting/omemo/file transfer all work pretty well.
This commit is contained in:
parent
6e3ddf62d7
commit
1340cffecf
2 changed files with 67 additions and 0 deletions
54
temp/dino/APKBUILD
Normal file
54
temp/dino/APKBUILD
Normal file
|
@ -0,0 +1,54 @@
|
||||||
|
# Forked from Alpine Linux
|
||||||
|
pkgname=dino
|
||||||
|
pkgver=9999_git20201123
|
||||||
|
pkgrel=0
|
||||||
|
# feature/handy branch
|
||||||
|
_commit="9b522a6f30c43765a667519a56f68b579c54b6af"
|
||||||
|
pkgdesc="Modern Jabber/XMPP client"
|
||||||
|
url="https://dino.im"
|
||||||
|
arch="all"
|
||||||
|
license="GPL-3.0-only"
|
||||||
|
makedepends="
|
||||||
|
glib-dev
|
||||||
|
glib-networking
|
||||||
|
gtk+3.0-dev
|
||||||
|
gpgme-dev
|
||||||
|
libgee-dev
|
||||||
|
libsignal-protocol-c-dev
|
||||||
|
libgcrypt-dev
|
||||||
|
libhandy1-dev
|
||||||
|
libsoup-dev
|
||||||
|
sqlite-dev
|
||||||
|
libqrencode-dev
|
||||||
|
cmake
|
||||||
|
vala
|
||||||
|
ninja
|
||||||
|
"
|
||||||
|
subpackages="$pkgname-lang"
|
||||||
|
source="
|
||||||
|
https://github.com/dino/dino/archive/$_commit.tar.gz
|
||||||
|
bump-signal-version.patch
|
||||||
|
"
|
||||||
|
builddir="$srcdir/$pkgname-$_commit"
|
||||||
|
build() {
|
||||||
|
./configure \
|
||||||
|
--build=$CBUILD \
|
||||||
|
--host=$CHOST \
|
||||||
|
--prefix=/usr \
|
||||||
|
--sysconfdir=/etc \
|
||||||
|
--mandir=/usr/share/man \
|
||||||
|
--localstatedir=/var \
|
||||||
|
--with-tests
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
check() {
|
||||||
|
build/xmpp-vala-test
|
||||||
|
build/signal-protocol-vala-test
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
make DESTDIR="$pkgdir" install
|
||||||
|
}
|
||||||
|
sha512sums="019c9088ccaef18f6befcbc5bfe374ca44a45ce97f43a76cbc42bc53885cd6af7a7ff68d05961342c2683e3a93876a18be8527b4ba6cc7e59711249ff96c79bd 9b522a6f30c43765a667519a56f68b579c54b6af.tar.gz
|
||||||
|
838ccba8d97db8bc43de26afd259e4bdaf3afea786bf40a7ed9ae63f4fb7c2190e8bf6de7b41880602113df87831d01467547f8bfd1f88b50d35287822cb5f4c bump-signal-version.patch"
|
13
temp/dino/bump-signal-version.patch
Normal file
13
temp/dino/bump-signal-version.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
diff --git a/plugins/signal-protocol/CMakeLists.txt b/plugins/signal-protocol/CMakeLists.txt
|
||||||
|
index 400de03..0d776de 100644
|
||||||
|
--- a/plugins/signal-protocol/CMakeLists.txt
|
||||||
|
+++ b/plugins/signal-protocol/CMakeLists.txt
|
||||||
|
@@ -32,7 +32,7 @@ if(NOT BUILD_LIBSIGNAL_IN_TREE)
|
||||||
|
# libsignal-protocol-c has a history of breaking compatibility on the patch level
|
||||||
|
# we'll have to check compatibility for every new release
|
||||||
|
# distro maintainers may update this dependency after compatibility tests
|
||||||
|
- find_package(SignalProtocol 2.3.2 REQUIRED)
|
||||||
|
+ find_package(SignalProtocol 2.3.3 REQUIRED)
|
||||||
|
else()
|
||||||
|
add_subdirectory(libsignal-protocol-c EXCLUDE_FROM_ALL)
|
||||||
|
set_property(TARGET curve25519 PROPERTY POSITION_INDEPENDENT_CODE ON)
|
Loading…
Reference in a new issue