linux-motorola-osprey: use devicepkg-dev (MR 1751)
This commit is contained in:
parent
3bf72cb6ae
commit
1212611108
3 changed files with 34 additions and 169 deletions
|
@ -1,31 +1,16 @@
|
||||||
_flavor=motorola-osprey
|
# Reference: <https://postmarketos.org/vendorkernel>
|
||||||
_hash="ac87541051278c7ea7f494c0b689d08e4a5cdd4f"
|
|
||||||
_config="config-$_flavor.armhf"
|
|
||||||
|
|
||||||
pkgname=linux-$_flavor
|
pkgname=linux-motorola-osprey
|
||||||
pkgver=3.10.49
|
pkgver=3.10.49
|
||||||
case $pkgver in
|
pkgrel=7
|
||||||
*.*.*) _kernver=${pkgver%.*};;
|
pkgdesc="Motorola Moto G 3rd gen. (2015) kernel fork"
|
||||||
*.*) _kernver=$pkgver;;
|
|
||||||
esac
|
|
||||||
pkgrel=6
|
|
||||||
arch="armhf"
|
arch="armhf"
|
||||||
pkgdesc="Moto G (2015) kernel from LineageOS"
|
|
||||||
url="https://github.com/LineageOS/android_kernel_motorola_msm8916"
|
|
||||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev dtbtool gcc6"
|
|
||||||
options="!strip !check !tracedeps pmb:cross-native"
|
|
||||||
source="
|
|
||||||
$pkgname-$_hash.tar.gz::https://github.com/LineageOS/android_kernel_motorola_msm8916/archive/$_hash.tar.gz
|
|
||||||
$_config
|
|
||||||
compiler-gcc6.h
|
|
||||||
Wno-error.patch
|
|
||||||
02_mdss_fb_refresh_rate.patch
|
|
||||||
gcc10-extern_YYLOC_global_declaration.patch
|
|
||||||
"
|
|
||||||
license="GPL2"
|
|
||||||
|
|
||||||
_abi_release=$pkgver
|
|
||||||
_carch="arm"
|
_carch="arm"
|
||||||
|
_flavor="motorola-osprey"
|
||||||
|
url="https://kernel.org"
|
||||||
|
license="GPL-2.0-only"
|
||||||
|
options="!strip !check !tracedeps pmb:cross-native"
|
||||||
|
makedepends="bash bc bison devicepkg-dev flex openssl-dev perl dtbtool linux-headers gcc6"
|
||||||
|
|
||||||
# Compiler: this kernel was only tested with GCC6. Feel free to make a merge
|
# Compiler: this kernel was only tested with GCC6. Feel free to make a merge
|
||||||
# request if you find out that it is booting working with newer GCCs as
|
# request if you find out that it is booting working with newer GCCs as
|
||||||
|
@ -36,83 +21,44 @@ if [ "${CC:0:5}" != "gcc6-" ]; then
|
||||||
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
|
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
ksrcdir="$srcdir/android_kernel_motorola_msm8916-$_hash"
|
# Source
|
||||||
|
_repository="android_kernel_motorola_msm8916"
|
||||||
|
_commit="ac87541051278c7ea7f494c0b689d08e4a5cdd4f"
|
||||||
|
_config="config-$_flavor.$arch"
|
||||||
|
source="
|
||||||
|
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/$_repository/archive/$_commit.tar.gz
|
||||||
|
$_config
|
||||||
|
gcc10-extern_YYLOC_global_declaration.patch
|
||||||
|
02_mdss_fb_refresh_rate.patch
|
||||||
|
"
|
||||||
|
builddir="$srcdir/$_repository-$_commit"
|
||||||
|
_outdir="out"
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
local _patch_failed=
|
default_prepare
|
||||||
cd "$ksrcdir"
|
. downstreamkernel_prepare
|
||||||
|
|
||||||
# first apply patches in specified order
|
|
||||||
for i in $source; do
|
|
||||||
case $i in
|
|
||||||
*.patch)
|
|
||||||
msg "Applying $i..."
|
|
||||||
if ! patch -s -p1 -N -i "$srcdir"/$i; then
|
|
||||||
echo $i >>failed
|
|
||||||
_patch_failed=1
|
|
||||||
fi
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
done
|
|
||||||
|
|
||||||
if ! [ -z "$_patch_failed" ]; then
|
|
||||||
error "The following patches failed:"
|
|
||||||
cat failed
|
|
||||||
return 1
|
|
||||||
fi
|
|
||||||
|
|
||||||
# gcc6 support
|
|
||||||
cp -v "$srcdir/compiler-gcc6.h" "$ksrcdir/include/linux/"
|
|
||||||
|
|
||||||
mkdir -p "$srcdir"/build
|
|
||||||
cp "$srcdir"/$_config "$srcdir"/build/.config
|
|
||||||
make -C "$ksrcdir" O="$srcdir"/build ARCH="$_carch" HOSTCC="$HOSTCC" \
|
|
||||||
silentoldconfig
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir"/build
|
|
||||||
unset LDFLAGS
|
unset LDFLAGS
|
||||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine"
|
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||||
# Generate dt.img
|
|
||||||
dtbTool -s 2048 -p "scripts/dtc/" -o "arch/arm/boot/dt.img" "arch/arm/boot"
|
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
export builddir="$srcdir"/build
|
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||||
# kernel.release
|
|
||||||
install -D "$builddir/include/config/kernel.release" \
|
|
||||||
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
|
||||||
|
|
||||||
# zImage (find the right one)
|
unset LDFLAGS
|
||||||
cd "$builddir/arch/$_carch/boot"
|
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||||
_target="$pkgdir/boot/vmlinuz-$_flavor"
|
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS" \
|
||||||
for _zimg in zImage-dtb Image.gz-dtb *zImage Image; do
|
INSTALL_MOD_PATH="$pkgdir" INSTALL_MOD_STRIP=1 modules_install
|
||||||
[ -e "$_zimg" ] || continue
|
|
||||||
msg "zImage found: $_zimg"
|
|
||||||
install -Dm644 "$_zimg" "$_target"
|
|
||||||
break
|
|
||||||
done
|
|
||||||
if ! [ -e "$_target" ]; then
|
|
||||||
error "Could not find zImage in $PWD!"
|
|
||||||
return 1
|
|
||||||
fi
|
|
||||||
|
|
||||||
# Master DTB (deviceinfo_bootimg_qcdt)
|
# Master DTB (deviceinfo_bootimg_qcdt)
|
||||||
install -Dm644 "$builddir/arch/arm/boot/dt.img" \
|
dtbTool -p scripts/dtc/ -o "$_outdir/arch/$_carch/boot"/dt.img "$_outdir/arch/$_carch/boot/"
|
||||||
"$pkgdir/boot/dt.img"
|
install -Dm644 "$_outdir/arch/$_carch/boot"/dt.img "$pkgdir"/boot/dt.img
|
||||||
|
|
||||||
cd "$srcdir"/build
|
|
||||||
|
|
||||||
make -j1 modules_install \
|
|
||||||
ARCH="$_carch" \
|
|
||||||
INSTALL_MOD_PATH="$pkgdir"
|
|
||||||
}
|
}
|
||||||
|
|
||||||
sha512sums="fbc2e1fa6ff33dd4c20bb063c655fe85ee20c194a9c19a5fadd3434b8ade4b95377848349ce9266d74ca34882446e1e257c0e1a3e35bd23ff05813918dc74750 linux-motorola-osprey-ac87541051278c7ea7f494c0b689d08e4a5cdd4f.tar.gz
|
sha512sums="fbc2e1fa6ff33dd4c20bb063c655fe85ee20c194a9c19a5fadd3434b8ade4b95377848349ce9266d74ca34882446e1e257c0e1a3e35bd23ff05813918dc74750 linux-motorola-osprey-ac87541051278c7ea7f494c0b689d08e4a5cdd4f.tar.gz
|
||||||
d98f97a3dce8c580161f185bf0ebe2a349c94539848a742adfe6d94b30a709c53d1ac59c5fdfb53b72b5f2fbccb0e62c45117951cbcbdae22fdf24690f4d79e1 config-motorola-osprey.armhf
|
d98f97a3dce8c580161f185bf0ebe2a349c94539848a742adfe6d94b30a709c53d1ac59c5fdfb53b72b5f2fbccb0e62c45117951cbcbdae22fdf24690f4d79e1 config-motorola-osprey.armhf
|
||||||
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h
|
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||||
135828e7c9a8cdd4e1f71143e84a80a5d882d2627cacf5e5d808d1172d57cb0ca19520b53429a5f3eee7a17d1489bd77d31ce34e3790062fadb6aa392c09e1af Wno-error.patch
|
a8c955bf718f155011e980f3d0948be98e1fee5649f418299a4851780543019daf7afa406aa7b0829375645107e4e6fbf241026b0cabe2b2ac895a47df83d2d8 02_mdss_fb_refresh_rate.patch"
|
||||||
a8c955bf718f155011e980f3d0948be98e1fee5649f418299a4851780543019daf7afa406aa7b0829375645107e4e6fbf241026b0cabe2b2ac895a47df83d2d8 02_mdss_fb_refresh_rate.patch
|
|
||||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch"
|
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index e666b354d36..2e9ab8e34d7 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -380,7 +380,6 @@ KBUILD_CPPFLAGS := -D__KERNEL__
|
|
||||||
|
|
||||||
KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
|
|
||||||
-fno-strict-aliasing -fno-common \
|
|
||||||
- -Werror-implicit-function-declaration \
|
|
||||||
-Wno-format-security \
|
|
||||||
-fno-delete-null-pointer-checks
|
|
||||||
KBUILD_AFLAGS_KERNEL :=
|
|
|
@ -1,69 +0,0 @@
|
||||||
// SOURCE:
|
|
||||||
// https://github.com/NextThingCo/CHIP-u-boot/issues/10#issuecomment-287515505
|
|
||||||
|
|
||||||
#ifndef __LINUX_COMPILER_H
|
|
||||||
#error "Please don't include <linux/compiler-gcc6.h> directly, include <linux/compiler.h> instead."
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#define __used __attribute__((__used__))
|
|
||||||
#define __must_check __attribute__((warn_unused_result))
|
|
||||||
#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
|
||||||
|
|
||||||
/* Mark functions as cold. gcc will assume any path leading to a call
|
|
||||||
to them will be unlikely. This means a lot of manual unlikely()s
|
|
||||||
are unnecessary now for any paths leading to the usual suspects
|
|
||||||
like BUG(), printk(), panic() etc. [but let's keep them for now for
|
|
||||||
older compilers]
|
|
||||||
|
|
||||||
Early snapshots of gcc 4.3 don't support this and we can't detect this
|
|
||||||
in the preprocessor, but we can live with this because they're unreleased.
|
|
||||||
Maketime probing would be overkill here.
|
|
||||||
|
|
||||||
gcc also has a __attribute__((__hot__)) to move hot functions into
|
|
||||||
a special section, but I don't see any sense in this right now in
|
|
||||||
the kernel context */
|
|
||||||
#define __cold __attribute__((__cold__))
|
|
||||||
|
|
||||||
#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
|
||||||
|
|
||||||
#ifndef __CHECKER__
|
|
||||||
# define __compiletime_warning(message) __attribute__((warning(message)))
|
|
||||||
# define __compiletime_error(message) __attribute__((error(message)))
|
|
||||||
#endif /* __CHECKER__ */
|
|
||||||
|
|
||||||
/*
|
|
||||||
* Mark a position in code as unreachable. This can be used to
|
|
||||||
* suppress control flow warnings after asm blocks that transfer
|
|
||||||
* control elsewhere.
|
|
||||||
*
|
|
||||||
* Early snapshots of gcc 4.5 don't support this and we can't detect
|
|
||||||
* this in the preprocessor, but we can live with this because they're
|
|
||||||
* unreleased. Really, we need to have autoconf for the kernel.
|
|
||||||
*/
|
|
||||||
#define unreachable() __builtin_unreachable()
|
|
||||||
|
|
||||||
/* Mark a function definition as prohibited from being cloned. */
|
|
||||||
#define __noclone __attribute__((__noclone__))
|
|
||||||
|
|
||||||
/*
|
|
||||||
* Tell the optimizer that something else uses this function or variable.
|
|
||||||
*/
|
|
||||||
#define __visible __attribute__((externally_visible))
|
|
||||||
|
|
||||||
/*
|
|
||||||
* GCC 'asm goto' miscompiles certain code sequences:
|
|
||||||
*
|
|
||||||
* http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
|
||||||
*
|
|
||||||
* Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
|
||||||
*
|
|
||||||
* (asm goto is automatically volatile - the naming reflects this.)
|
|
||||||
*/
|
|
||||||
#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
|
||||||
|
|
||||||
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
|
||||||
#define __HAVE_BUILTIN_BSWAP32__
|
|
||||||
#define __HAVE_BUILTIN_BSWAP64__
|
|
||||||
#define __HAVE_BUILTIN_BSWAP16__
|
|
||||||
#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
|
||||||
|
|
Loading…
Reference in a new issue