main/mipi-dbi-cmd: tool for generating SPI panel init sequence firmware (MR 3527)
This commit is contained in:
parent
4144c7631f
commit
10df987e0e
2 changed files with 41 additions and 0 deletions
16
main/mipi-dbi-cmd/0001-convert-to-python3.patch
Normal file
16
main/mipi-dbi-cmd/0001-convert-to-python3.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- a/mipi-dbi-cmd
|
||||
+++ b/mipi-dbi-cmd
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python3
|
||||
# -*- coding: utf-8 -*-
|
||||
|
||||
# SPDX-License-Identifier: CC0-1.0
|
||||
@@ -12,7 +12,6 @@
|
||||
# You should have received a copy of the CC0 Public Domain Dedication along with this software.
|
||||
# If not, see <http://creativecommons.org/publicdomain/zero/1.0/>.
|
||||
|
||||
-from __future__ import print_function
|
||||
import argparse
|
||||
import sys
|
||||
|
25
main/mipi-dbi-cmd/APKBUILD
Normal file
25
main/mipi-dbi-cmd/APKBUILD
Normal file
|
@ -0,0 +1,25 @@
|
|||
pkgname=mipi-dbi-cmd
|
||||
pkgver=0_git20220210
|
||||
pkgrel=0
|
||||
pkgdesc="Tool to create firmware files for the panel-mipi-dbi display driver"
|
||||
url="https://github.com/notro/panel-mipi-dbi"
|
||||
arch="noarch"
|
||||
license="CC0-1.0"
|
||||
depends="python3"
|
||||
options="!check"
|
||||
_repository="panel-mipi-dbi"
|
||||
_commit="374b15f78611c619c381c643c5b3a8b5d23f479b"
|
||||
source="
|
||||
$url/archive/$_commit/$_repository-$_commit.tar.gz
|
||||
0001-convert-to-python3.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
|
||||
package() {
|
||||
install -Dm755 "$builddir"/mipi-dbi-cmd "$pkgdir"/usr/bin/mipi-dbi-cmd
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
9046951fb2559272ce658c46043c6850751d4a3a96cbd43f2574075c5236af8619ed24da13bb9dba672fca4ee77f16e7f97d446d6679cceba04a3d4ae587c9be panel-mipi-dbi-374b15f78611c619c381c643c5b3a8b5d23f479b.tar.gz
|
||||
0b96fc68d491a5d5f0a3d1ca3d985c7418c03c591a989ab306288db0ff942f47c7bc4a7e121b28b433c1c4dd6563577bbeead557ceebbe1aa2a4b8ea71e84544 0001-convert-to-python3.patch
|
||||
"
|
Loading…
Reference in a new issue