temp/plasma-workspace: fork from Alpine (!1021)
Add a patch to fix an issue with word wrapping on the language KCM
This commit is contained in:
parent
28b10068a9
commit
05d72f4821
2 changed files with 80 additions and 0 deletions
39
temp/plasma-workspace/APKBUILD
Normal file
39
temp/plasma-workspace/APKBUILD
Normal file
|
@ -0,0 +1,39 @@
|
|||
# Forked to apply Plasma Mobile specific fixes that are not in a release yet
|
||||
pkgname=plasma-workspace
|
||||
pkgver=5.18.80
|
||||
_pkgver=5.18.2
|
||||
pkgrel=0
|
||||
pkgdesc="KDE Plasma Workspace"
|
||||
arch="all !armhf" # armhf blocked by kirigami2 -> qt5-qtdeclarative
|
||||
url="https://www.kde.org/workspaces/plasmadesktop/"
|
||||
license="(GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later AND GPL-2.0-or-later AND MIT AND LGPL-2.1-only AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-only"
|
||||
depends="tzdata qt5-qtquickcontrols kirigami2 kinit qt5-qttools kwin kactivitymanagerd milou plasma-integration qtchooser kded kquickcharts"
|
||||
depends_dev="plasma-framework-dev krunner-dev kjsembed-dev knotifyconfig-dev kdesu-dev knewstuff-dev kwallet-dev kidletime-dev kdeclarative-dev ki18n-dev kcmutils-dev ktextwidgets-dev kdelibs4support-dev kcrash-dev kglobalaccel-dev kdbusaddons-dev kwayland-dev kcoreaddons-dev kded-dev libksysguard-dev kpackage-dev kscreenlocker-dev phonon-dev zlib-dev kitemmodels-dev networkmanager-qt-dev baloo-dev ktexteditor-dev kwin-dev kholidays-dev prison-dev kpeople-dev kactivities-stats-dev libkscreen-dev gpsd-dev iso-codes-dev"
|
||||
makedepends="$depends_dev extra-cmake-modules kdoctools-dev libxtst-dev"
|
||||
checkdepends="xvfb-run"
|
||||
source="https://download.kde.org/stable/plasma/$_pkgver/plasma-workspace-$_pkgver.tar.xz
|
||||
language-kcm-wrap-label-text.patch
|
||||
"
|
||||
subpackages="$pkgname-dev $pkgname-libs $pkgname-doc $pkgname-lang"
|
||||
builddir="$srcdir/$pkgname-$_pkgver"
|
||||
|
||||
build() {
|
||||
cmake -B "$builddir"/build \
|
||||
-DCMAKE_BUILD_TYPE=None \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib
|
||||
make -C build
|
||||
}
|
||||
|
||||
check() {
|
||||
cd "$builddir"/build
|
||||
# nightcolortest requires running dbus
|
||||
# testdesktop is broken
|
||||
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(nightcolortest|testdesktop)"
|
||||
}
|
||||
|
||||
package() {
|
||||
DESTDIR="$pkgdir" make -C build install
|
||||
}
|
||||
sha512sums="0fa91451e28b70d7602de79686afb57143eecd86e3856ed9c773bc4f5394610e5a5cf2f13fd03398b7a01624b45ab86d7e12da016980cb91ab23adac41a6793e plasma-workspace-5.18.2.tar.xz
|
||||
5628f61e702d332cbb87b8221a2b71e80bca1789026b82e74b1eaaa0a2f8438a705aac5ec99888239390753c81ec6a036acbf9ffad800987f08953cf6631adfe language-kcm-wrap-label-text.patch"
|
41
temp/plasma-workspace/language-kcm-wrap-label-text.patch
Normal file
41
temp/plasma-workspace/language-kcm-wrap-label-text.patch
Normal file
|
@ -0,0 +1,41 @@
|
|||
From b2df03a51f979066e6b0211dfd4986c2d1820089 Mon Sep 17 00:00:00 2001
|
||||
From: Bart Ribbers <bribbers@disroot.org>
|
||||
Date: Mon, 2 Mar 2020 14:10:53 +0100
|
||||
Subject: [Language KCM] Wrap the label text
|
||||
|
||||
Summary:
|
||||
This way the text doesn't get cut off the screen on at least the
|
||||
PinePhone
|
||||
|
||||
Test Plan:
|
||||
1. Open the Language KCM on a small screen without this patch
|
||||
2. Open the Language KCM on a small screen with this patch
|
||||
|
||||
Reviewers: davidedmundson
|
||||
|
||||
Reviewed By: davidedmundson
|
||||
|
||||
Subscribers: plasma-devel
|
||||
|
||||
Tags: #plasma
|
||||
|
||||
Differential Revision: https://phabricator.kde.org/D27781
|
||||
---
|
||||
kcms/translations/package/contents/ui/main.qml | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/kcms/translations/package/contents/ui/main.qml b/kcms/translations/package/contents/ui/main.qml
|
||||
index 24054ab..9e9d999 100644
|
||||
--- a/kcms/translations/package/contents/ui/main.qml
|
||||
+++ b/kcms/translations/package/contents/ui/main.qml
|
||||
@@ -171,6 +171,7 @@ ScrollViewKCM {
|
||||
visible: languagesList.count
|
||||
|
||||
text: i18n("The language at the top of this list is the one you want to see and use most often.")
|
||||
+ wrapMode: Text.WordWrap
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
cgit v1.1
|
||||
|
Loading…
Reference in a new issue