nvidia-shieldtablet: new device (MR 2112)
[ci:skip-build]: already built successfully in CI
This commit is contained in:
parent
0818a37457
commit
03f4d02df2
9 changed files with 4743 additions and 0 deletions
27
device/testing/device-nvidia-shieldtablet/APKBUILD
Normal file
27
device/testing/device-nvidia-shieldtablet/APKBUILD
Normal file
|
@ -0,0 +1,27 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-nvidia-shieldtablet
|
||||
pkgdesc="Nvidia Shield Tablet"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="armv7"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-nvidia-shieldtablet
|
||||
mesa-dri-gallium
|
||||
mkbootimg
|
||||
postmarketos-base
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="16f798ae9004e7f0cda2f1955376732ed8040b4f73a27edb1350cc43da295dc0144b28677ce6a19f1e666f9717c240eaf19fe4b44ec574f8ae9403c12db1de99 deviceinfo"
|
32
device/testing/device-nvidia-shieldtablet/deviceinfo
Normal file
32
device/testing/device-nvidia-shieldtablet/deviceinfo
Normal file
|
@ -0,0 +1,32 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Nvidia Shield Tablet"
|
||||
deviceinfo_manufacturer="Nvidia"
|
||||
deviceinfo_codename="nvidia-shieldtablet"
|
||||
deviceinfo_year="2014"
|
||||
deviceinfo_arch="armv7"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="tablet"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="1920"
|
||||
deviceinfo_screen_height="1200"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="vmalloc=450M buildvariant=eng"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_offset_base="0x10000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_flash_sparse="true"
|
62
device/testing/linux-nvidia-shieldtablet/APKBUILD
Normal file
62
device/testing/linux-nvidia-shieldtablet/APKBUILD
Normal file
|
@ -0,0 +1,62 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm/configs/cyanogenmod_shieldtablet_defconfig
|
||||
|
||||
pkgname=linux-nvidia-shieldtablet
|
||||
pkgver=3.10.33
|
||||
pkgrel=0
|
||||
pkgdesc="Nvidia Shield Tablet kernel fork"
|
||||
arch="armv7"
|
||||
_carch="arm"
|
||||
_flavor="nvidia-shieldtablet"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
flex
|
||||
openssl-dev
|
||||
perl
|
||||
linux-headers
|
||||
"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_nvidia_shieldtablet"
|
||||
_commit="80eedb988bec3cbed1d45300c47c42f9fe7d65af"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
gcc8-fix-put-user.patch
|
||||
gcc10-extern_YYLOC_global_declaration.patch
|
||||
kernel-use-the-gnu89-standard-explicitly.patch
|
||||
fix_recordmcount.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
}
|
||||
|
||||
sha512sums="f40a0d7ec9d639ff03793475489d4f70915d353cdd59916a7086790053c49973cef06597658cb9e615914b69be0e7ad26b2c2b683390dc198ccc39e2fce9b777 linux-nvidia-shieldtablet-80eedb988bec3cbed1d45300c47c42f9fe7d65af.tar.gz
|
||||
613117561db64faac57c7177e0b1d8261eb3abf7729b090b09c2ef1c65cc9cb3051914f2d8abf392bc8ed6980ec8a8451f81be53d208c917bb5f765d938364bb config-nvidia-shieldtablet.armv7
|
||||
77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7 gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||
ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c kernel-use-the-gnu89-standard-explicitly.patch
|
||||
6aa11a75f422ac5c20cddfce23bff81940e61e65bc86fe1070c60714a6ccf631b2da70bff20e2b88e723706f0f233eb03540a8d9389adffd495592e8ab6bd82a fix_recordmcount.patch"
|
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1,61 @@
|
|||
From 84f8a24ade96a8c1499823b160a0591199cf9d12 Mon Sep 17 00:00:00 2001
|
||||
From: Laura Abbott <labbott@redhat.com>
|
||||
Date: Fri, 8 Jul 2016 12:18:50 -0700
|
||||
Subject: [PATCH] ftrace/recordmcount: Work around for addition of metag magic
|
||||
but not relocations
|
||||
|
||||
commit b2e1c26f0b62531636509fbcb6dab65617ed8331 upstream.
|
||||
|
||||
glibc recently did a sync up (94e73c95d9b5 "elf.h: Sync with the gabi
|
||||
webpage") that added a #define for EM_METAG but did not add relocations
|
||||
|
||||
This triggers build errors:
|
||||
|
||||
scripts/recordmcount.c: In function 'do_file':
|
||||
scripts/recordmcount.c:466:28: error: 'R_METAG_ADDR32' undeclared (first use in this function)
|
||||
case EM_METAG: reltype = R_METAG_ADDR32;
|
||||
^~~~~~~~~~~~~~
|
||||
scripts/recordmcount.c:466:28: note: each undeclared identifier is reported only once for each function it appears in
|
||||
scripts/recordmcount.c:468:20: error: 'R_METAG_NONE' undeclared (first use in this function)
|
||||
rel_type_nop = R_METAG_NONE;
|
||||
^~~~~~~~~~~~
|
||||
|
||||
Work around this change with some more #ifdefery for the relocations.
|
||||
|
||||
Fedora Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1354034
|
||||
|
||||
Link: http://lkml.kernel.org/r/1468005530-14757-1-git-send-email-labbott@redhat.com
|
||||
|
||||
Cc: James Hogan <james.hogan@imgtec.com>
|
||||
Fixes: 00512bdd4573 ("metag: ftrace support")
|
||||
Reported-by: Ross Burton <ross.burton@intel.com>
|
||||
Signed-off-by: Laura Abbott <labbott@redhat.com>
|
||||
Signed-off-by: Steven Rostedt <rostedt@goodmis.org>
|
||||
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
||||
---
|
||||
scripts/recordmcount.c | 9 ++++++++-
|
||||
1 file changed, 8 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/scripts/recordmcount.c b/scripts/recordmcount.c
|
||||
index e167592793a7..42396a74405d 100644
|
||||
--- a/scripts/recordmcount.c
|
||||
+++ b/scripts/recordmcount.c
|
||||
@@ -33,10 +33,17 @@
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
|
||||
+/*
|
||||
+ * glibc synced up and added the metag number but didn't add the relocations.
|
||||
+ * Work around this in a crude manner for now.
|
||||
+ */
|
||||
#ifndef EM_METAG
|
||||
-/* Remove this when these make it to the standard system elf.h. */
|
||||
#define EM_METAG 174
|
||||
+#endif
|
||||
+#ifndef R_METAG_ADDR32
|
||||
#define R_METAG_ADDR32 2
|
||||
+#endif
|
||||
+#ifndef R_METAG_NONE
|
||||
#define R_METAG_NONE 3
|
||||
#endif
|
||||
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc7-give-up-on-ilog2-const-optimizations.patch
|
1
device/testing/linux-nvidia-shieldtablet/gcc8-fix-put-user.patch
Symbolic link
1
device/testing/linux-nvidia-shieldtablet/gcc8-fix-put-user.patch
Symbolic link
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc8-fix-put-user.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/kernel-use-the-gnu89-standard-explicitly.patch
|
Loading…
Reference in a new issue