main/crust: remove (MR 4785)

The community/crust package in aports is newer, and
its crust-pinephone subpackage is equivalent to this one.
This commit is contained in:
Arnav Singh 2024-02-06 08:45:17 -08:00
parent a12bbf1057
commit 03940b180a
No known key found for this signature in database
GPG key ID: 89A451A9C0E3AF0B
2 changed files with 0 additions and 55 deletions

View file

@ -1,26 +0,0 @@
# Maintainer: Martijn Braam <martijn@brixit.nl>
pkgname=crust
pkgver=0.5
pkgrel=1
pkgdesc="SCP firmware for sunxi SoCs"
arch="aarch64"
url="https://github.com/crust-firmware/crust"
license="BSD-1-Clause AND BSD-3-Clause AND GPL-2.0-only and MIT"
makedepends="gcc-or1k-elf binutils-or1k-elf dtc bison flex"
source="crust-v$pkgver.tar.gz::https://github.com/crust-firmware/crust/archive/refs/tags/v$pkgver.tar.gz
fix-build-with-gcc-12.patch
"
options="!check !archcheck !tracedeps pmb:cross-native" # No tests
build() {
make CROSS_COMPILE=or1k-elf- pinephone_defconfig
make CROSS_COMPILE=or1k-elf- build/scp/scp.bin
}
package() {
install -D -m644 build/scp/scp.bin "$pkgdir"/usr/share/crust/pinephone/scp.bin
}
sha512sums="
1a3811053fd3a27285a1377888ab5b36e9363a2f5818f69966eb7f5214e571475a2a7865b9e1b68387940a9a7e9dc3841d2458544c155aecc5b9da041eb946ba crust-v0.5.tar.gz
cde7b2ab368533a9902fa67a8f35c012864cdaaa4f38b62715513c67bd9a0591b22a6d7c29961da9e5ea342589a2aac5beec4b84838041f7dfb2d414d6bc4d4b fix-build-with-gcc-12.patch
"

View file

@ -1,29 +0,0 @@
From 9c5a56c4c162dd18c3db71e770982860f850e5d3 Mon Sep 17 00:00:00 2001
From: Kayo Phoenix <kayo@illumium.org>
Date: Sat, 29 Oct 2022 21:30:58 +0500
Subject: [PATCH] Fix build using GCC 12.x
I have linking error like the following:
```
| LD .../crust/2022.09.13-r0/build/scp/scp.elf
| .../crust/2022.09.13-r0/recipe-sysroot-native/usr/bin/../lib/gcc/or1k-none-elf/12.2.0/../../../../or1k-none-elf/bin/ld: warning: .../crust/2022.09.13-r0/build/scp/scp.elf has a LOAD segment with RWX permissions
| collect2: error: ld returned 1 exit status
| make: *** [Makefile:197: .../crust/2022.09.13-r0/build/scp/scp.elf] Error 1
| make: Leaving directory '.../crust/2022.09.13-r0/git'
```
---
Makefile | 1 +
1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile
index 2f6b707a..d41838c3 100644
--- a/Makefile
+++ b/Makefile
@@ -80,6 +80,7 @@ LDFLAGS = -nostdlib \
-static \
-Wl,-O1 \
-Wl,--build-id=none \
+ -Wl,--no-warn-rwx-segments \
-Wl,--fatal-warnings \
-Wl,--gc-sections \
-Wl,--no-dynamic-linker \