This repository has been archived on 2024-08-13. You can view files and clone it, but cannot push or open issues or pull requests.
bunc/PKGBUILD

31 lines
468 B
Bash

pkgname=bunc
pkgver=0.1
pkgrel=1
pkgdesc="A functional bash library"
arch=(any)
changelog=CHANGELOG.md
license=('GPLv3')
depends=()
makedepends=('git')
source=(
"${pkgname}::git+https://github.com/ayakael/${pkgname}.git"
)
sha256sums=(
"SKIP"
)
prepare(){
cd ${srcdir}/${pkgname}
git checkout ${pkgver}
}
build(){
cd ${srcdir}/bunc
./build.sh
}
package() {
# Install the library
install -Dm644 "${srcdir}/bunc/bunc" "${pkgdir}/usr/lib/bash/bunc"
}