89 lines
2.7 KiB
Diff
89 lines
2.7 KiB
Diff
core issue: https://github.com/rust-lang/rust-bindgen/issues/2312
|
|
upstream: https://github.com/signalapp/boring/pull/19
|
|
upstream's upstream: https://github.com/cloudflare/boring/pull/110
|
|
|
|
--- ./Cargo.toml.orig
|
|
+++ ./Cargo.toml
|
|
@@ -25,3 +25,6 @@
|
|
# Use our fork of curve25519-dalek for eventual zkgroup support.
|
|
curve25519-dalek = { git = 'https://github.com/signalapp/curve25519-dalek', branch = 'lizard2' }
|
|
boring = { git = 'https://github.com/signalapp/boring', branch = 'libsignal'}
|
|
+
|
|
+[patch.'https://github.com/signalapp/boring']
|
|
+boring-sys = { git = 'https://github.com/selfisekai/boring-cf', branch = 'i109-signal', package = 'boring-sys' }
|
|
--- ./Cargo.lock.orig
|
|
+++ ./Cargo.lock
|
|
@@ -206,9 +206,9 @@
|
|
|
|
[[package]]
|
|
name = "bindgen"
|
|
-version = "0.60.1"
|
|
+version = "0.62.0"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "062dddbc1ba4aca46de6338e2bf87771414c335f7b2f2036e8f3e9befebf88e6"
|
|
+checksum = "c6720a8b7b2d39dd533285ed438d458f65b31b5c257e6ac7bb3d7e82844dd722"
|
|
dependencies = [
|
|
"bitflags",
|
|
"cexpr",
|
|
@@ -221,6 +221,7 @@
|
|
"regex",
|
|
"rustc-hash",
|
|
"shlex",
|
|
+ "syn",
|
|
]
|
|
|
|
[[package]]
|
|
@@ -295,7 +296,7 @@
|
|
[[package]]
|
|
name = "boring-sys"
|
|
version = "2.1.0"
|
|
-source = "git+https://github.com/signalapp/boring?branch=libsignal#25e1dd8fa519ae90772008fbd4a284582096fece"
|
|
+source = "git+https://github.com/selfisekai/boring-cf?branch=i109-signal#5c13f5c357c8b33c9978f2e447de2d6caf825d13"
|
|
dependencies = [
|
|
"bindgen",
|
|
"cmake",
|
|
@@ -1398,11 +1399,11 @@
|
|
|
|
[[package]]
|
|
name = "proc-macro2"
|
|
-version = "1.0.29"
|
|
+version = "1.0.54"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "b9f5105d4fdaab20335ca9565e106a5d9b82b6219b5ba735731124ac6711d23d"
|
|
+checksum = "e472a104799c74b514a57226160104aa483546de37e839ec50e3c2e41dd87534"
|
|
dependencies = [
|
|
- "unicode-xid",
|
|
+ "unicode-ident",
|
|
]
|
|
|
|
[[package]]
|
|
@@ -1868,13 +1869,13 @@
|
|
|
|
[[package]]
|
|
name = "syn"
|
|
-version = "1.0.80"
|
|
+version = "1.0.109"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "d010a1623fbd906d51d650a9916aaefc05ffa0e4053ff7fe601167f3e715d194"
|
|
+checksum = "72b64191b275b66ffe2469e8af2c1cfe3bafa67b529ead792a6d0160888b4237"
|
|
dependencies = [
|
|
"proc-macro2",
|
|
"quote",
|
|
- "unicode-xid",
|
|
+ "unicode-ident",
|
|
]
|
|
|
|
[[package]]
|
|
@@ -1981,6 +1982,12 @@
|
|
version = "0.1.3"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
checksum = "56dee185309b50d1f11bfedef0fe6d036842e3fb77413abef29f8f8d1c5d4c1c"
|
|
+
|
|
+[[package]]
|
|
+name = "unicode-ident"
|
|
+version = "1.0.8"
|
|
+source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
+checksum = "e5464a87b239f13a63a501f2701565754bae92d243d4bb7eb12f6d57d2269bf4"
|
|
|
|
[[package]]
|
|
name = "unicode-segmentation"
|