21 lines
504 B
Diff
21 lines
504 B
Diff
--- /dev/null
|
|
+++ ./pyproject.toml.in
|
|
@@ -0,0 +1,17 @@
|
|
+[build-system]
|
|
+requires = ["sip >=6, <7"]
|
|
+build-backend = "sipbuild.api"
|
|
+
|
|
+[tool.sip.metadata]
|
|
+name = "pynest2d"
|
|
+
|
|
+[tool.sip.project]
|
|
+builder-factory = "CMakeBuilder"
|
|
+sip-files-dir = "${CMAKE_CURRENT_SOURCE_DIR}/src/"
|
|
+sip-include-dirs = ["CMAKE_CURRENT_SOURCE_DIR/src/"]
|
|
+build-dir = "${CMAKE_CURRENT_BINARY_DIR}/pynest2d/"
|
|
+
|
|
+[tool.sip.bindings.pynest2d]
|
|
+exceptions = true
|
|
+release-gil = true
|
|
+concatenate = 8
|
|
\ No newline at end of file
|