39 lines
1,014 B
Text
39 lines
1,014 B
Text
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
|
|
pkgname=py3-ruamel-yaml
|
|
_pyname="ruamel.yaml"
|
|
pkgver=0.17.32
|
|
pkgrel=0
|
|
arch="noarch"
|
|
pkgdesc="AML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order"
|
|
url="https://pypi.python.org/project/$_pyname"
|
|
license="MIT"
|
|
depends="
|
|
py3-ruamel-yaml-clib
|
|
"
|
|
makedepends="
|
|
py3-setuptools
|
|
py3-wheel
|
|
py3-gpep517
|
|
py3-wheel
|
|
"
|
|
options="!check" # No testsuite
|
|
source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz"
|
|
builddir="$srcdir"/$_pyname-$pkgver
|
|
subpackages="$pkgname-pyc"
|
|
|
|
build() {
|
|
gpep517 build-wheel \
|
|
--wheel-dir dist \
|
|
--output-fd 3 3>&1 >&2
|
|
}
|
|
|
|
package() {
|
|
python3 -m installer -d "$pkgdir" \
|
|
dist/*.whl
|
|
}
|
|
|
|
sha512sums="
|
|
9734b7bda9a333a4271d584470622177d112b3084c5efa730345228828863e2f5aa4de9ee0a30d4127336ef3604488a9b739535dfc9b3e760b396a0e269643d7 py3-ruamel-yaml-0.17.32.tar.gz
|
|
"
|