34 lines
934 B
Text
34 lines
934 B
Text
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
|
|
pkgname=py3-pytz-deprecation-shim
|
|
_pkgname=pytz_deprecation_shim
|
|
pkgver=0.1.0
|
|
_pkgver=$pkgver.post0
|
|
pkgrel=0
|
|
arch='noarch'
|
|
pkgdesc="Shims to help you safely remove pytz"
|
|
url="https://pypi.org/project/$_pkgname/"
|
|
license="MIT"
|
|
makedepends="
|
|
py3-setuptools
|
|
py3-wheel
|
|
py3-installer
|
|
py3-build
|
|
"
|
|
source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$_pkgver.tar.gz"
|
|
builddir="$srcdir"/$_pkgname-$_pkgver
|
|
options="!check" # No testsuite
|
|
subpackages="$pkgname-pyc"
|
|
|
|
build() {
|
|
python3 -m build --wheel --no-isolation
|
|
}
|
|
|
|
package() {
|
|
python3 -m installer --destdir="$pkgdir" dist/*.whl
|
|
}
|
|
|
|
sha512sums="
|
|
201eea777f4da9def1b060911da5eaa89652f6716d5608278fdc94a2f67af5ea23a8b667cb181e03d5edd7f0a07f4954047621668f4c2e7bb325dd07f454d0b6 py3-pytz-deprecation-shim-0.1.0.tar.gz
|
|
"
|