45 lines
1,003 B
Text
45 lines
1,003 B
Text
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
|
|
_pyname=dacite
|
|
pkgname="py3-$_pyname"
|
|
pkgver=1.8.1
|
|
pkgrel=0
|
|
arch="noarch"
|
|
pkgdesc="This module simplifies creation of data classes (PEP 557) from dictionaries."
|
|
url="https://pypi.python.org/project/$_pyname"
|
|
license="MIT"
|
|
makedepends="
|
|
py3-setuptools
|
|
py3-gpep517
|
|
py3-installer
|
|
py3-wheel
|
|
"
|
|
checkdepends="
|
|
py3-pytest
|
|
py3-pytest-benchmark
|
|
py3-pytest-cov
|
|
py3-coveralls
|
|
"
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/konradhalas/dacite/archive/refs/tags/v$pkgver.tar.gz"
|
|
builddir="$srcdir"/$_pyname-$pkgver
|
|
subpackages="$pkgname-pyc"
|
|
|
|
build() {
|
|
gpep517 build-wheel \
|
|
--wheel-dir dist \
|
|
--output-fd 3 3>&1 >&2
|
|
}
|
|
|
|
check() {
|
|
pytest -v
|
|
}
|
|
|
|
package() {
|
|
python3 -m installer -d "$pkgdir" \
|
|
dist/*.whl
|
|
}
|
|
|
|
sha512sums="
|
|
4b40c0bdcf5490bcc77de9e7f04b7267642bcfd41e4168607a5457f38abe3ad4b3041d8a23cb43af76de14eabee45f900ad5ddf7af8f70a2be4850bccc2d3af1 py3-dacite-1.8.1.tar.gz
|
|
"
|