48 lines
1.3 KiB
Text
48 lines
1.3 KiB
Text
# Maintainer: Hoang Nguyen <folliekazetani@protonmail.com>
|
|
pkgname=py3-gitlab
|
|
_pyname=${pkgname/py3/python}
|
|
pkgver=3.14.0
|
|
pkgrel=1
|
|
pkgdesc="Python wrapper for Gitlab's API"
|
|
url="https://github.com/python-gitlab/python-gitlab"
|
|
arch="noarch"
|
|
license="LGPL-3.0-or-later"
|
|
depends="python3 py3-requests py3-requests-toolbelt"
|
|
makedepends="
|
|
py3-setuptools
|
|
py3-gpep517
|
|
py3-installer
|
|
py3-wheel
|
|
py3-sphinx
|
|
py3-sphinxcontrib-autoprogram
|
|
py3-myst-parser
|
|
"
|
|
checkdepends="py3-pytest py3-responses"
|
|
subpackages="$pkgname-doc $pkgname-pyc"
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/python-gitlab/python-gitlab/archive/refs/tags/v$pkgver.tar.gz"
|
|
builddir="$srcdir/$_pyname-$pkgver"
|
|
|
|
build() {
|
|
gpep517 build-wheel \
|
|
--wheel-dir dist \
|
|
--output-fd 3 3>&1 >&2
|
|
sphinx-build -W -b man docs/ man/
|
|
}
|
|
|
|
check() {
|
|
sed -i "s|/usr/bin/false|/bin/false|g" tests/unit/test_config.py
|
|
python3 -m venv --clear --without-pip --system-site-packages testenv
|
|
testenv/bin/python3 -m installer dist/*.whl
|
|
testenv/bin/python3 -m pytest --ignore=tests/functional/
|
|
}
|
|
|
|
package() {
|
|
python3 -m installer -d "$pkgdir" \
|
|
dist/*.whl
|
|
install -Dm644 man/$_pyname.1 \
|
|
"$pkgdir"/usr/share/man/man1/$_pyname.1
|
|
}
|
|
|
|
sha512sums="
|
|
01a41e6f4b9e316672b83270fce6fc30e69e9a0047644d04b27587eebda06dc2c575649367d9dc99b84782e940f236a07098a78d7c7662b555fd901e32d35176 py3-gitlab-3.14.0.tar.gz
|
|
"
|