45 lines
1.5 KiB
Text
45 lines
1.5 KiB
Text
# Contributor: Quillith <tag.quill@protonmail.com>
|
|
# Maintainer: Quillith <tag.quill@protonmail.com>
|
|
pkgname=nb
|
|
pkgver=7.15.0
|
|
pkgrel=0
|
|
pkgdesc="Command line note-taking, bookmarking, archiving, and knowledge base application"
|
|
url="https://github.com/xwmx/nb"
|
|
arch="noarch"
|
|
license="AGPL-3.0-or-later"
|
|
depends="bash git"
|
|
subpackages="
|
|
$pkgname-doc
|
|
$pkgname-full
|
|
$pkgname-bash-completion
|
|
$pkgname-fish-completion
|
|
$pkgname-zsh-completion
|
|
"
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/xwmx/nb/archive/$pkgver.tar.gz"
|
|
options="!check" # no tests
|
|
|
|
package() {
|
|
install -Dm755 nb "$pkgdir/usr/bin/nb"
|
|
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/nb/LICENSE"
|
|
install -Dm644 README.md "$pkgdir/usr/share/doc/nb/README.md"
|
|
# Completions
|
|
install -Dm644 etc/nb-completion.bash "$pkgdir/usr/share/bash-completion/completions/nb"
|
|
install -Dm644 etc/nb-completion.fish "$pkgdir/usr/share/fish/vendor_completions.d/nb.fish"
|
|
install -Dm644 etc/nb-completion.zsh "$pkgdir/usr/share/zsh/site-functions/_nb"
|
|
# Plugins
|
|
install -Dm644 -t "$pkgdir/usr/share/nb/plugins/" plugins/*
|
|
# Extras (prefixed with "nb-")
|
|
for extra in bookmark notes; do
|
|
install -Dm0755 "bin/$extra" "$pkgdir/usr/bin/nb-$extra"
|
|
done
|
|
}
|
|
|
|
full() {
|
|
pkgdesc="More utilities that integrate with nb"
|
|
depends="$pkgname=$pkgver-r$pkgrel bat nmap-ncat pandoc ripgrep tig w3m"
|
|
mkdir -p "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
54b270aa7f9b89a95fb7b11ca472c2fd24c627d2a3dc14d96f587d89e110940cd4158b2398168c70abc9440f79cefd5cefab40c93829a5b494e9201bc8d41493 nb-7.15.0.tar.gz
|
|
"
|