62 lines
1.4 KiB
Text
62 lines
1.4 KiB
Text
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
pkgname=roxy-wi
|
|
pkgver=6.3.7.0
|
|
pkgrel=1
|
|
pkgdesc="Web interface for managing HAProxy, Nginx and Keepalived servers"
|
|
arch='noarch'
|
|
url="https://github.com/Aidaho12/haproxy-wi"
|
|
license='Apache-2.0'
|
|
makedepends='git'
|
|
depends="
|
|
net-tools
|
|
lshw
|
|
dos2unix
|
|
nginx
|
|
py3-pip
|
|
netcat-openbsd
|
|
python3
|
|
libpq
|
|
libldap
|
|
libsasl
|
|
pkgconfig
|
|
nmap
|
|
py3-paramiko
|
|
py3-pytz-deprecation-shim
|
|
py3-requests
|
|
py3-pytelegrambotapi
|
|
py3-networkx
|
|
py3-matplotlib
|
|
py3-future
|
|
py3-jinja2
|
|
py3-slack-sdk
|
|
py3-peewee
|
|
py3-pymysql
|
|
py3-distro
|
|
py3-bottle
|
|
py3-psutil
|
|
"
|
|
makedepends="
|
|
python3-dev
|
|
libxml2-dev
|
|
libxslt-dev
|
|
libffi-dev
|
|
freetype-dev
|
|
"
|
|
source="roxi-wi.$pkgver.tar.gz::https://github.com/hap-wi/roxy-wi/archive/refs/tags/v$pkgver.tar.gz"
|
|
_giturl="https://github.com/Aidaho12/haproxy-wi"
|
|
_gittag="0f02f84588bd15c5c923e0e405d8f32a19321b2a"
|
|
options="!check"
|
|
|
|
package() {
|
|
_instdir="$pkgdir"/usr/share/webapps/haproxy-wi
|
|
mkdir -p "$_instdir"
|
|
cd "$_instdir"
|
|
cp -ra "$builddir"/* .
|
|
chmod +x app/*.py
|
|
install -Dm755 -d "$_instdir"/app/certs "$_instdir"/keys "$_instdir"/log "$pkgdir"/etc/logrotate.d
|
|
cp "$_instdir"/config_other/logrotate/* "$pkgdir"/etc/logrotate.d/.
|
|
}
|
|
sha512sums="
|
|
6b362ba3f78c479fa61f168da1cb26c30168ab27c96dd1818e74e930b798ded4be7f0742cd67ccba4401eb346e44f2864df735e2bd62402c8dd360999cf3f7c1 roxi-wi.6.3.7.0.tar.gz
|
|
"
|