39 lines
1,013 B
Text
39 lines
1,013 B
Text
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
|
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
|
|
|
pkgname=qt5-svg
|
|
_qtver=5.14.2
|
|
pkgver=${_qtver}
|
|
pkgrel=0
|
|
arch=('x86_64')
|
|
url='https://www.qt.io'
|
|
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
|
pkgdesc='Classes for displaying the contents of SVG files'
|
|
depends=('qt5-base')
|
|
groups=('qt' 'qt5')
|
|
_pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
|
|
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
|
|
sha256sums=('c7d7faa01a3e7a6e4d38fafcec5529a488258218749779e6fa0e09a21173b5a1')
|
|
|
|
prepare() {
|
|
mkdir -p build
|
|
}
|
|
|
|
build() {
|
|
cd build
|
|
|
|
qmake ../${_pkgfqn}
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd build
|
|
make INSTALL_ROOT="$pkgdir" install
|
|
|
|
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
|
|
find "$pkgdir/usr/lib" -type f -name '*.prl' \
|
|
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
|
|
|
|
install -d "$pkgdir"/usr/share/licenses
|
|
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
|
|
}
|