28 lines
837 B
Text
28 lines
837 B
Text
# Contributor: Francesco Colista <francesco.colista@gmail.com>
|
|
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
|
|
pkgname=py3-mechanize
|
|
_pkgname=mechanize
|
|
pkgver=0.4.5
|
|
pkgrel=0
|
|
pkgdesc="Stateful programmatic web browsing in Python"
|
|
url="https://github.com/python-mechanize/mechanize"
|
|
arch="noarch"
|
|
license="BSD-3-Clause"
|
|
depends="python3"
|
|
makedepends="py3-setuptools"
|
|
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
|
|
builddir="$srcdir/$_pkgname-$pkgver"
|
|
|
|
build() {
|
|
python3 setup.py build
|
|
}
|
|
|
|
check() {
|
|
python3 setup.py check
|
|
}
|
|
|
|
package() {
|
|
python3 setup.py install --prefix=/usr --root="$pkgdir"
|
|
}
|
|
|
|
sha512sums="51706d5c073501d02fb7395eda30625ed9191324f948073c7d1589df0e507d8b7641ca514ceff55e7d82e899ba6e10c55507c79668976c7654ff0004671d09d2 mechanize-0.4.5.tar.gz"
|