32 lines
818 B
Text
32 lines
818 B
Text
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
|
|
pkgname=gulp
|
|
pkgver=4.0.2
|
|
pkgrel=1
|
|
pkgdesc="The streaming build system"
|
|
arch="noarch"
|
|
url="https://gulpjs.com/"
|
|
license="MIT"
|
|
depends="nodejs py3-semver"
|
|
makedepends="npm"
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/gulpjs/gulp/archive/refs/tags/v$pkgver.tar.gz"
|
|
builddir="$srcdir"/package
|
|
|
|
build() {
|
|
npm install --ignore-scripts --production
|
|
}
|
|
|
|
package() {
|
|
local appdir=/usr/lib/$pkgname
|
|
|
|
install -d "$pkgdir"$appdir
|
|
cp -r * "$pkgdir"$appdir
|
|
|
|
install -d "$pkgdir"/usr/bin
|
|
ln -s $appdir/bin/gulp.js "$pkgdir"/usr/bin/gulp
|
|
}
|
|
|
|
sha512sums="
|
|
76f12cdbb48266dda26c5dbdc588269f0c02619c5dc6143ff8b15695b016f32ee3b7af0bffae78d362f3dfe08acb43afe2b3acf8d111983abb62565a0ea5087c gulp-4.0.2.tar.gz
|
|
"
|