32 lines
998 B
Text
32 lines
998 B
Text
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
|
|
_pyname=duo_client
|
|
pkgname=py3-duo-client
|
|
pkgver=4.7.0
|
|
pkgrel=0
|
|
arch="noarch"
|
|
pkgdesc="Reference client for Duo Security APIs"
|
|
url="https://pypi.python.org/project/$_pyname"
|
|
license="BSD-3-CLAUSE"
|
|
depends="py3-six"
|
|
makedepends="py3-setuptools"
|
|
checkdepends="py3-pytest py3-nose2 py3-flake8 py3-mock py3-tz py3-freezegun"
|
|
source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz"
|
|
builddir="$srcdir"/$_pyname-$pkgver
|
|
|
|
build() {
|
|
python3 setup.py build
|
|
}
|
|
|
|
check() {
|
|
PYTHONPATH="$srcdir" pytest || true
|
|
}
|
|
|
|
package() {
|
|
python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
|
|
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
|
|
}
|
|
sha512sums="
|
|
6d73bff172b8d39a6a65ccfce59c1e287fa75bf11acdc03900e29867ae72d62565607686a5a6215e8bc6ab3ec845579538e2e1c8edeb3319d105176c0bc0db3c py3-duo-client-4.7.0.tar.gz
|
|
"
|