38 lines
1.2 KiB
Text
38 lines
1.2 KiB
Text
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
|
|
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
|
|
pkgname=py3-flask-principal
|
|
_pkgname=flask-principal
|
|
pkgver=0.4.0
|
|
pkgrel=7
|
|
pkgdesc="Flask Identity management"
|
|
url="https://pythonhosted.org/Flask-Principal/"
|
|
arch="noarch"
|
|
license="MIT"
|
|
depends="python3 py3-blinker py3-flask"
|
|
makedepends="py3-setuptools py3-gpep517 py3-wheel"
|
|
checkdepends="py3-nose"
|
|
subpackages="$pkgname-pyc"
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/mattupstate/flask-principal/archive/$pkgver.tar.gz"
|
|
builddir="$srcdir"/$_pkgname-$pkgver
|
|
|
|
replaces="py-flask-principal" # Backwards compatibility
|
|
provides="py-flask-principal=$pkgver-r$pkgrel" # Backwards compatibility
|
|
|
|
build() {
|
|
gpep517 build-wheel \
|
|
--wheel-dir .dist \
|
|
--output-fd 3 3>&1 >&2
|
|
}
|
|
|
|
check() {
|
|
python3 -m venv --clear --without-pip --system-site-packages .testenv
|
|
gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
|
|
.testenv/bin/python3 -m nose
|
|
}
|
|
|
|
package() {
|
|
gpep517 install-wheel --destdir "$pkgdir" \
|
|
.dist/*.whl
|
|
}
|
|
|
|
sha512sums="ed8cb28c4e8d936de96db0bf9f7cb45b253dc204c4b8f8dd8022ef1552592ff6324b4a33d3ee862794a6e20eb8c32a0365e7b9397d427da5022c5ded3dfa308a py3-flask-principal-0.4.0.tar.gz"
|