45 lines
1.2 KiB
Text
45 lines
1.2 KiB
Text
# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
|
|
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
|
|
pkgname=py3-codespell
|
|
_pkgname=${pkgname#py3-}
|
|
pkgver=2.2.6
|
|
pkgrel=2
|
|
pkgdesc="Fix common misspellings in text files, primarily source code"
|
|
url="https://github.com/codespell-project/codespell/"
|
|
arch="noarch"
|
|
license="GPL-2.0-only"
|
|
makedepends="
|
|
py3-gpep517
|
|
py3-setuptools
|
|
py3-setuptools_scm
|
|
py3-wheel
|
|
"
|
|
checkdepends="py3-pytest-cov"
|
|
depends="py3-chardet"
|
|
subpackages="$pkgname-pyc"
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/codespell-project/codespell/archive/refs/tags/v$pkgver.tar.gz"
|
|
builddir="$srcdir"/$_pkgname-$pkgver
|
|
|
|
build() {
|
|
SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver \
|
|
gpep517 build-wheel \
|
|
--wheel-dir .dist \
|
|
--output-fd 3 3>&1 >&2
|
|
}
|
|
|
|
check() {
|
|
python3 -m venv --clear --without-pip --system-site-packages .testenv
|
|
.testenv/bin/python3 -m installer .dist/*.whl
|
|
|
|
# tests want to run bin/codespell
|
|
PATH="$builddir/.testenv/bin:$PATH" .testenv/bin/python3 -m pytest
|
|
}
|
|
|
|
package() {
|
|
python3 -m installer -d "$pkgdir" \
|
|
.dist/*.whl
|
|
}
|
|
|
|
sha512sums="
|
|
37a6fbcf196447e8204a973499c6b3f7efda67e3caaaa707897da438c602834f91ca49b95020d2c03dcb95528c03451a2d9cfe145b2a24e88615c4a5418a4d2b py3-codespell-2.2.6.tar.gz
|
|
"
|