ayaports/testing/py3-rauth/APKBUILD

39 lines
921 B
Text

# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=py3-rauth
_pkgname=rauth
pkgver=0.7.3
pkgrel=0
pkgdesc="A Python library for OAuth 1.0/a, 2.0, and Ofly"
arch="noarch"
url="https://github.com/maxcountryman/rauth"
license="MIT"
depends="
py3-requests
"
makedepends="
py3-setuptools
py3-wheel
py3-gpep517
py3-installer
"
source="$_pkgname-$pkgver.tar.gz::https://pypi.python.org/packages/source/r/$_pkgname/$_pkgname-$pkgver.tar.gz"
options="!check" # No testsuite
builddir="$srcdir"/$_pkgname-$pkgver
subpackages="$pkgname-pyc"
build() {
gpep517 build-wheel \
--wheel-dir dist \
--output-fd 3 3>&1 >&2
}
package() {
python3 -m installer -d "$pkgdir" \
dist/*.whl
}
sha512sums="
8bb6d10e5d4ddb583c45e3bf166051b8edde8193cd10da8c1a623908d2cc5a3a2cbc9065d5fa397188414e72fa66166051893e4ba956369b3f0f850ae823837e rauth-0.7.3.tar.gz
"