ayaports/testing/py3-goodreads/APKBUILD

40 lines
988 B
Text

# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=py3-goodreads
_pkgname=goodreads
pkgver=0.3.2
pkgrel=0
pkgdesc="Python extension for computing string edit distances and similarities"
url="https://pypi.python.org/pypi/Goodreads"
license="MIT"
arch="noarch"
makedepends="
py3-setuptools
py3-gpep517
py3-wheel
py3-installer
python3-dev
py3-xmltodict
py3-requests
py3-rauth
"
source="$_pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/g/$_pkgname/$_pkgname-$pkgver.tar.gz"
options="!check" # No testsuite
builddir="$srcdir"/$_pkgname-$pkgver
subpackages="$pkgname-pyc"
build() {
gpep517 build-wheel \
--wheel-dir dist \
--output-fd 3 3>&1 >&2
}
package() {
python3 -m installer -d "$pkgdir" \
dist/*.whl
}
sha512sums="
2c1f7be226bbbac3d60247a5dddc06c48ad1d72790e4ce61c8c369100358965926422958563f153661b91b561414e4b573b95098808cc25ac5c7e6edfc46e344 goodreads-0.3.2.tar.gz
"