46 lines
1,006 B
Text
46 lines
1,006 B
Text
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
|
|
|
|
_pyname=facebook-sdk
|
|
pkgname="py3-$_pyname"
|
|
pkgver=3.1.0
|
|
pkgrel=0
|
|
arch="noarch"
|
|
pkgdesc="Python SDK for Facebook's Graph API"
|
|
url="https://pypi.python.org/project/$_pyname"
|
|
license="Apache-2.0"
|
|
depends="
|
|
py3-requests
|
|
"
|
|
makedepends="
|
|
py3-setuptools
|
|
py3-wheel
|
|
py3-gpep517
|
|
py3-installer
|
|
"
|
|
checkdepends="
|
|
py3-pytest
|
|
"
|
|
options="!check" # Testsuite requires API access
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/mobolic/facebook-sdk/archive/refs/tags/v$pkgver.tar.gz"
|
|
builddir="$srcdir"/$_pyname-$pkgver
|
|
subpackages="$pkgname-pyc"
|
|
|
|
build() {
|
|
gpep517 build-wheel \
|
|
--wheel-dir dist \
|
|
--output-fd 3 3>&1 >&2
|
|
}
|
|
|
|
check() {
|
|
pytest -v
|
|
}
|
|
|
|
package() {
|
|
python3 -m installer -d "$pkgdir" \
|
|
dist/*.whl
|
|
}
|
|
|
|
sha512sums="
|
|
90bb8242107ba37e0b3e05b91f2f8be07b359aa7c60646c1319f38a0ad910eb18b432af75515947109745539a6728b6571ceeb0239e8b94a669455d809cfab59 py3-facebook-sdk-3.1.0.tar.gz
|
|
"
|